summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2006-09-24 06:34:57 +0000
committerLuca Barbato <lu_zero@gentoo.org>2006-09-24 06:34:57 +0000
commite1dace38e1e3cee1cbfdfc73fba1c47a4b091764 (patch)
tree9c3b638932fbadcebb44bde3822fb83f683e2db4 /media-gfx/graphviz
parentAdded nofork patch as reported/requested by Dan Davis in bug #125700. (diff)
downloadgentoo-2-e1dace38e1e3cee1cbfdfc73fba1c47a4b091764.tar.gz
gentoo-2-e1dace38e1e3cee1cbfdfc73fba1c47a4b091764.tar.bz2
gentoo-2-e1dace38e1e3cee1cbfdfc73fba1c47a4b091764.zip
bug #142712 and bug #148733 fixed
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'media-gfx/graphviz')
-rw-r--r--media-gfx/graphviz/ChangeLog8
-rw-r--r--media-gfx/graphviz/files/digest-graphviz-2.8-r23
-rw-r--r--media-gfx/graphviz/graphviz-2.8-r2.ebuild96
3 files changed, 106 insertions, 1 deletions
diff --git a/media-gfx/graphviz/ChangeLog b/media-gfx/graphviz/ChangeLog
index 869c4c20644b..14b8017a2854 100644
--- a/media-gfx/graphviz/ChangeLog
+++ b/media-gfx/graphviz/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/graphviz
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/ChangeLog,v 1.91 2006/09/21 21:04:53 chrb Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/ChangeLog,v 1.92 2006/09/24 06:34:57 lu_zero Exp $
+
+*graphviz-2.8-r2 (24 Sep 2006)
+
+ 24 Sep 2006; Luca Barbato <lu_zero@gentoo.org> +graphviz-2.8-r2.ebuild:
+ fix libtool/autotools deps and language binding bug #142712 and bug #148733,
+ thanks to the respective reporters
*graphviz-2.8-r1 (21 Sep 2006)
diff --git a/media-gfx/graphviz/files/digest-graphviz-2.8-r2 b/media-gfx/graphviz/files/digest-graphviz-2.8-r2
new file mode 100644
index 000000000000..7b7f660f37dd
--- /dev/null
+++ b/media-gfx/graphviz/files/digest-graphviz-2.8-r2
@@ -0,0 +1,3 @@
+MD5 ca921b4a9bcd86da4a1092bb17a57d83 graphviz-2.8.tar.gz 4243130
+RMD160 d3b46e9777e9db5ead4fdf5274c6bd10823fe4cd graphviz-2.8.tar.gz 4243130
+SHA256 be0c4b7e49f7c226c68d54bb47018f3b3bfb51bb992f5ad71da875cad13367ca graphviz-2.8.tar.gz 4243130
diff --git a/media-gfx/graphviz/graphviz-2.8-r2.ebuild b/media-gfx/graphviz/graphviz-2.8-r2.ebuild
new file mode 100644
index 000000000000..bdc226cd5c91
--- /dev/null
+++ b/media-gfx/graphviz/graphviz-2.8-r2.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-2.8-r2.ebuild,v 1.1 2006/09/24 06:34:57 lu_zero Exp $
+
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=latest
+
+inherit eutils libtool autotools
+
+DESCRIPTION="Open Source Graph Visualization Software"
+HOMEPAGE="http://www.graphviz.org/"
+SRC_URI="http://www.graphviz.org/pub/graphviz/ARCHIVE/${P}.tar.gz"
+
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 hppa ia64 ppc ~ppc-macos ppc64 s390 sparc x86 ~x86-fbsd"
+IUSE="cairo tcltk X static minimal guile java lua perl php python ruby ocaml"
+
+RDEPEND=">=sys-libs/zlib-1.1.3
+ >=media-libs/libpng-1.2
+ >=media-libs/jpeg-6b
+ media-libs/gd
+ media-libs/freetype
+ media-libs/fontconfig
+ dev-libs/expat
+ sys-libs/zlib
+ tcltk? ( >=dev-lang/tk-8.3 >=dev-lang/tcl-8.3 )
+ cairo? ( >=x11-libs/libsvg-cairo-0.1.3 )
+ guile? ( dev-util/guile )
+ java? ( virtual/jdk )
+ perl? ( dev-lang/perl )
+ ocaml? ( dev-lang/ocaml )
+ lua? ( dev-lang/lua )
+ php? ( dev-lang/php )
+ python? ( dev-lang/python )
+ ruby? ( dev-lang/ruby )
+ X? ( || (
+ ( x11-libs/libXaw x11-libs/libXpm )
+ virtual/x11 )
+ )
+ sys-devel/libtool"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ !minimal? ( dev-lang/swig )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch ${FILESDIR}/${P}-notcl.patch || die "epatch failed"
+
+ elibtoolize
+ eautoreconf
+}
+
+src_compile() {
+ local my_conf
+ use minimal && my_conf="${my_conf} --disable-swig"
+ econf ${my_conf} \
+ --disable-dependency-tracking \
+ $(use_enable static) \
+ $(use_with tcltk tcl) \
+ $(use_with tcltk tk) \
+ $(use_enable guile) \
+ $(use_enable java) \
+ $(use_enable lua) \
+ $(use_enable ocaml) \
+ $(use_enable perl) \
+ $(use_enable php) \
+ $(use_enable python) \
+ $(use_enable ruby) \
+ --disable-{sharp,io} \
+ $(use_with X x) || die "Configure Failed!"
+
+ LC_ALL=C emake || die "Compile Failed!"
+}
+
+src_install() {
+ sed -i -e "s:htmldir:htmlinfodir:g" doc/info/Makefile
+ make DESTDIR="${D}" \
+ txtdir=/usr/share/doc/${PF} \
+ htmldir=/usr/share/doc/${PF}/html \
+ htmlinfodir=/usr/share/doc/${PF}/html/info \
+ pdfdir=/usr/share/doc/${PF}/pdf \
+ pkgconfigdir=/usr/$(get_libdir)/pkgconfig \
+ install || die "Install Failed!"
+ if use minimal ; then
+ rm -rf "${D}"usr/share/doc/${PF}/{pdf,html}
+ rm -rf "${D}"usr/$(get_libdir)/${PN}/{tcl,lua,perl,python,ruby}
+ fi
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ dot -c
+}