summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-04-26 07:27:51 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-04-26 07:27:51 +0000
commit232fda5c994fc5afd0b14984bac21e679d58c9ed (patch)
tree191ca4463aca1f7d3669e14cc865823f4e1e94cd /media-gfx/graphite2
parentVersion bump for dev channel release. Remove old. (diff)
downloadgentoo-2-232fda5c994fc5afd0b14984bac21e679d58c9ed.tar.gz
gentoo-2-232fda5c994fc5afd0b14984bac21e679d58c9ed.tar.bz2
gentoo-2-232fda5c994fc5afd0b14984bac21e679d58c9ed.zip
ppc stable wrt bug#411449.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/graphite2')
-rw-r--r--media-gfx/graphite2/ChangeLog7
-rw-r--r--media-gfx/graphite2/files/graphite2-includes-libs-perl.patch13
-rw-r--r--media-gfx/graphite2/graphite2-1.0.3-r1.ebuild95
-rw-r--r--media-gfx/graphite2/graphite2-1.1.1.ebuild4
4 files changed, 8 insertions, 111 deletions
diff --git a/media-gfx/graphite2/ChangeLog b/media-gfx/graphite2/ChangeLog
index 7eb249e2ef9a..692931e86b8a 100644
--- a/media-gfx/graphite2/ChangeLog
+++ b/media-gfx/graphite2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/graphite2
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphite2/ChangeLog,v 1.26 2012/04/23 10:53:44 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphite2/ChangeLog,v 1.27 2012/04/26 07:27:51 scarabeus Exp $
+
+ 26 Apr 2012; Tomáš Chvátal <scarabeus@gentoo.org>
+ -files/graphite2-includes-libs-perl.patch, -graphite2-1.0.3-r1.ebuild,
+ graphite2-1.1.1.ebuild:
+ ppc stable wrt bug#411449.
*graphite2-1.1.2 (23 Apr 2012)
diff --git a/media-gfx/graphite2/files/graphite2-includes-libs-perl.patch b/media-gfx/graphite2/files/graphite2-includes-libs-perl.patch
deleted file mode 100644
index eb3783b1dc7a..000000000000
--- a/media-gfx/graphite2/files/graphite2-includes-libs-perl.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- graphite2-0.9.3.orig/contrib/perl/Build.PL
-+++ graphite2-0.9.3/contrib/perl/Build.PL
-@@ -8,8 +8,8 @@ my $builder = Module::Build->new(
- dist_author => 'Simon Cozens <simon@cpan.org>',
- dist_version_from => 'lib/Text/Graphite2.pm',
- extra_compiler_flags => '-Wall -Wno-unused-variable',
-- extra_linker_flags => '-lgraphite2',
-- include_dirs => ['.'],
-+ extra_linker_flags => '-L @BUILD_DIR@ -lgraphite2',
-+ include_dirs => ['.', '../../include'],
- requires => {
- 'Test::More' => 0,
- },
diff --git a/media-gfx/graphite2/graphite2-1.0.3-r1.ebuild b/media-gfx/graphite2/graphite2-1.0.3-r1.ebuild
deleted file mode 100644
index a7b3acaa0a22..000000000000
--- a/media-gfx/graphite2/graphite2-1.0.3-r1.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphite2/graphite2-1.0.3-r1.ebuild,v 1.3 2011/12/18 20:42:45 halcy0n Exp $
-
-EAPI=4
-
-inherit base cmake-utils perl-module
-
-DESCRIPTION="Library providing rendering capabilities for complex non-Roman writing systems"
-HOMEPAGE="http://graphite.sil.org/"
-SRC_URI="mirror://sourceforge/silgraphite/${PN}/${P}.tgz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
-IUSE="perl test"
-
-RDEPEND="
- perl? ( dev-lang/perl )
-"
-DEPEND="${RDEPEND}
- perl? ( virtual/perl-Module-Build )
- test? (
- dev-libs/glib:2
- media-libs/fontconfig
- media-libs/silgraphite
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-includes-libs-perl.patch"
- "${FILESDIR}/${PN}-fix_wrong_linker_opts.patch"
- "${FILESDIR}/${PN}-1.0.2-no_harfbuzz_tests.patch"
- "${FILESDIR}/${PN}-1.0.3-no-test-binaries.patch"
-)
-
-pkg_setup() {
- use perl && perl-module_pkg_setup
-}
-
-src_prepare() {
- base_src_prepare
-
- # fix perl linking
- if use perl; then
- _check_build_dir init
- sed -i \
- -e "s:@BUILD_DIR@:\"${CMAKE_BUILD_DIR}/src\":" \
- contrib/perl/Build.PL || die
- fi
-
- # make tests optional
- if ! use test; then
- sed -i \
- -e '/tests/d' \
- CMakeLists.txt || die
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- "-DVM_MACHINE_TYPE=direct"
- )
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
- if use perl; then
- cd contrib/perl
- perl-module_src_prep
- perl-module_src_compile
- fi
-}
-
-src_test() {
- cmake-utils_src_test
- if use perl; then
- cd contrib/perl
- perl-module_src_test
- fi
-}
-
-src_install() {
- cmake-utils_src_install
- if use perl; then
- cd contrib/perl
- perl-module_src_install
- fixlocalpod
- fi
-
- find "${ED}" -name '*.la' -exec rm -f {} +
-
-}
diff --git a/media-gfx/graphite2/graphite2-1.1.1.ebuild b/media-gfx/graphite2/graphite2-1.1.1.ebuild
index b024f4daf538..d17e5a7cf8ea 100644
--- a/media-gfx/graphite2/graphite2-1.1.1.ebuild
+++ b/media-gfx/graphite2/graphite2-1.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphite2/graphite2-1.1.1.ebuild,v 1.2 2012/04/06 10:32:18 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphite2/graphite2-1.1.1.ebuild,v 1.3 2012/04/26 07:27:51 scarabeus Exp $
EAPI=4
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/silgraphite/${PN}/${P}.tgz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
IUSE="perl test"
RDEPEND="