summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-05-05 09:25:13 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-05-05 09:25:13 +0000
commitcb82adbef4253b4dd806fd9e209d58c1472f12eb (patch)
treec0c4fe36a9e5975deb275b235dfe33f9fe8fac2a /media-gfx/gnuplot
parentStable on x86 (Manifest recommit) (diff)
downloadgentoo-2-cb82adbef4253b4dd806fd9e209d58c1472f12eb.tar.gz
gentoo-2-cb82adbef4253b4dd806fd9e209d58c1472f12eb.tar.bz2
gentoo-2-cb82adbef4253b4dd806fd9e209d58c1472f12eb.zip
Added a patch for bug #49263 and corrected the header.
Diffstat (limited to 'media-gfx/gnuplot')
-rw-r--r--media-gfx/gnuplot/ChangeLog6
-rw-r--r--media-gfx/gnuplot/files/header-order.patch44
-rw-r--r--media-gfx/gnuplot/gnuplot-4.0.ebuild9
3 files changed, 58 insertions, 1 deletions
diff --git a/media-gfx/gnuplot/ChangeLog b/media-gfx/gnuplot/ChangeLog
index 13ed2c8f9d0d..6fee15154ea5 100644
--- a/media-gfx/gnuplot/ChangeLog
+++ b/media-gfx/gnuplot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/gnuplot
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnuplot/ChangeLog,v 1.21 2004/05/04 23:33:16 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnuplot/ChangeLog,v 1.22 2004/05/05 09:25:13 phosphan Exp $
+
+ 05 May 2004; Patrick Kursawe <phosphan@gentoo.org> gnuplot-4.0.ebuild,
+ files/header-order.patch:
+ Added a patch for bug #49263 and corrected the header.
05 May 2004; Bryan Østergaard <kloeri@gentoo.org> gnuplot-3.8j.ebuild:
Stable on alpha.
diff --git a/media-gfx/gnuplot/files/header-order.patch b/media-gfx/gnuplot/files/header-order.patch
new file mode 100644
index 000000000000..82ba590fcb2b
--- /dev/null
+++ b/media-gfx/gnuplot/files/header-order.patch
@@ -0,0 +1,44 @@
+--- src/term.h 2004-04-13 19:24:02.000000000 +0200
++++ src/term.h.new 2004-05-05 11:16:41.216200736 +0200
+@@ -270,6 +270,20 @@
+ /****************************************************************************/
+ /* These terminals can be used on any system */
+
++/* NOTE THAT PNG AND JPEG SUPPORT REQUIRE SEPARATE LIBRARIES */
++/* There are 2 flavors of PNG support */
++/* If you are using an old version of libgd in order to get true GIF support */
++/* then the best we can do is use a separate poor-quality PNG driver png.trm */
++/* But if you are using a newer libgd then it provides full blown support */
++/* for both PNG and JPEG in term/gd.trm */
++#ifdef HAVE_LIBPNG
++# if defined(HAVE_GD_PNG) || defined(HAVE_GD_JPEG)
++# include "gd.trm"
++# else
++# include "png.trm"
++# endif
++#endif
++
+ #ifdef X11
+ # include "x11.trm" /* X Window System */
+ # include "xlib.trm" /* dumps x11 commands to gpoutfile */
+@@ -351,20 +365,6 @@
+ # include "pdf.trm"
+ #endif
+
+-/* NOTE THAT PNG AND JPEG SUPPORT REQUIRE SEPARATE LIBRARIES */
+-/* There are 2 flavors of PNG support */
+-/* If you are using an old version of libgd in order to get true GIF support */
+-/* then the best we can do is use a separate poor-quality PNG driver png.trm */
+-/* But if you are using a newer libgd then it provides full blown support */
+-/* for both PNG and JPEG in term/gd.trm */
+-#ifdef HAVE_LIBPNG
+-# if defined(HAVE_GD_PNG) || defined(HAVE_GD_JPEG)
+-# include "gd.trm"
+-# else
+-# include "png.trm"
+-# endif
+-#endif
+-
+ /* postscript */
+ #include "post.trm"
+
diff --git a/media-gfx/gnuplot/gnuplot-4.0.ebuild b/media-gfx/gnuplot/gnuplot-4.0.ebuild
index dabe32deb8b3..db54bb78cfa0 100644
--- a/media-gfx/gnuplot/gnuplot-4.0.ebuild
+++ b/media-gfx/gnuplot/gnuplot-4.0.ebuild
@@ -1,5 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnuplot/gnuplot-4.0.ebuild,v 1.2 2004/05/05 09:25:13 phosphan Exp $
+
+inherit eutils
MY_P="${P}.0"
S=${WORKDIR}/${MY_P}
@@ -24,6 +27,12 @@ DEPEND="
readline? ( >=sys-libs/readline-4.2 )
plotutils? ( media-libs/plotutils )"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/header-order.patch
+}
+
src_compile() {
local myconf