summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-07 21:43:50 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-07 21:43:50 +0000
commitf9361784a66da95849d5b34cf0a77686b32be92f (patch)
treeb9eda72134eb76a0d62fac8a8fbb65bae7b1ca9e /media-gfx/gimp
parentFix use invocation (Manifest recommit) (diff)
downloadgentoo-2-f9361784a66da95849d5b34cf0a77686b32be92f.tar.gz
gentoo-2-f9361784a66da95849d5b34cf0a77686b32be92f.tar.bz2
gentoo-2-f9361784a66da95849d5b34cf0a77686b32be92f.zip
Fix use invocation
Diffstat (limited to 'media-gfx/gimp')
-rw-r--r--media-gfx/gimp/ChangeLog6
-rw-r--r--media-gfx/gimp/gimp-1.2.3-r3.ebuild22
-rw-r--r--media-gfx/gimp/gimp-1.2.4.ebuild4
-rw-r--r--media-gfx/gimp/gimp-1.2.5.ebuild4
4 files changed, 20 insertions, 16 deletions
diff --git a/media-gfx/gimp/ChangeLog b/media-gfx/gimp/ChangeLog
index f6affd8d5ad2..1f99993645d6 100644
--- a/media-gfx/gimp/ChangeLog
+++ b/media-gfx/gimp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/gimp
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/ChangeLog,v 1.80 2004/06/05 09:50:02 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/ChangeLog,v 1.81 2004/06/07 21:40:36 agriffis Exp $
+
+ 07 Jun 2004; Aron Griffis <agriffis@gentoo.org> gimp-1.2.3-r3.ebuild,
+ gimp-1.2.4.ebuild, gimp-1.2.5.ebuild:
+ Fix use invocation
05 Jun 2004; Bryan Østergaard <kloeri@gentoo.org> gimp-1.2.5.ebuild:
Stable on alpha.
diff --git a/media-gfx/gimp/gimp-1.2.3-r3.ebuild b/media-gfx/gimp/gimp-1.2.3-r3.ebuild
index 7a66c77b1270..f74fc7646db4 100644
--- a/media-gfx/gimp/gimp-1.2.3-r3.ebuild
+++ b/media-gfx/gimp/gimp-1.2.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.2.3-r3.ebuild,v 1.14 2004/01/30 05:52:20 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.2.3-r3.ebuild,v 1.15 2004/06/07 21:40:36 agriffis Exp $
inherit eutils flag-o-matic
@@ -27,7 +27,7 @@ DEPEND="nls? ( sys-devel/gettext )
${RDEPEND}"
src_unpack() {
- if [ "`use threads`" ]; then
+ if use threads; then
eerror "I'm sorry I can't build against a threaded perl,"
eerror "please remerge perl and libperl without"
eerror "'USE=threads' and try again. (Note: this message"
@@ -88,28 +88,28 @@ src_compile() {
local myconf=""
local mymake=""
local myvars=""
- if [ -z "`use nls`" ] ; then
+ if ! use nls ; then
myconf="${myconf} --disable-nls"
fi
- if [ -z "`use perl`" ] ; then
+ if ! use perl ; then
myconf="${myconf} --disable-perl"
else
export PERL_MM_OPT=' PREFIX=${D}/usr'
myconf="${myconf} --enable-perl"
fi
- if [ -z "`use python`" ] ; then
+ if ! use python ; then
myconf="${myconf} --disable-python"
else
myconf="${myconf} --enable-python"
fi
- if [ -z "`use aalib`" ] ; then
+ if ! use aalib ; then
mymake="LIBAA= AA="
fi
- if [ -z "`use gnome`" ] ; then
+ if ! use gnome ; then
mymake="${mymake} HELPBROWSER="
fi
@@ -119,7 +119,7 @@ src_compile() {
--disable-debug \
${myconf} || die
- if [ -z "`use aalib`" ] ; then
+ if ! use aalib ; then
# Horrible automake brokenness
cp plug-ins/common/Makefile plug-ins/common/Makefile.orig
cat plug-ins/common/Makefile.orig | \
@@ -134,11 +134,11 @@ src_compile() {
src_install() {
local mymake=""
- if [ -z "`use aalib`" ] ; then
+ if ! use aalib ; then
mymake="LIBAA= AA="
fi
- if [ -z "`use gnome`" ] ; then
+ if ! use gnome ; then
mymake="${mymake} HELPBROWSER="
fi
@@ -160,7 +160,7 @@ src_install() {
#this next line closes bug #810
dosym gimptool-1.2 /usr/bin/gimptool
- if [ "`use gnome`" ] && [ -d ${ROOT}/usr/share/applications ]
+ if use gnome && [ -d ${ROOT}/usr/share/applications ]
then
insinto /usr/share/applications
doins ${FILESDIR}/gimp.desktop
diff --git a/media-gfx/gimp/gimp-1.2.4.ebuild b/media-gfx/gimp/gimp-1.2.4.ebuild
index 3c72c097b150..1e938a61467a 100644
--- a/media-gfx/gimp/gimp-1.2.4.ebuild
+++ b/media-gfx/gimp/gimp-1.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.2.4.ebuild,v 1.12 2004/03/19 13:08:49 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.2.4.ebuild,v 1.13 2004/06/07 21:40:36 agriffis Exp $
inherit eutils flag-o-matic
@@ -65,7 +65,7 @@ src_compile() {
`use_enable doc gtk-doc` \
${myconf} || die
- if [ -z "`use aalib`" ] ; then
+ if ! use aalib ; then
# Horrible automake brokenness
cp plug-ins/common/Makefile plug-ins/common/Makefile.orig
cat plug-ins/common/Makefile.orig | \
diff --git a/media-gfx/gimp/gimp-1.2.5.ebuild b/media-gfx/gimp/gimp-1.2.5.ebuild
index 7a84eda2b8cd..c5ce2c92b130 100644
--- a/media-gfx/gimp/gimp-1.2.5.ebuild
+++ b/media-gfx/gimp/gimp-1.2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.2.5.ebuild,v 1.18 2004/06/05 09:50:02 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.2.5.ebuild,v 1.19 2004/06/07 21:40:36 agriffis Exp $
inherit eutils flag-o-matic
@@ -67,7 +67,7 @@ src_compile() {
`use_enable doc gtk-doc` \
${myconf} || die
- if [ -z "`use aalib`" ] ; then
+ if ! use aalib ; then
# Horrible automake brokenness
cp plug-ins/common/Makefile plug-ins/common/Makefile.orig
cat plug-ins/common/Makefile.orig | \