summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-02-15 19:07:09 +0000
committerMarinus Schraal <foser@gentoo.org>2004-02-15 19:07:09 +0000
commit6fbff67aaba6daf8aa33fd3a3d334c04dda29506 (patch)
treedfe492cfef142d12944fc9e4576900a5232b544d /media-gfx/gimp
parentheap overflow in mpg123, package masking for now (diff)
downloadgentoo-2-6fbff67aaba6daf8aa33fd3a3d334c04dda29506.tar.gz
gentoo-2-6fbff67aaba6daf8aa33fd3a3d334c04dda29506.tar.bz2
gentoo-2-6fbff67aaba6daf8aa33fd3a3d334c04dda29506.zip
add some fixes
Diffstat (limited to 'media-gfx/gimp')
-rw-r--r--media-gfx/gimp/ChangeLog8
-rw-r--r--media-gfx/gimp/files/digest-gimp-2.0_pre11
-rw-r--r--media-gfx/gimp/files/digest-gimp-2.0_pre3-r1 (renamed from media-gfx/gimp/files/digest-gimp-2.0_pre3)0
-rw-r--r--media-gfx/gimp/files/gimp-2.0_pre3-gcc_2.95.patch54
-rw-r--r--media-gfx/gimp/gimp-2.0_pre1.ebuild135
-rw-r--r--media-gfx/gimp/gimp-2.0_pre3-r1.ebuild (renamed from media-gfx/gimp/gimp-2.0_pre3.ebuild)20
6 files changed, 78 insertions, 140 deletions
diff --git a/media-gfx/gimp/ChangeLog b/media-gfx/gimp/ChangeLog
index b91138072f31..261cf9337a56 100644
--- a/media-gfx/gimp/ChangeLog
+++ b/media-gfx/gimp/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for media-gfx/gimp
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/ChangeLog,v 1.70 2004/02/11 23:24:39 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/ChangeLog,v 1.71 2004/02/15 19:07:09 foser Exp $
+*gimp-2.0_pre3-r1 (15 Feb 2004)
+
+ 15 Feb 2004; foser <foser@gentoo.org> gimp-2.0_pre3-r1.ebuild :
+ The return of the linking fix, which i was a bit too keen on removing (#38972)
+ Added gcc2 build fixes, reported by Tristan Henderson in #41487 with patch
+
*gimp-2.0_pre3 (12 Feb 2004)
12 Feb 2004; <spider@gentoo.org> gimp-2.0_pre3.ebuild:
diff --git a/media-gfx/gimp/files/digest-gimp-2.0_pre1 b/media-gfx/gimp/files/digest-gimp-2.0_pre1
deleted file mode 100644
index 8179f744ba6e..000000000000
--- a/media-gfx/gimp/files/digest-gimp-2.0_pre1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 7862920def4ee411f6417c9372753a6d gimp-2.0pre1.tar.bz2 12065700
diff --git a/media-gfx/gimp/files/digest-gimp-2.0_pre3 b/media-gfx/gimp/files/digest-gimp-2.0_pre3-r1
index 43568a17c2d3..43568a17c2d3 100644
--- a/media-gfx/gimp/files/digest-gimp-2.0_pre3
+++ b/media-gfx/gimp/files/digest-gimp-2.0_pre3-r1
diff --git a/media-gfx/gimp/files/gimp-2.0_pre3-gcc_2.95.patch b/media-gfx/gimp/files/gimp-2.0_pre3-gcc_2.95.patch
new file mode 100644
index 000000000000..c4e89dd94de3
--- /dev/null
+++ b/media-gfx/gimp/files/gimp-2.0_pre3-gcc_2.95.patch
@@ -0,0 +1,54 @@
+diff -Naur gimp-2.0pre3.orig/app/core/gimpchannel.c gimp-2.0pre3/app/core/gimpchannel.c
+--- gimp-2.0pre3.orig/app/core/gimpchannel.c 2004-02-03 16:53:08.000000000 -0500
++++ gimp-2.0pre3/app/core/gimpchannel.c 2004-02-13 10:44:09.000000000 -0500
+@@ -640,7 +640,7 @@
+ else if (GIMP_IS_PAINT_INFO (stroke_desc))
+ {
+ GimpImage *gimage = gimp_item_get_image (item);
+- GimpPaintInfo *paint_info = GIMP_PAINT_INFO (stroke_desc);;
++ GimpPaintInfo *paint_info = GIMP_PAINT_INFO (stroke_desc);
+ GimpPaintOptions *paint_options;
+ GimpPaintCore *core;
+
+diff -Naur gimp-2.0pre3.orig/app/tools/gimptexttool.c gimp-2.0pre3/app/tools/gimptexttool.c
+--- gimp-2.0pre3.orig/app/tools/gimptexttool.c 2004-02-03 16:53:10.000000000 -0500
++++ gimp-2.0pre3/app/tools/gimptexttool.c 2004-02-13 11:03:06.000000000 -0500
+@@ -187,7 +187,7 @@
+ GimpToolAction action,
+ GimpDisplay *gdisp)
+ {
+- GimpTextTool *text_tool = GIMP_TEXT_TOOL (tool);;
++ GimpTextTool *text_tool = GIMP_TEXT_TOOL (tool);
+
+ switch (action)
+ {
+@@ -218,7 +218,7 @@
+ GdkModifierType state,
+ GimpDisplay *gdisp)
+ {
+- GimpTextTool *text_tool = GIMP_TEXT_TOOL (tool);;
++ GimpTextTool *text_tool = GIMP_TEXT_TOOL (tool);
+ GimpDrawable *drawable;
+ GimpText *text = NULL;
+ gint off_x = 0;
+diff -Naur gimp-2.0pre3.orig/app/vectors/gimpvectors.c gimp-2.0pre3/app/vectors/gimpvectors.c
+--- gimp-2.0pre3.orig/app/vectors/gimpvectors.c 2004-02-03 16:53:10.000000000 -0500
++++ gimp-2.0pre3/app/vectors/gimpvectors.c 2004-02-13 11:02:34.000000000 -0500
+@@ -545,7 +545,7 @@
+ GimpObject *stroke_desc,
+ gboolean use_default_values)
+ {
+- GimpVectors *vectors = GIMP_VECTORS (item);;
++ GimpVectors *vectors = GIMP_VECTORS (item);
+ gboolean retval = FALSE;
+
+ if (! vectors->strokes)
+@@ -564,7 +564,7 @@
+ else if (GIMP_IS_PAINT_INFO (stroke_desc))
+ {
+ GimpImage *gimage = gimp_item_get_image (item);
+- GimpPaintInfo *paint_info = GIMP_PAINT_INFO (stroke_desc);;
++ GimpPaintInfo *paint_info = GIMP_PAINT_INFO (stroke_desc);
+ GimpPaintOptions *paint_options;
+ GimpPaintCore *core;
+
diff --git a/media-gfx/gimp/gimp-2.0_pre1.ebuild b/media-gfx/gimp/gimp-2.0_pre1.ebuild
deleted file mode 100644
index 8c5de995852d..000000000000
--- a/media-gfx/gimp/gimp-2.0_pre1.ebuild
+++ /dev/null
@@ -1,135 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-2.0_pre1.ebuild,v 1.3 2004/01/30 05:52:20 drobbins Exp $
-
-inherit debug flag-o-matic libtool
-
-MY_PV=${PV/_/}
-MY_P=${PN}-${MY_PV}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="GNU Image Manipulation Program - Development series"
-SRC_URI="mirror://gimp/v2.0/testing/${MY_P}.tar.bz2"
-HOMEPAGE="http://www.gimp.org/"
-
-SLOT="2"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~hppa ~sparc"
-IUSE="doc python aalib png jpeg tiff gtkhtml mmx sse X altivec"
-
-# protect against over optimisation (related to #21787)
-#replace-flags -Os -O2
-#MAKEOPTS="${MAKEOPTS} -j1"
-
-# FIXME : some more things can be (local) USE flagged
-# FIXME : printing needs to be re-enabled
-
-RDEPEND=">=dev-libs/glib-2.2
- >=x11-libs/gtk+-2.2.2
- >=x11-libs/pango-1.2.2
- >=media-libs/fontconfig-2.2
- >=media-libs/libart_lgpl-2.3.8-r1
- sys-libs/zlib
-
- gtkhtml? ( =gnome-extra/libgtkhtml-2* )
-
- png? ( >=media-libs/libpng-1.2.1 )
- jpeg? ( >=media-libs/jpeg-6b-r2
- media-libs/libexif )
- tiff? ( >=media-libs/tiff-3.5.7 )
-
- aalib? ( media-libs/aalib )
- python? ( >=dev-lang/python-2.2
- >=dev-python/pygtk-1.99.13 )
-
- X? ( virtual/x11 )"
-
-
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.12.0
- dev-util/intltool
- >=sys-devel/autoconf-2.58
- doc? ( >=dev-util/gtk-doc-1 )"
-# sys-devel/gettext
-
-# Attention : libtool hack not needed anymore it seems (testing)
-src_unpack() {
-
- unpack ${A}
- cd ${S}
- # Fix linking to older version of gimp if installed - this should
- # void liquidx's hack, so it is removed.
-# epatch ${FILESDIR}/ltmain_sh-1.5.0-fix-relink.patch
- # note: this make elibtoolize do some weird things, so disabling - liquidx
- # replace ltmain.sh from libtool 1.5a with libtool 1.4.x
- #cd ${S}; aclocal; automake; libtoolize --force; autoconf
-
- # fix problems with libtool-0.28 generated stuff
- intltoolize --force
-
- export WANT_AUTOMAKE=1.7
- export WANT_AUTOCONF=2.5
- aclocal || die
- autoconf || die
- automake -a || die
-
-}
-
-src_compile() {
-
- # Since 1.3.16, fixes linker problems when upgrading
- elibtoolize
-
- # Workaround portage variable leakage
- local AA=
- local myconf=
-
- replace-flags "-march=k6*" "-march=i586"
- # gimp uses inline functions (plug-ins/common/grid.c) (#23078)
- filter-flags "-fno-inline"
-
- econf ${myconf} \
- `use_enable mmx` \
- `use_enable sse` \
- `use_enable altivec` \
- `use_enable doc gtk-doc` \
- `use_enable python` \
- `use_with X x` \
- `use_with png libpng` \
- `use_with jpeg libjpeg` \
- `use_with jpeg libexif` \
- `use_with tiff libtiff` \
- `use_with aalib aa` \
- --enable-debug \
- --disable-print || die
-
- emake || die
-
-}
-
-src_install() {
-
- # Workaround portage variable leakage
- local AA=
-
- make DESTDIR=${D} install || die
-
- # Install desktop file in the right place
- insinto /usr/share/applications
- newins ${S}/data/misc/gimp.desktop gimp-${PV}.desktop
-
- dodoc AUTHORS COPYING ChangeL* HACKING INSTALL \
- MAINTAINERS NEWS PLUGIN_MAINTAINERS README* TODO*
-
-}
-
-pkg_postinst() {
-
- ewarn "The development Gimp series have been reslotted to SLOT 2"
- ewarn "To clean up old 1.3 versions use 'emerge -C =gimp-1.3* -vp'"
- echo ""
- ewarn "If you are upgrading from an earlier 1.3 release, please note that"
- ewarn "the gimprc and sessionrc file formats changed. We suggest you remove"
- ewarn "your personal ~/.gimp-1.3 directory and do a fresh user installation."
-
-}
diff --git a/media-gfx/gimp/gimp-2.0_pre3.ebuild b/media-gfx/gimp/gimp-2.0_pre3-r1.ebuild
index 1a32ef15c289..13df3accb374 100644
--- a/media-gfx/gimp/gimp-2.0_pre3.ebuild
+++ b/media-gfx/gimp/gimp-2.0_pre3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-2.0_pre3.ebuild,v 1.1 2004/02/11 23:24:40 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-2.0_pre3-r1.ebuild,v 1.1 2004/02/15 19:07:09 foser Exp $
inherit debug flag-o-matic libtool
@@ -39,7 +39,7 @@ RDEPEND=">=dev-libs/glib-2.2
aalib? ( media-libs/aalib )
python? ( >=dev-lang/python-2.2
- >=dev-python/pygtk-1.99.13 )
+ >=dev-python/pygtk-2 )
X? ( virtual/x11 )"
@@ -50,10 +50,24 @@ DEPEND="${RDEPEND}
doc? ( >=dev-util/gtk-doc-1 )"
# sys-devel/gettext
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ # Fix linking to older version of gimp if installed - this should
+ # void liquidx's hack, so it is removed.
+ epatch ${FILESDIR}/ltmain_sh-1.5.0-fix-relink.patch
+
+ # gcc2 fixes (#41487)
+ epatch ${FILESDIR}/${P}-gcc_2.95.patch
+
+}
+
src_compile() {
# Since 1.3.16, fixes linker problems when upgrading
- elibtoolize --reverse-deps
+ elibtoolize
# Workaround portage variable leakage
local AA=