summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2013-02-05 01:18:32 +0000
committerRyan Hill <dirtyepic@gentoo.org>2013-02-05 01:18:32 +0000
commit916fc9a71e6275e06799f1eeda13d9d973e545f6 (patch)
treeadcae8d104259a29c1d76b6c63f643b59073b1da /media-gfx/fontypython/fontypython-0.4.4.ebuild
parentkeyword ~arm (diff)
downloadgentoo-2-916fc9a71e6275e06799f1eeda13d9d973e545f6.tar.gz
gentoo-2-916fc9a71e6275e06799f1eeda13d9d973e545f6.tar.bz2
gentoo-2-916fc9a71e6275e06799f1eeda13d9d973e545f6.zip
Version bump. Drop python 2.5 support.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 957A8463)
Diffstat (limited to 'media-gfx/fontypython/fontypython-0.4.4.ebuild')
-rw-r--r--media-gfx/fontypython/fontypython-0.4.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-gfx/fontypython/fontypython-0.4.4.ebuild b/media-gfx/fontypython/fontypython-0.4.4.ebuild
new file mode 100644
index 000000000000..8e6f5cb3de4e
--- /dev/null
+++ b/media-gfx/fontypython/fontypython-0.4.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/fontypython/fontypython-0.4.4.ebuild,v 1.1 2013/02/05 01:18:32 dirtyepic Exp $
+
+EAPI="5"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-jython 2.7-pypy-*"
+
+inherit distutils multilib python
+
+DESCRIPTION="Font preview application"
+HOMEPAGE="http://savannah.nongnu.org/projects/fontypython"
+SRC_URI="http://download.savannah.nongnu.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Crashes w/ debug build of wxGTK (#201315)
+DEPEND="dev-python/imaging
+ dev-python/wxpython:2.8
+ x11-libs/wxGTK:2.8[-debug]"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="fontypythonmodules"
+
+src_install() {
+ distutils_src_install
+ doman "${S}"/fontypython.1
+}