summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-02-15 21:58:26 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-02-15 21:58:26 +0000
commit853877c22d38810b7d8713f8d3520f2686518ba6 (patch)
tree1ea38d9c297d4bcb4355698d702fd712ddb4da65 /media-gfx/feh
parentDrop unused LINGUAS. Bug #457550 (diff)
downloadgentoo-2-853877c22d38810b7d8713f8d3520f2686518ba6.tar.gz
gentoo-2-853877c22d38810b7d8713f8d3520f2686518ba6.tar.bz2
gentoo-2-853877c22d38810b7d8713f8d3520f2686518ba6.zip
Version bump
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'media-gfx/feh')
-rw-r--r--media-gfx/feh/ChangeLog7
-rw-r--r--media-gfx/feh/feh-2.9.1.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/media-gfx/feh/ChangeLog b/media-gfx/feh/ChangeLog
index a5d149a9e3dc..27b8aa0f62ac 100644
--- a/media-gfx/feh/ChangeLog
+++ b/media-gfx/feh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/feh
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/feh/ChangeLog,v 1.123 2013/02/15 02:25:35 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/feh/ChangeLog,v 1.124 2013/02/15 21:58:26 hwoarang Exp $
+
+*feh-2.9.1 (15 Feb 2013)
+
+ 15 Feb 2013; Markos Chandras <hwoarang@gentoo.org> +feh-2.9.1.ebuild:
+ Version bump
*feh-2.9 (15 Feb 2013)
diff --git a/media-gfx/feh/feh-2.9.1.ebuild b/media-gfx/feh/feh-2.9.1.ebuild
new file mode 100644
index 000000000000..f6d65900ce03
--- /dev/null
+++ b/media-gfx/feh/feh-2.9.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/feh/feh-2.9.1.ebuild,v 1.1 2013/02/15 21:58:26 hwoarang Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A fast, lightweight imageviewer using imlib2"
+HOMEPAGE="http://feh.finalrewind.org/"
+SRC_URI="http://feh.finalrewind.org/${P}.tar.bz2"
+
+LICENSE="feh"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="debug curl exif test xinerama"
+
+COMMON_DEPEND=">=media-libs/giblib-1.2.4
+ media-libs/imlib2
+ >=media-libs/libpng-1.2:0
+ x11-libs/libX11
+ curl? ( net-misc/curl )
+ exif? ( media-libs/libexif )
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND="${COMMON_DEPEND}
+ virtual/jpeg"
+DEPEND="${COMMON_DEPEND}
+ x11-libs/libXt
+ x11-proto/xproto
+ test? (
+ >=dev-lang/perl-5.10
+ dev-perl/Test-Command
+ )"
+
+pkg_setup() {
+ use_feh() { usex $1 1 0; }
+
+ fehopts=(
+ DESTDIR="${D}"
+ PREFIX=/usr
+ doc_dir='${main_dir}'/share/doc/${PF}
+ example_dir='${main_dir}'/share/doc/${PF}/examples
+ curl=$(use_feh curl)
+ debug=$(use_feh debug)
+ xinerama=$(use_feh xinerama)
+ exif=$(use_feh exif)
+ )
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.6.2-debug-cflags.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake "${fehopts[@]}"
+}
+
+src_install() {
+ emake "${fehopts[@]}" install
+}