summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2008-06-09 21:39:41 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2008-06-09 21:39:41 +0000
commit7ac29ad336024d2fea165364d46d2112ad250a44 (patch)
tree5bbaa7f5e50d0ac9a0af68212b5af8e8eb30bafb /media-gfx/exiv2
parentAdd cups-1.3.7-r2.ebuild, fixes glibc-2.8 compatibility bug #225421 and also ... (diff)
downloadgentoo-2-7ac29ad336024d2fea165364d46d2112ad250a44.tar.gz
gentoo-2-7ac29ad336024d2fea165364d46d2112ad250a44.tar.bz2
gentoo-2-7ac29ad336024d2fea165364d46d2112ad250a44.zip
version bump (see bug #225485).
(Portage version: 2.1.5.4)
Diffstat (limited to 'media-gfx/exiv2')
-rw-r--r--media-gfx/exiv2/ChangeLog7
-rw-r--r--media-gfx/exiv2/exiv2-0.17.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/media-gfx/exiv2/ChangeLog b/media-gfx/exiv2/ChangeLog
index 96b3a307d7fe..a1a369c040ac 100644
--- a/media-gfx/exiv2/ChangeLog
+++ b/media-gfx/exiv2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/exiv2
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/ChangeLog,v 1.45 2008/03/26 23:50:42 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/ChangeLog,v 1.46 2008/06/09 21:39:41 sbriesen Exp $
+
+*exiv2-0.17 (09 Jun 2008)
+
+ 09 Jun 2008; Stefan Briesenick <sbriesen@gentoo.org> +exiv2-0.17.ebuild:
+ version bump (see bug #225485).
26 Mar 2008; Stefan Briesenick <sbriesen@gentoo.org> -exiv2-0.13.ebuild,
-exiv2-0.13-r1.ebuild:
diff --git a/media-gfx/exiv2/exiv2-0.17.ebuild b/media-gfx/exiv2/exiv2-0.17.ebuild
new file mode 100644
index 000000000000..7780bd05cf8a
--- /dev/null
+++ b/media-gfx/exiv2/exiv2-0.17.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/exiv2-0.17.ebuild,v 1.1 2008/06/09 21:39:41 sbriesen Exp $
+
+inherit eutils
+
+DESCRIPTION="EXIF and IPTC metadata C++ library and command line utility"
+HOMEPAGE="http://www.exiv2.org/"
+SRC_URI="http://www.exiv2.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+
+IUSE="doc nls zlib xmp examples unicode"
+IUSE_LINGUAS="de es fi fr pl ru sk"
+
+for X in ${IUSE_LINGUAS}; do IUSE="${IUSE} linguas_${X}"; done
+
+RDEPEND="zlib? ( sys-libs/zlib )
+ xmp? ( dev-libs/expat )
+ nls? ( virtual/libintl )
+ virtual/libiconv"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use unicode; then
+ for i in doc/cmd.txt; do
+ echo ">>> Converting "${i}" to UTF-8"
+ iconv -f LATIN1 -t UTF-8 "${i}" > "${i}~" && mv -f "${i}~" "${i}" || rm -f "${i}~"
+ done
+ fi
+
+ if use doc; then
+ echo ">>> Updating doxygen config"
+ doxygen &>/dev/null -u config/Doxyfile
+ fi
+}
+
+src_compile() {
+ local myconf="$(use_enable nls) $(use_enable xmp)"
+ use zlib || myconf="${myconf} --without-zlib" # plain 'use_with' fails
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+ if use doc; then
+ emake doc || die "emake doc failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README doc/{ChangeLog,cmd.txt}
+ use xmp && dodoc doc/{COPYING-XMPSDK,README-XMP,cmdxmp.txt}
+ use doc && dohtml -r doc/html/.
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins samples/*.cpp
+ fi
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "PLEASE PLEASE take note of this:"
+ ewarn "Please make *sure* to run revdep-rebuild now"
+ ewarn "Certain things on your system may have linked against a"
+ ewarn "different version of exiv2 -- those things need to be"
+ ewarn "recompiled. Sorry for the inconvenience!"
+ ewarn
+}