summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-06-15 16:16:14 +0000
committerPacho Ramos <pacho@gentoo.org>2010-06-15 16:16:14 +0000
commitae7416ec5e9ebb6a2f7c7b1b66b3cb304380a639 (patch)
tree5fcb841e2ff6e74b1d2ba06251c44d8faf635606 /media-gfx/eog
parentVersion bump <http://my.opera.com/desktopteam/blog/2010/06/15/10-60-beta-rc>. (diff)
downloadgentoo-2-ae7416ec5e9ebb6a2f7c7b1b66b3cb304380a639.tar.gz
gentoo-2-ae7416ec5e9ebb6a2f7c7b1b66b3cb304380a639.tar.bz2
gentoo-2-ae7416ec5e9ebb6a2f7c7b1b66b3cb304380a639.zip
Add new version for Gnome 2.30. Also fix bug #319157
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/eog')
-rw-r--r--media-gfx/eog/ChangeLog10
-rw-r--r--media-gfx/eog/eog-2.30.1.ebuild67
-rw-r--r--media-gfx/eog/files/eog-2.30.1-libjpeg-configure.patch32
3 files changed, 108 insertions, 1 deletions
diff --git a/media-gfx/eog/ChangeLog b/media-gfx/eog/ChangeLog
index fd51d0931b4b..22e1e4adbd24 100644
--- a/media-gfx/eog/ChangeLog
+++ b/media-gfx/eog/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-gfx/eog
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/ChangeLog,v 1.258 2010/06/04 20:36:45 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/ChangeLog,v 1.259 2010/06/15 16:16:14 pacho Exp $
+
+*eog-2.30.1 (15 Jun 2010)
+
+ 15 Jun 2010; Pacho Ramos <pacho@gentoo.org> +eog-2.30.1.ebuild,
+ +files/eog-2.30.1-libjpeg-configure.patch:
+ Add new version for Gnome 2.30. Also fix bug #319157 with upstream patch
+ (by Claudio Saavedra). Thanks to Roelof Wobben, Jacob Swanson and other
+ people involved in that bug report.
04 Jun 2010; Markus Meier <maekke@gentoo.org> eog-2.28.2.ebuild:
x86 stable, bug #314899
diff --git a/media-gfx/eog/eog-2.30.1.ebuild b/media-gfx/eog/eog-2.30.1.ebuild
new file mode 100644
index 000000000000..e9d768c3faf1
--- /dev/null
+++ b/media-gfx/eog/eog-2.30.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-2.30.1.ebuild,v 1.1 2010/06/15 16:16:14 pacho Exp $
+
+EAPI=2
+
+inherit eutils gnome2 autotools
+
+DESCRIPTION="The Eye of GNOME image viewer"
+HOMEPAGE="http://www.gnome.org/projects/eog/"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="dbus doc exif jpeg lcms python tiff xmp"
+
+RDEPEND=">=x11-libs/gtk+-2.17.5
+ >=dev-libs/glib-2.15.3
+ >=dev-libs/libxml2-2
+ >=gnome-base/gconf-2.5.90
+ >=gnome-base/gnome-desktop-2.25.1
+ >=x11-themes/gnome-icon-theme-2.19.1
+ >=x11-misc/shared-mime-info-0.20
+
+ dbus? ( >=dev-libs/dbus-glib-0.71 )
+ exif? (
+ >=media-libs/libexif-0.6.14
+ media-libs/jpeg )
+ jpeg? ( media-libs/jpeg
+ x11-libs/gtk+[jpeg] )
+ lcms? ( media-libs/lcms )
+ python? (
+ >=dev-lang/python-2.3
+ >=dev-python/pygobject-2.15.1
+ >=dev-python/pygtk-2.13 )
+ tiff? ( >=x11-libs/gtk+-2.15.1[tiff] )
+ xmp? ( >=media-libs/exempi-2 )"
+
+DEPEND="${RDEPEND}
+ app-text/gnome-doc-utils
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.17
+ doc? ( >=dev-util/gtk-doc-1.10 )"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README THANKS TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_with jpeg libjpeg)
+ $(use_with exif libexif)
+ $(use_with dbus)
+ $(use_with lcms cms)
+ $(use_enable python)
+ $(use_with xmp)
+ --disable-scrollkeeper
+ --disable-schemas-install"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix build without libjpeg, bug #319157
+ epatch "${FILESDIR}/${P}-libjpeg-configure.patch"
+
+ eautoreconf
+}
diff --git a/media-gfx/eog/files/eog-2.30.1-libjpeg-configure.patch b/media-gfx/eog/files/eog-2.30.1-libjpeg-configure.patch
new file mode 100644
index 000000000000..97ab0c5d2674
--- /dev/null
+++ b/media-gfx/eog/files/eog-2.30.1-libjpeg-configure.patch
@@ -0,0 +1,32 @@
+From d44efad798c313288f4b136b08e88ad580880673 Mon Sep 17 00:00:00 2001
+From: Claudio Saavedra <csaavedra@igalia.com>
+Date: Tue, 15 Jun 2010 15:47:18 +0000
+Subject: Fix build without libjpeg
+
+AM_CONDITIONAL calls should be called always, otherwise configure
+gets confused.
+
+Fixes bug #621616.
+---
+diff --git a/configure.ac b/configure.ac
+index 3631dd7..8f1e713 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -227,7 +227,6 @@ int main(int c, char**v) { return 0; }
+ have_libjpeg_80=yes],
+ [AC_MSG_RESULT(no)
+ have_libjpeg_80=no])
+- AM_CONDITIONAL(HAVE_LIBJPEG_80, test "x$have_libjpeg_80" = xyes)
+
+ else
+ AC_MSG_WARN(*** JPEG loader will not be built (JPEG header file not found) ***)
+@@ -243,6 +242,7 @@ int main(int c, char**v) { return 0; }
+ fi
+ AC_SUBST(LIBJPEG)
+ AM_CONDITIONAL(ENABLE_JPEG, test x$have_jpeg = xyes)
++AM_CONDITIONAL(HAVE_LIBJPEG_80, test "x$have_libjpeg_80" = xyes)
+
+ # ****************
+ # D-Bus activation
+--
+cgit v0.8.3.1