summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2012-02-12 15:57:12 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2012-02-12 15:57:12 +0000
commit4bc14f21adcc212c3bedb9eede8d7c546aad7aaf (patch)
treeebfa44e99568bc2b4ed2d6993fbcc57237e0ba45 /media-gfx/digikam
parentVersion bump. Translation updates. (diff)
downloadgentoo-2-4bc14f21adcc212c3bedb9eede8d7c546aad7aaf.tar.gz
gentoo-2-4bc14f21adcc212c3bedb9eede8d7c546aad7aaf.tar.bz2
gentoo-2-4bc14f21adcc212c3bedb9eede8d7c546aad7aaf.zip
Add compatibility patch for Boost 1.48, bug 399727
(Portage version: 2.1.10.45/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/digikam')
-rw-r--r--media-gfx/digikam/ChangeLog6
-rw-r--r--media-gfx/digikam/digikam-2.5.0.ebuild7
-rw-r--r--media-gfx/digikam/files/digikam-2.5.0-boost148.patch74
3 files changed, 84 insertions, 3 deletions
diff --git a/media-gfx/digikam/ChangeLog b/media-gfx/digikam/ChangeLog
index cafd041ec902..47e6488c75c3 100644
--- a/media-gfx/digikam/ChangeLog
+++ b/media-gfx/digikam/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/digikam
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/digikam/ChangeLog,v 1.211 2012/02/12 15:47:41 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/digikam/ChangeLog,v 1.212 2012/02/12 15:57:12 dilfridge Exp $
+
+ 12 Feb 2012; Andreas K. Huettel <dilfridge@gentoo.org> digikam-2.5.0.ebuild,
+ +files/digikam-2.5.0-boost148.patch:
+ Add compatibility patch for Boost 1.48, bug 399727
12 Feb 2012; Andreas K. Huettel <dilfridge@gentoo.org> digikam-2.5.0.ebuild:
Install handbooks, bug 338757
diff --git a/media-gfx/digikam/digikam-2.5.0.ebuild b/media-gfx/digikam/digikam-2.5.0.ebuild
index 54091bd8ad4d..460b75b9e160 100644
--- a/media-gfx/digikam/digikam-2.5.0.ebuild
+++ b/media-gfx/digikam/digikam-2.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/digikam/digikam-2.5.0.ebuild,v 1.2 2012/02/12 15:47:41 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/digikam/digikam-2.5.0.ebuild,v 1.3 2012/02/12 15:57:12 dilfridge Exp $
EAPI=4
@@ -72,7 +72,10 @@ S="${WORKDIR}/${MY_P}/core"
RESTRICT=test
# bug 366505
-PATCHES=( "${FILESDIR}/${P}-libkipi.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-libkipi.patch"
+ "${FILESDIR}/${P}-boost148.patch"
+)
src_prepare() {
# just to make absolutely sure
diff --git a/media-gfx/digikam/files/digikam-2.5.0-boost148.patch b/media-gfx/digikam/files/digikam-2.5.0-boost148.patch
new file mode 100644
index 000000000000..81198397ab80
--- /dev/null
+++ b/media-gfx/digikam/files/digikam-2.5.0-boost148.patch
@@ -0,0 +1,74 @@
+commit d18ea6da2d3e2359f4113e83c3fd40c18a29ddab
+Author: Gilles Caulier <caulier.gilles@gmail.com>
+Date: Fri Jan 6 11:23:48 2012 +0100
+
+ Apply patch #67483 from Jeremiah Willcock to compile fine digiKam boost graph interface with libboost 1.48
+ BUGS: 287772
+ CCBUGS: 267777
+
+diff --git a/libs/database/imagehistory/imagehistorygraph_boost.h b/libs/database/imagehistory/imagehistorygraph_boost.h
+index 4017c4f..76c764a 100644
+--- a/libs/database/imagehistory/imagehistorygraph_boost.h
++++ b/libs/database/imagehistory/imagehistorygraph_boost.h
+@@ -1198,7 +1198,7 @@ protected:
+ {
+ boost::dag_shortest_paths(graph, v,
+ // we provide a constant weight of 1
+- weight_map(boost::ref_property_map<edge_t,int>(weight)).
++ weight_map(boost::ref_property_map<typename boost::graph_traits<GraphType>::edge_descriptor,int>(weight)).
+ // Store distance and predecessors in QMaps, wrapped to serve as property maps
+ distance_map(VertexIntMapAdaptor(distances)).
+ predecessor_map(VertexVertexMapAdaptor(predecessors))
+@@ -1218,7 +1218,7 @@ protected:
+ {
+ boost::dag_shortest_paths(graph, v,
+ // we provide a constant weight of 1
+- weight_map(boost::ref_property_map<edge_t,int>(weight)).
++ weight_map(boost::ref_property_map<typename boost::graph_traits<GraphType>::edge_descriptor,int>(weight)).
+ // Invert the default compare method: With greater, we get the longest path
+ distance_compare(std::greater<int>()).
+ // will be returned if a node is unreachable
+@@ -1384,14 +1384,15 @@ protected:
+ template <class GraphType, typename VertexLessThan>
+ class lessThanMapEdgeToTarget
+ {
++ typedef typename boost::graph_traits<GraphType>::edge_descriptor edge_descriptor;
+ public:
+ lessThanMapEdgeToTarget(const GraphType& g, VertexLessThan vertexLessThan)
+ : g(g), vertexLessThan(vertexLessThan) {}
+ const GraphType& g;
+ VertexLessThan vertexLessThan;
+- bool operator()(const Edge& a, const Edge& b)
++ bool operator()(const edge_descriptor& a, const edge_descriptor& b)
+ {
+- return vertexLessThan(boost::target(a.toEdge(), g), boost::target(b.toEdge(), g));
++ return vertexLessThan(boost::target(a, g), boost::target(b, g));
+ }
+ };
+
+@@ -1402,20 +1403,21 @@ protected:
+ {
+ typedef std::pair<Vertex, QList<Edge> > VertexInfo;
+
+- QList<Edge> outEdges;
++ typedef typename boost::graph_traits<IncidenceGraph>::edge_descriptor edge_descriptor;
++ QList<edge_descriptor> outEdges;
+ std::vector<VertexInfo> stack;
+
+ boost::put(color, u, boost::gray_color);
+ vis.discover_vertex(u, g);
+
+- outEdges = toEdgeList(boost::out_edges(u, g));
++ outEdges = toList<edge_descriptor>(boost::out_edges(u, g));
+ // Sort edges. The lessThan we have takes vertices, so we use a lessThan which
+ // maps the given edges to their targets, and calls our vertex lessThan.
+ qSort(outEdges.begin(), outEdges.end(), lessThanMapEdgeToTarget<IncidenceGraph, LessThan>(g, lessThan));
+
+- foreach(const Edge& e, outEdges)
++ foreach(const edge_descriptor& e, outEdges)
+ {
+- Vertex v = boost::target(e.toEdge(), g);
++ Vertex v = boost::target(e, g);
+ vis.examine_edge(e, g);
+ boost::default_color_type v_color = boost::get(color, v);
+ if (v_color == boost::white_color)