summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-05-20 22:29:03 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-05-20 22:29:03 +0000
commit2b44845bdbc08b14c70f0ef01065662fe41dc43b (patch)
tree45a30159188a37923530b17c95c2c804766b16e5 /media-gfx/digikam/files
parentInitial import (diff)
downloadgentoo-2-2b44845bdbc08b14c70f0ef01065662fe41dc43b.tar.gz
gentoo-2-2b44845bdbc08b14c70f0ef01065662fe41dc43b.tar.bz2
gentoo-2-2b44845bdbc08b14c70f0ef01065662fe41dc43b.zip
Backport build fix for libjpeg-turbo
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/digikam/files')
-rw-r--r--media-gfx/digikam/files/digikam-1.9.0-turbo.patch56
1 files changed, 56 insertions, 0 deletions
diff --git a/media-gfx/digikam/files/digikam-1.9.0-turbo.patch b/media-gfx/digikam/files/digikam-1.9.0-turbo.patch
new file mode 100644
index 000000000000..bd105529b0bd
--- /dev/null
+++ b/media-gfx/digikam/files/digikam-1.9.0-turbo.patch
@@ -0,0 +1,56 @@
+From 1ad9ae102ea1a82a72e31401fe840954a791219f Mon Sep 17 00:00:00 2001
+From: Riccardo Iaconelli <riccardo@kde.org>
+Date: Sun, 15 May 2011 16:18:44 +0200
+Subject: [PATCH] Don't fail CMake check: compile with libjpeg-turbo
+
+Patch by Rex Dieter
+
+BUG: 265431
+
+Signed-off-by: Riccardo Iaconelli <riccardo@kde.org>
+---
+ CMakeLists.txt | 28 +++++++++++++++++-----------
+ 1 files changed, 17 insertions(+), 11 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 43293ef..63402e9 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -166,17 +166,23 @@ ELSE(NOT APPLE)
+ SET(CLAPACK_FOUND FALSE)
+ ENDIF(NOT APPLE)
+
+-# Extract version of libjpeg so that we can use the appropriate dir
+-# See bug #227313, #228483
+-FILE(READ "${JPEG_INCLUDE_DIR}/jpeglib.h" jpeglib_h_content)
+-STRING(REGEX REPLACE ".*#define +JPEG_LIB_VERSION +([0-9]+).*" "\\1" jpeglib_version "${jpeglib_h_content}")
+-MESSAGE(STATUS "Identified libjpeg version: ${jpeglib_version}")
+-
+-IF ("${jpeglib_version}" LESS 80)
+- SET(DIGIKAM_LIBJPEG_DIR libjpeg-62)
+-ELSE ("${jpeglib_version}" LESS 80)
+- SET(DIGIKAM_LIBJPEG_DIR libjpeg-80)
+-ENDIF ("${jpeglib_version}" LESS 80)
++# check version of libjpeg so that we can use the appropriate dir
++# See bug #227313
++set(_jpeglib_version_source "#include <stddef.h>\n#include<stdio.h>\n#include <jpeglib.h>\n int main()\n {\n #if (JPEG_LIB_VERSION >= 80) \n #error JPEG_LIB_VERSION >= 80 found \n #endif \n }\n")
++set(_jpeglib_version_source_file ${CMAKE_BINARY_DIR}/CMakeTmp/cmake_jpeglib_version_check.cpp)
++file(WRITE "${_jpeglib_version_source_file}" "${_jpeglib_version_source}")
++set(_jpeglib_version_include_dirs "-DINCLUDE_DIRECTORIES:STRING=${JPEG_INCLUDE_DIR}")
++
++try_compile(_jpeglib_version_compile_result ${CMAKE_BINARY_DIR} ${_jpeglib_version_source_file} CMAKE_FLAGS "${_jpeglib_version_include_dirs}" COMPILE_OUTPUT_VARIABLE _jpeglib_version_compile_output_var)
++
++if(_jpeglib_version_compile_result)
++MESSAGE(STATUS "Identified libjpeg version: 62")
++set(DIGIKAM_LIBJPEG_DIR libjpeg-62)
++else(_jpeglib_version_compile_result)
++MESSAGE(STATUS "Identified libjpeg version: 80+")
++set(DIGIKAM_LIBJPEG_DIR libjpeg-80)
++endif(_jpeglib_version_compile_result)
++
+
+ IF (ENABLE_INTERNALMYSQL)
+ # Check MySQL executables
+--
+1.7.3.4
+