summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-08-26 19:46:48 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-08-26 19:46:48 +0000
commit088ad0927f638fd4cd953dcee68a017643493ede (patch)
tree49b42f0a064363ec9e349bc0f1206c1f09450081 /media-gfx/digikam/files
parentChanges to DEPEND wrt bug #380501 thanks to Michael. Added fix for prefix wrt... (diff)
downloadgentoo-2-088ad0927f638fd4cd953dcee68a017643493ede.tar.gz
gentoo-2-088ad0927f638fd4cd953dcee68a017643493ede.tar.bz2
gentoo-2-088ad0927f638fd4cd953dcee68a017643493ede.zip
Fix underlinking and library linking order. Fixes bug 380687, revbump because it might also be related to bug 380287
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/digikam/files')
-rw-r--r--media-gfx/digikam/files/digikam-2.0.0-underlinking.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-gfx/digikam/files/digikam-2.0.0-underlinking.patch b/media-gfx/digikam/files/digikam-2.0.0-underlinking.patch
new file mode 100644
index 000000000000..a5f05e08d3ce
--- /dev/null
+++ b/media-gfx/digikam/files/digikam-2.0.0-underlinking.patch
@@ -0,0 +1,29 @@
+commit 772f592f639f52d0c1a991265098b46672fecb6e
+Author: Gilles Caulier <caulier.gilles@gmail.com>
+Date: Fri Aug 26 11:58:59 2011 +0200
+
+ Fix order to link gphoto2 library with digiKam shared lib. This must be the last on linker command line...
+ CCBUGS: 258931
+ CCBUGS: 268267
+
+diff --git a/digikam/CMakeLists.txt b/digikam/CMakeLists.txt
+index 42017df..78ca1f1 100644
+--- a/digikam/CMakeLists.txt
++++ b/digikam/CMakeLists.txt
+@@ -279,13 +279,15 @@ TARGET_LINK_LIBRARIES(digikam
+
+ ${STRIGI_LIBRARIES}
+ ${LCMS_LIBRARIES}
+- ${GPHOTO2_LIBRARIES}
+
+ digikamcore
+ digikamdatabase
+ advancedrename
+ queuemanager
+ cameragui
++
++ # See B.K.O #258931: libgphoto2 library must be the last arg for linker.
++ ${GPHOTO2_LIBRARIES}
+ )
+
+ IF (NOT WIN32 AND GPHOTO2_FOUND)