summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-06-11 08:56:10 +0000
committerMichael Weber <xmw@gentoo.org>2012-06-11 08:56:10 +0000
commitc3592f3079406d318720851d0fbc08a469de5847 (patch)
treea37ce9f04b36ed8884a5f1679cf724e4c51c49ae /media-gfx/dcraw
parentThe patch is actually no longer required. I should rather cp from overlay whe... (diff)
downloadgentoo-2-c3592f3079406d318720851d0fbc08a469de5847.tar.gz
gentoo-2-c3592f3079406d318720851d0fbc08a469de5847.tar.bz2
gentoo-2-c3592f3079406d318720851d0fbc08a469de5847.zip
Version bump (bug 398085 by Gian), non-maint commit.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/dcraw')
-rw-r--r--media-gfx/dcraw/ChangeLog7
-rw-r--r--media-gfx/dcraw/dcraw-9.12.ebuild125
2 files changed, 131 insertions, 1 deletions
diff --git a/media-gfx/dcraw/ChangeLog b/media-gfx/dcraw/ChangeLog
index 2bde5b5aad35..9b896ca5bb95 100644
--- a/media-gfx/dcraw/ChangeLog
+++ b/media-gfx/dcraw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/dcraw
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/dcraw/ChangeLog,v 1.83 2012/05/05 07:00:19 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/dcraw/ChangeLog,v 1.84 2012/06/11 08:56:10 xmw Exp $
+
+*dcraw-9.12 (11 Jun 2012)
+
+ 11 Jun 2012; Michael Weber <xmw@gentoo.org> +dcraw-9.12.ebuild:
+ Version bump (bug 398085 by Gian), non-maint commit.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> dcraw-9.05.ebuild,
dcraw-9.10.ebuild:
diff --git a/media-gfx/dcraw/dcraw-9.12.ebuild b/media-gfx/dcraw/dcraw-9.12.ebuild
new file mode 100644
index 000000000000..463f4408c2ea
--- /dev/null
+++ b/media-gfx/dcraw/dcraw-9.12.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/dcraw/dcraw-9.12.ebuild,v 1.1 2012/06/11 08:56:10 xmw Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Converts the native (RAW) format of various digital cameras into netpbm portable pixmap (.ppm) image"
+HOMEPAGE="http://www.cybercom.net/~dcoffin/dcraw/"
+SRC_URI="http://www.cybercom.net/~dcoffin/dcraw/archive/${P}.tar.gz
+ mirror://gentoo/parse-1.73.tar.bz2
+ gimp? ( mirror://gentoo/rawphoto-1.32.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="nls gimp jpeg jpeg2k lcms"
+
+COMMON_DEPEND="jpeg? ( virtual/jpeg )
+ lcms? ( =media-libs/lcms-1* )
+ jpeg2k? ( media-libs/jasper )
+ gimp? ( media-gfx/gimp )"
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )
+ gimp? ( virtual/pkgconfig )"
+RDEPEND="${COMMON_DEPEND}
+ media-libs/netpbm"
+
+S=${WORKDIR}/dcraw
+
+LANGS="ca cs de da eo es fr hu it nl pl pt ru sv zh_CN zh_TW"
+
+for lng in ${LANGS}; do
+ IUSE+=" linguas_${lng}"
+done
+
+# Helper function to list only langs listed in LANGS or
+linguas_list() {
+ local nolangs=true
+ for lng in ${LANGS}; do
+ if use linguas_${lng}; then
+ nolangs=false
+ echo " ${lng}"
+ fi
+ done
+ if ${nolangs}; then
+ echo ${LANGS}
+ fi
+}
+
+run_build() {
+ einfo "${@}"
+ ${@} || die
+}
+
+src_prepare() {
+ rename dcraw_ dcraw. dcraw_*.1 || die "Failed to rename"
+}
+
+src_compile() {
+ local ECFLAGS="-O2" # Without optimisation build fails
+ local ELIBS="-lm"
+
+ use lcms && ELIBS="-llcms ${ELIBS}" || ECFLAGS+=" -DNO_LCMS=yes"
+ use jpeg && ELIBS="-ljpeg ${ELIBS}" || ECFLAGS+=" -DNO_JPEG=yes"
+ use jpeg2k && ELIBS="-ljasper ${ELIBS}" || ECFLAGS+=" -DNO_JASPER=yes"
+ use nls && ECFLAGS+=" -DLOCALEDIR=\"/usr/share/locale/\""
+
+ run_build $(tc-getCC) ${ECFLAGS} ${CFLAGS} ${LDFLAGS} \
+ -o dcraw dcraw.c ${ELIBS}
+
+ run_build $(tc-getCC) -O2 ${CFLAGS} ${LDFLAGS} \
+ -o dcparse parse.c
+
+ # rawphoto gimp plugin
+ if use gimp; then
+ run_build $(tc-getCC) ${CFLAGS} ${LDFLAGS} \
+ $(pkg-config --cflags gimpui-2.0) rawphoto.c -o rawphoto \
+ $(pkg-config --libs gimpui-2.0)
+ fi
+
+ if use nls; then
+ for lng in $(linguas_list); do
+ run_build msgfmt -c -o dcraw_${lng}.mo dcraw_${lng}.po
+ done
+ fi
+}
+
+src_install() {
+ dobin dcraw dcparse || die
+ dodoc "${FILESDIR}"/{conversion-examples.txt,dcwrap} || die
+
+ # rawphoto gimp plugin
+ if use gimp; then
+ insinto "$(pkg-config --variable=gimplibdir gimp-2.0)/plug-ins"
+ insopts -m0755
+ doins rawphoto || die
+ fi
+
+ doman dcraw.1 || die
+ if use nls; then
+ for lng in $(linguas_list); do
+ [[ -f dcraw.${lng}.1 ]] && doman dcraw.${lng}.1
+ insinto /usr/share/locale/${lng}/LC_MESSAGES
+ newins dcraw_${lng}.mo dcraw.mo || die "failed to install dcraw_${lng}.mo"
+ done
+ fi
+}
+
+pkg_postinst() {
+ elog ""
+ elog "See conversion-examples.txt.gz on how to convert"
+ elog "the PPM files produced by dcraw to other image formats."
+ elog ""
+ ewarn "The functionality of the external program 'fujiturn' was"
+ ewarn "incorporated into dcraw and is automatically used now."
+ elog ""
+ elog "There's an example wrapper script included called 'dcwrap'."
+ elog ""
+ elog "This package also includes 'dcparse', which extracts"
+ elog "thumbnail images (preferably JPEGs) from any raw digital"
+ elog "camera formats that have them, and shows table contents."
+ elog ""
+}