summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-08-21 23:13:29 +0000
committerMichael Januszewski <spock@gentoo.org>2004-08-21 23:13:29 +0000
commit52a1b1f95ad56d491d03891d9cdd708f1bf13fcf (patch)
tree659df1fe21bfb81a4a056771dc8f103d4616b2dc /media-gfx/bootsplash
parentbump, fixed amd64 issue with resolver lib, marked ~amd64, closes #54024 (Mani... (diff)
downloadgentoo-2-52a1b1f95ad56d491d03891d9cdd708f1bf13fcf.tar.gz
gentoo-2-52a1b1f95ad56d491d03891d9cdd708f1bf13fcf.tar.bz2
gentoo-2-52a1b1f95ad56d491d03891d9cdd708f1bf13fcf.zip
Added a patch for 2.6.8.1.
Diffstat (limited to 'media-gfx/bootsplash')
-rw-r--r--media-gfx/bootsplash/ChangeLog8
-rw-r--r--media-gfx/bootsplash/bootsplash-0.6.1-r6.ebuild107
-rw-r--r--media-gfx/bootsplash/files/digest-bootsplash-0.6.1-r63
3 files changed, 117 insertions, 1 deletions
diff --git a/media-gfx/bootsplash/ChangeLog b/media-gfx/bootsplash/ChangeLog
index f8fd134e61f5..d462239204d4 100644
--- a/media-gfx/bootsplash/ChangeLog
+++ b/media-gfx/bootsplash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/bootsplash
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash/ChangeLog,v 1.51 2004/08/06 10:45:18 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash/ChangeLog,v 1.52 2004/08/21 23:13:29 spock Exp $
+
+*bootsplash-0.6.1-r6 (22 Aug 2004)
+
+ 22 Aug 2004; Michal Januszewski <spock@gentoo.org>
+ +bootsplash-0.6.1-r6.ebuild:
+ Added a patch for 2.6.8.1. Closed bug #58544.
*bootsplash-0.6.1-r5 (06 Aug 2004)
diff --git a/media-gfx/bootsplash/bootsplash-0.6.1-r6.ebuild b/media-gfx/bootsplash/bootsplash-0.6.1-r6.ebuild
new file mode 100644
index 000000000000..dcd1c1f6e0a6
--- /dev/null
+++ b/media-gfx/bootsplash/bootsplash-0.6.1-r6.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash/bootsplash-0.6.1-r6.ebuild,v 1.1 2004/08/21 23:13:29 spock Exp $
+
+IUSE=""
+S=${WORKDIR}
+DESCRIPTION="Graphical backgrounds for frame buffer consoles"
+HOMEPAGE="http://www.bootsplash.org/ http://linux.tkdack.com/"
+SRC_URI="mirror://gentoo/${PN}-core-0.6.1-r6.tar.bz2
+ mirror://gentoo/${PN}-themes-0.6.1.tar.bz2
+ mirror://gentoo/${PN}-kernel-0.6.1-r6.tar.bz2"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+DEPEND=">=media-libs/freetype-2
+ media-libs/libmng
+ media-libs/lcms
+ !media-gfx/splashutils"
+
+src_compile() {
+ # compile utils
+ # the util builds but the rc scripts have not been modified
+ # animated boot up require patches to the baselayout package
+ cd ${S}/utils
+
+ emake -C fbmngplay || die
+ emake -C fbtruetype || die
+ emake -C splashutils || die
+
+ cd ${S}
+}
+
+src_install() {
+ # Splash utilities
+ exeinto /sbin
+ doexe utils/fbmngplay/fbmngplay{,.static}
+ doexe utils/fbtruetype/fbtruetype{,.static}
+ doexe misc/bootsplash_resize
+ newexe utils/splashutils/splash splash.bin
+ doexe misc/splash
+ doexe utils/splashutils/{fbresolution,getkey,progress,splashpbm}
+
+ insinto /sbin
+ doins misc/splash-functions.sh
+
+ exeinto /usr/lib/${PN}
+ doexe misc/bootsplash_resizer.pl
+
+ dodir /etc/${PN}
+ cp -pR themes/* ${D}/etc/${PN}
+
+ # link default config for boot images if not already set
+ if [ ! -e ${ROOT}/etc/bootsplash/default ]; then
+ dosym ./gentoo /etc/bootsplash/default
+ fi
+
+ exeinto /etc/init.d
+ doexe misc/bootsplash
+
+ insinto /etc/conf.d
+ newins misc/bootsplash.conf bootsplash
+
+ insinto /usr/share/${PN}
+ doins kernel/*.bz2 misc/grub.conf.sample misc/yaboot.conf.sample
+
+ into /
+ dosbin misc/bootsplash_patch misc/bootsplash_initrdgen
+ fperms 0754 /sbin/bootsplash_patch /sbin/bootsplash_initrdgen
+}
+
+pkg_postinst() {
+ # has to be done here so that the initrd images are created properly
+ if [ "${ROOT}" = "/" ]
+ then
+ /sbin/bootsplash_initrdgen --all
+ fi
+
+ # rename bootsplash config file to fit with the standard
+ if [ -f ${ROOT}/etc/conf.d/bootsplash.conf ]
+ then
+ mv -f ${ROOT}/etc/conf.d/bootsplash.conf ${ROOT}/etc/conf.d/bootsplash
+ fi
+
+ echo ""
+ einfo "Execute \`bootsplash_patch\` to have your kernel sources in"
+ einfo "/usr/src/linux patched with the Framebuffer Bootsplash patches."
+ einfo
+ einfo "You can also use:"
+ einfo " bootsplash_patch /path/to/your/custom/kernel/"
+ einfo "to patch your custom kernel sources."
+ echo ""
+ ewarn "If you have already patched the kernel then you only need to copy"
+ ewarn "an initrd from /usr/share/${PN} to /boot"
+ echo ""
+ einfo "Run:"
+ einfo " rc-update add bootsplash default"
+ einfo "to change the console images after startup"
+ echo ""
+ einfo "If you want to automatically generate configs for a new resolution"
+ einfo "you can use the \`bootsplash_resize\` script. More info:"
+ einfo " bootsplash_resize -h"
+ echo ""
+ ewarn "If you're using bootsplash with a pre-2.6.7 kernel, it will only"
+ ewarn "work in 16bpp modes."
+ echo ""
+}
diff --git a/media-gfx/bootsplash/files/digest-bootsplash-0.6.1-r6 b/media-gfx/bootsplash/files/digest-bootsplash-0.6.1-r6
new file mode 100644
index 000000000000..42c1b61a6556
--- /dev/null
+++ b/media-gfx/bootsplash/files/digest-bootsplash-0.6.1-r6
@@ -0,0 +1,3 @@
+MD5 3ec34e6cc47d7e47825658f1f71e718f bootsplash-core-0.6.1-r6.tar.bz2 130805
+MD5 1d93157ac8796a86cc269b24bb882769 bootsplash-themes-0.6.1.tar.bz2 416892
+MD5 61ad5145876db963402bcf166a01f94a bootsplash-kernel-0.6.1-r6.tar.bz2 177574