summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin McCarthy <signals@gentoo.org>2011-02-23 17:56:58 +0000
committerKevin McCarthy <signals@gentoo.org>2011-02-23 17:56:58 +0000
commit7833c251ee48d506b734ae3f6d6a57d4435d649b (patch)
tree10d45782b124466998b38428cf4da17fd3a78ab3 /media-gfx/aview
parentDrop lib deprecation preprocessor defines again, bug #352400. (diff)
downloadgentoo-2-7833c251ee48d506b734ae3f6d6a57d4435d649b.tar.gz
gentoo-2-7833c251ee48d506b734ae3f6d6a57d4435d649b.tar.bz2
gentoo-2-7833c251ee48d506b734ae3f6d6a57d4435d649b.zip
Fix bug #293654. Add myself as maintainer.
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/aview')
-rw-r--r--media-gfx/aview/ChangeLog10
-rw-r--r--media-gfx/aview/aview-1.3.0_rc1-r2.ebuild37
-rw-r--r--media-gfx/aview/files/aview-1.3.0_rc1-asciiview.patch76
-rw-r--r--media-gfx/aview/metadata.xml7
4 files changed, 125 insertions, 5 deletions
diff --git a/media-gfx/aview/ChangeLog b/media-gfx/aview/ChangeLog
index ffa9f779f3b0..d5214dd383ab 100644
--- a/media-gfx/aview/ChangeLog
+++ b/media-gfx/aview/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/aview
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/aview/ChangeLog,v 1.15 2009/05/29 14:08:56 rbu Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/aview/ChangeLog,v 1.16 2011/02/23 17:56:58 signals Exp $
+
+*aview-1.3.0_rc1-r2 (23 Feb 2011)
+
+ 23 Feb 2011; Kevin McCarthy <signals@gentoo.org> +aview-1.3.0_rc1-r2.ebuild,
+ +files/aview-1.3.0_rc1-asciiview.patch:
+ Fixed multiple filename bug and keyboard input problem. (Bug #293654)
29 May 2009; Robert Buchholz <rbu@gentoo.org> -aview-1.3.0_rc1.ebuild:
Remove ebuild that is vulnerable to GLSA 200812-14, bug #271762.
diff --git a/media-gfx/aview/aview-1.3.0_rc1-r2.ebuild b/media-gfx/aview/aview-1.3.0_rc1-r2.ebuild
new file mode 100644
index 000000000000..04e8d65a42bc
--- /dev/null
+++ b/media-gfx/aview/aview-1.3.0_rc1-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/aview/aview-1.3.0_rc1-r2.ebuild,v 1.1 2011/02/23 17:56:58 signals Exp $
+
+inherit base
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P/rc*/}
+DESCRIPTION="An ASCII Image Viewer"
+SRC_URI="mirror://sourceforge/aa-project/${MY_P}.tar.gz"
+HOMEPAGE="http://aa-project.sourceforge.net/aview/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/aalib-1.4_rc4"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-asciiview.patch
+ "${FILESDIR}"/${P}-includes.patch
+)
+
+src_compile() {
+ econf || die
+ make aview || die
+}
+
+src_install() {
+ into /usr
+ dobin aview asciiview
+
+ doman *.1
+ dodoc ANNOUNCE ChangeLog README TODO
+}
diff --git a/media-gfx/aview/files/aview-1.3.0_rc1-asciiview.patch b/media-gfx/aview/files/aview-1.3.0_rc1-asciiview.patch
new file mode 100644
index 000000000000..6d71bbb967b1
--- /dev/null
+++ b/media-gfx/aview/files/aview-1.3.0_rc1-asciiview.patch
@@ -0,0 +1,76 @@
+Support spaces in filenames (bug #39207) based on a patch from
+kyberneticist AT yahoo DOT com with additional fixes to address bug
+#293654 by Kevin McCarthy <signals@gentoo.org>
+
+Fix insecure temporary file permissions (bug #235808) based on a patch from
+Robert Buchholz <rbu@gentoo.org>
+
+Fix ignored interactive keyboard commands when aview is called from the
+asciiview script (bug #293654) by Kevin McCarthy <signals@gentoo.org>
+
+Rollup patch created by Kevin McCarthy <signals@gentoo.org>
+
+--- asciiview
++++ asciiview
+@@ -3,13 +3,13 @@
+ clear()
+ {
+ kill $! 2>/dev/null
+- rm -f /tmp/aview$$.pgm 2>/dev/null
++ rm -rf $tmpdir 2>/dev/null
+ }
+ myconvert()
+ {
+- if anytopnm $1 >/tmp/aview$$.pgm 2>/dev/null ; then
++ if anytopnm "$1" >"$2" 2>/dev/null ; then
+ exit
+- elif convert -colorspace gray $1 pgm:- 2>/dev/null ; then
++ elif convert -colorspace gray "$1" pgm:- 2>/dev/null ; then
+ exit
+ fi
+ echo "Failed to convert file format to PNM by both convert and anytopnm" >&2
+@@ -44,27 +44,34 @@
+ options="$options $1"
+ shift
+ ;;
+- *)
+- filenames="$filenames $1"
++ *)
++ if [ "$filenames" = "" ]
++ then
++ filenames=$1 #avoid leading null
++ else
++ filenames=$(echo -e "$filenames\n$1")
++ fi
+ shift
+ ;;
+ esac
+ done
+ trap clear 0
+-mkfifo /tmp/aview$$.pgm
+-outfile=/tmp/aview$$.pgm
+-for name in $filenames ; do
+-if test -r $name ; then
+-case $name in
++tmpdir=`mktemp -t -d`
++outfile=$tmpdir/aview.pgm
++mkfifo $outfile
++exec 3<&0
++echo "$filenames" | while read name; do
++if test -r "$name" ; then
++case "$name" in
+ *.fli | *.lfc | *.flic )
+ PATH="$PATH:."
+- aaflip $options $name
++ aaflip $options "$name"
+ ;;
+ *)
+- myconvert $name >/tmp/aview$$.pgm &
++ myconvert "$name" "$outfile" >"$outfile" &
+ pid=$!
+ PATH="$PATH:."
+- aview $options /tmp/aview$$.pgm
++ aview $options $outfile <&3
+ kill $pid 2>/dev/null
+ esac
+ else
diff --git a/media-gfx/aview/metadata.xml b/media-gfx/aview/metadata.xml
index 54494c4bb860..ee209a571253 100644
--- a/media-gfx/aview/metadata.xml
+++ b/media-gfx/aview/metadata.xml
@@ -2,7 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>no-herd</herd>
-<maintainer>
-<email>maintainer-needed@gentoo.org</email>
-</maintainer>
+ <maintainer>
+ <email>signals@gentoo.org</email>
+ <name>Kevin McCarthy</name>
+ </maintainer>
</pkgmetadata>