summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-07-10 18:31:44 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-07-10 18:31:44 +0000
commitd6e515fa4033d4dea16d6417717ec96f8e2017e3 (patch)
treead64d13f58401e77bd4c28eddf6bf79b83c034f0 /media-gfx/autotrace
parentVersion bump (bug #322405). (diff)
downloadgentoo-2-d6e515fa4033d4dea16d6417717ec96f8e2017e3.tar.gz
gentoo-2-d6e515fa4033d4dea16d6417717ec96f8e2017e3.tar.bz2
gentoo-2-d6e515fa4033d4dea16d6417717ec96f8e2017e3.zip
Fix to new ImageMagick API. Upgrade to latest Debian patchset version.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/autotrace')
-rw-r--r--media-gfx/autotrace/ChangeLog9
-rw-r--r--media-gfx/autotrace/autotrace-0.31.1-r6.ebuild49
-rw-r--r--media-gfx/autotrace/files/autotrace-0.31.1-GetOnePixel.patch16
-rw-r--r--media-gfx/autotrace/files/autotrace-0.31.1-libpng14.patch17
-rw-r--r--media-gfx/autotrace/files/autotrace-0.31.1-pkgconfig.patch8
-rw-r--r--media-gfx/autotrace/files/autotrace-0.31.1-swf-output.patch10
6 files changed, 100 insertions, 9 deletions
diff --git a/media-gfx/autotrace/ChangeLog b/media-gfx/autotrace/ChangeLog
index dc8d6a722888..13efa9446dbd 100644
--- a/media-gfx/autotrace/ChangeLog
+++ b/media-gfx/autotrace/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/autotrace
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/autotrace/ChangeLog,v 1.43 2010/07/10 17:19:35 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/autotrace/ChangeLog,v 1.44 2010/07/10 18:31:44 ssuominen Exp $
+
+*autotrace-0.31.1-r6 (10 Jul 2010)
+
+ 10 Jul 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +autotrace-0.31.1-r6.ebuild, +files/autotrace-0.31.1-GetOnePixel.patch,
+ +files/autotrace-0.31.1-libpng14.patch:
+ Fix to new ImageMagick API. Upgrade to latest Debian patchset version.
10 Jul 2010; Raúl Porcel <armin76@gentoo.org> autotrace-0.31.1-r5.ebuild:
alpha/ia64/sparc stable wrt #322745
diff --git a/media-gfx/autotrace/autotrace-0.31.1-r6.ebuild b/media-gfx/autotrace/autotrace-0.31.1-r6.ebuild
new file mode 100644
index 000000000000..07e31c96ddd2
--- /dev/null
+++ b/media-gfx/autotrace/autotrace-0.31.1-r6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/autotrace/autotrace-0.31.1-r6.ebuild,v 1.1 2010/07/10 18:31:44 ssuominen Exp $
+
+EAPI=3
+inherit autotools eutils
+
+_dpatch=15
+
+DESCRIPTION="A program for converting bitmaps to vector graphics"
+HOMEPAGE="http://packages.qa.debian.org/a/autotrace.html http://autotrace.sourceforge.net/"
+SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/a/${PN}/${PN}_${PV}-${_dpatch}.diff.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+imagemagick"
+
+RDEPEND="media-libs/libexif
+ >=media-libs/libpng-1.4.3
+ >=media-libs/ming-0.4.2
+ >=media-gfx/pstoedit-3.50
+ imagemagick? ( >=media-gfx/imagemagick-6.6.2.5 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${WORKDIR}"/${PN}_${PV}-${_dpatch}.diff
+
+ epatch "${FILESDIR}"/${P}-{m4,libpng14,pkgconfig}.patch \
+ "${FILESDIR}"/${P}-swf-output.patch \
+ "${FILESDIR}"/${P}-GetOnePixel.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_with imagemagick magick) \
+ --with-ming \
+ --with-pstoedit
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+}
diff --git a/media-gfx/autotrace/files/autotrace-0.31.1-GetOnePixel.patch b/media-gfx/autotrace/files/autotrace-0.31.1-GetOnePixel.patch
new file mode 100644
index 000000000000..048b7a76be70
--- /dev/null
+++ b/media-gfx/autotrace/files/autotrace-0.31.1-GetOnePixel.patch
@@ -0,0 +1,16 @@
+http://cvs.fedoraproject.org/viewvc/rpms/autotrace/devel/autotrace-0.31.1-GetOnePixel.patch?view=markup
+
+--- input-magick.c
++++ input-magick.c
+@@ -83,7 +83,11 @@
+
+ for(j=0,runcount=0,point=0;j<image->rows;j++)
+ for(i=0;i<image->columns;i++) {
++#if (MagickLibVersion < 0x0645) || (MagickLibVersion >= 0x0649)
+ p=GetOnePixel(image,i,j);
++#else
++ GetOnePixel(image,i,j,pixel);
++#endif
+ AT_BITMAP_BITS(bitmap)[point++]=pixel->red; /* if gray: red=green=blue */
+ if(np==3) {
+ AT_BITMAP_BITS(bitmap)[point++]=pixel->green;
diff --git a/media-gfx/autotrace/files/autotrace-0.31.1-libpng14.patch b/media-gfx/autotrace/files/autotrace-0.31.1-libpng14.patch
new file mode 100644
index 000000000000..72f76bcf1535
--- /dev/null
+++ b/media-gfx/autotrace/files/autotrace-0.31.1-libpng14.patch
@@ -0,0 +1,17 @@
+http://bugs.gentoo.org/321525
+
+--- configure.in
++++ configure.in
+@@ -188,9 +188,9 @@
+ HAVE_LIBPNG=yes ,,-lz -lm)
+ if test "x$HAVE_LIBPNG" = "xyes" ; then
+ LIBPNG_LDFLAGS="-lpng -lz -lm"
+- PKGCONFIG_REQS="$PKGCONFIG_REQS, libpng12"
+- if pkg-config --exists libpng12 ; then
+- LIBPNG_LDFLAGS="`pkg-config --libs libpng12`"
++ PKGCONFIG_REQS="$PKGCONFIG_REQS, libpng"
++ if pkg-config --exists libpng ; then
++ LIBPNG_LDFLAGS="`pkg-config --libs libpng`"
+ fi
+ AC_SUBST(LIBPNG_LDFLAGS)
+ AC_DEFINE(HAVE_LIBPNG)
diff --git a/media-gfx/autotrace/files/autotrace-0.31.1-pkgconfig.patch b/media-gfx/autotrace/files/autotrace-0.31.1-pkgconfig.patch
index 49619082253d..a6371dd3c725 100644
--- a/media-gfx/autotrace/files/autotrace-0.31.1-pkgconfig.patch
+++ b/media-gfx/autotrace/files/autotrace-0.31.1-pkgconfig.patch
@@ -1,7 +1,7 @@
-diff --git a/configure.in b/configure.in
-index 564b32f..b396b26 100644
---- a/configure.in
-+++ b/configure.in
+http://bugs.gentoo.org/283534
+
+--- configure.in
++++ configure.in
@@ -223,7 +223,7 @@ if test "${swf_header_found}" = yes ; then
AC_CHECK_LIB(ming, Ming_init,
HAVE_LIBSWF=yes,,-lm)
diff --git a/media-gfx/autotrace/files/autotrace-0.31.1-swf-output.patch b/media-gfx/autotrace/files/autotrace-0.31.1-swf-output.patch
index 7deed35b1820..b9132c2ac529 100644
--- a/media-gfx/autotrace/files/autotrace-0.31.1-swf-output.patch
+++ b/media-gfx/autotrace/files/autotrace-0.31.1-swf-output.patch
@@ -1,5 +1,7 @@
---- output-swf.c.old 2006-04-01 21:50:06.000000000 -0500
-+++ output-swf.c 2006-04-01 21:50:28.000000000 -0500
+http://bugs.gentoo.org/122035
+
+--- output-swf.c
++++ output-swf.c
@@ -24,7 +24,6 @@
#include "spline.h"
#include "color.h"
@@ -9,8 +11,8 @@
#define FPS 24.0
#define IMGID 1
---- output-swf.h.old 2006-04-01 21:50:12.000000000 -0500
-+++ output-swf.h 2006-04-01 21:50:59.000000000 -0500
+--- output-swf.h
++++ output-swf.h
@@ -23,6 +23,7 @@
#define OUTPUTSWF_H