summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2012-10-08 10:01:49 +0000
committerAkinori Hattori <hattya@gentoo.org>2012-10-08 10:01:49 +0000
commita485ecf855416940deffcbb504531f26b6efb0b3 (patch)
tree61440ba0bd1a33d1b3dfe8efed29576f09b75503 /media-fonts
parentAdd missing debug USE flag wrt bug #433098 (diff)
downloadgentoo-2-a485ecf855416940deffcbb504531f26b6efb0b3.tar.gz
gentoo-2-a485ecf855416940deffcbb504531f26b6efb0b3.tar.bz2
gentoo-2-a485ecf855416940deffcbb504531f26b6efb0b3.zip
new upstream release.
(Portage version: 2.1.11.9/cvs/Linux i686)
Diffstat (limited to 'media-fonts')
-rw-r--r--media-fonts/mplus-outline-fonts/ChangeLog9
-rw-r--r--media-fonts/mplus-outline-fonts/mplus-outline-fonts-0_pre052.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/media-fonts/mplus-outline-fonts/ChangeLog b/media-fonts/mplus-outline-fonts/ChangeLog
index 5fa3ef89f443..f8078cabee27 100644
--- a/media-fonts/mplus-outline-fonts/ChangeLog
+++ b/media-fonts/mplus-outline-fonts/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-fonts/mplus-outline-fonts
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-fonts/mplus-outline-fonts/ChangeLog,v 1.36 2012/01/28 15:33:10 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/mplus-outline-fonts/ChangeLog,v 1.37 2012/10/08 10:01:49 hattya Exp $
+
+*mplus-outline-fonts-0_pre052 (08 Oct 2012)
+
+ 08 Oct 2012; Akinori Hattori <hattya@gentoo.org>
+ +mplus-outline-fonts-0_pre052.ebuild:
+ new upstream release.
*mplus-outline-fonts-0_pre046 (28 Jan 2012)
@@ -203,4 +209,3 @@
23 Dec 2005; Mamoru KOMACHI <usata@gentoo.org> +metadata.xml,
+mplus-outline-fonts-0_pre010.ebuild:
Initial import. Thanks to kuratomi, a5hr and bashi (GentooJP users).
-
diff --git a/media-fonts/mplus-outline-fonts/mplus-outline-fonts-0_pre052.ebuild b/media-fonts/mplus-outline-fonts/mplus-outline-fonts-0_pre052.ebuild
new file mode 100644
index 000000000000..22ba23fa51d1
--- /dev/null
+++ b/media-fonts/mplus-outline-fonts/mplus-outline-fonts-0_pre052.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/mplus-outline-fonts/mplus-outline-fonts-0_pre052.ebuild,v 1.1 2012/10/08 10:01:49 hattya Exp $
+
+EAPI="3"
+inherit font
+
+MY_P="mplus-${PV/0_pre/TESTFLIGHT-}"
+DESCRIPTION="M+ Japanese outline fonts"
+HOMEPAGE="http://mplus-fonts.sourceforge.jp/ http://ossipedia.ipa.go.jp/ipafont/"
+SRC_URI="mirror://sourceforge.jp/mplus-fonts/6650/${MY_P}.tar.xz"
+
+LICENSE="mplus-fonts ipafont? ( IPAfont )"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~x86 ~ppc-macos ~x86-macos"
+IUSE="ipafont"
+
+DEPEND="ipafont? (
+ media-gfx/fontforge
+ >=media-fonts/ja-ipafonts-003.02
+ )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+FONT_SUFFIX="ttf"
+FONT_S="${S}"
+
+DOCS="README_J README_E"
+
+RESTRICT="strip binchecks"
+
+IPAFONT_DIR="${EPREFIX}/usr/share/fonts/ja-ipafonts"
+
+src_prepare() {
+ if use ipafont ; then
+ cp -p "${IPAFONT_DIR}/ipag.ttf" "${S}" || die
+ fi
+}
+
+src_compile() {
+ if use ipafont ; then
+ fontforge -script m++ipa.pe || die
+ rm -f ipag.ttf || die
+ fi
+}