summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2006-01-11 16:02:04 +0000
committerAron Griffis <agriffis@gentoo.org>2006-01-11 16:02:04 +0000
commit1f4abaf192164b38250ec3f77de66d0a1605b2fc (patch)
tree38ad2a7897db43a510f0a6ca03af2bc3ac3eba1b /media-fonts/lfpfonts-fix
parentDrop old version and FILESDIR cleanup. (diff)
downloadgentoo-2-1f4abaf192164b38250ec3f77de66d0a1605b2fc.tar.gz
gentoo-2-1f4abaf192164b38250ec3f77de66d0a1605b2fc.tar.bz2
gentoo-2-1f4abaf192164b38250ec3f77de66d0a1605b2fc.zip
Get rid of copious output from compile script, which was drastically slowing
down emerge, even in a local xterm. (Portage version: 2.1_pre3-r1)
Diffstat (limited to 'media-fonts/lfpfonts-fix')
-rw-r--r--media-fonts/lfpfonts-fix/ChangeLog9
-rw-r--r--media-fonts/lfpfonts-fix/files/lfpfonts-fix-0.83-noglyph.patch16
-rw-r--r--media-fonts/lfpfonts-fix/lfpfonts-fix-0.83-r2.ebuild12
3 files changed, 32 insertions, 5 deletions
diff --git a/media-fonts/lfpfonts-fix/ChangeLog b/media-fonts/lfpfonts-fix/ChangeLog
index 114d211d1db8..9d81dac8ef01 100644
--- a/media-fonts/lfpfonts-fix/ChangeLog
+++ b/media-fonts/lfpfonts-fix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-fonts/lfpfonts-fix
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-fonts/lfpfonts-fix/ChangeLog,v 1.9 2005/03/12 23:49:34 agriffis Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/lfpfonts-fix/ChangeLog,v 1.10 2006/01/11 16:02:04 agriffis Exp $
+
+ 11 Jan 2006; Aron Griffis <agriffis@gentoo.org>
+ +files/lfpfonts-fix-0.83-noglyph.patch, lfpfonts-fix-0.83-r2.ebuild:
+ Get rid of copious output from compile script, which was drastically slowing
+ down emerge, even in a local xterm.
12 Mar 2005; Aron Griffis <agriffis@gentoo.org>
-lfpfonts-fix-0.82-r1.ebuild, -lfpfonts-fix-0.83-r1.ebuild,
diff --git a/media-fonts/lfpfonts-fix/files/lfpfonts-fix-0.83-noglyph.patch b/media-fonts/lfpfonts-fix/files/lfpfonts-fix-0.83-noglyph.patch
new file mode 100644
index 000000000000..77cf7a5fe5f4
--- /dev/null
+++ b/media-fonts/lfpfonts-fix/files/lfpfonts-fix-0.83-noglyph.patch
@@ -0,0 +1,16 @@
+--- src/ucs2any.agriffis 2001-02-17 12:34:50.000000000 -0500
++++ src/ucs2any 2006-01-11 10:53:15.000000000 -0500
+@@ -225,12 +225,7 @@
+ if (!is_control($ucs)) {
+ if ($startchar{$ucs}) {
+ $map{$target} = $ucs;
+- } else {
+- printf STDERR "No glyph for character U+%04X " .
+- "(0x%02x) available.\n", $ucs, $target
+- unless (is_blockgraphics($ucs) && $slant ne "R") ||
+- ($ucs >= 0x200e && $ucs <= 0x200f);
+- }
++ }
+ }
+ } else {
+ printf STDERR "Unrecognized line in '$fmap':\n$_";
diff --git a/media-fonts/lfpfonts-fix/lfpfonts-fix-0.83-r2.ebuild b/media-fonts/lfpfonts-fix/lfpfonts-fix-0.83-r2.ebuild
index 71177a690a5a..716b7781e522 100644
--- a/media-fonts/lfpfonts-fix/lfpfonts-fix-0.83-r2.ebuild
+++ b/media-fonts/lfpfonts-fix/lfpfonts-fix-0.83-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-fonts/lfpfonts-fix/lfpfonts-fix-0.83-r2.ebuild,v 1.2 2005/03/12 23:49:34 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/lfpfonts-fix/lfpfonts-fix-0.83-r2.ebuild,v 1.3 2006/01/11 16:02:04 agriffis Exp $
-inherit font
+inherit font eutils
DESCRIPTION="Linux Font Project fixed-width fonts"
SRC_URI="mirror://sourceforge/xfonts/${PN}-src-${PV}.tar.bz2"
@@ -21,6 +21,12 @@ FONT_S=${S}/lfp-fix
DOCS="doc/*"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-0.83-noglyph.patch
+}
+
src_compile() {
cd src
for a in *.bdf; do