summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2012-05-31 10:51:53 +0000
committerFabian Groffen <grobian@gentoo.org>2012-05-31 10:51:53 +0000
commit34e8897f0e77aeb866880e624b198107930b6957 (patch)
tree91f40a0482d116105cf44d3d8651c5a445732d19 /mail-mta
parentRemove old. (diff)
downloadgentoo-2-34e8897f0e77aeb866880e624b198107930b6957.tar.gz
gentoo-2-34e8897f0e77aeb866880e624b198107930b6957.tar.bz2
gentoo-2-34e8897f0e77aeb866880e624b198107930b6957.zip
Version bump to 4.80 release
(Portage version: 2.2.01.20430-prefix/cvs/SunOS i386)
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/exim/ChangeLog10
-rw-r--r--mail-mta/exim/exim-4.80.ebuild (renamed from mail-mta/exim/exim-4.80_rc7.ebuild)34
2 files changed, 29 insertions, 15 deletions
diff --git a/mail-mta/exim/ChangeLog b/mail-mta/exim/ChangeLog
index ceb5fd4819d3..743d384206ec 100644
--- a/mail-mta/exim/ChangeLog
+++ b/mail-mta/exim/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for mail-mta/exim
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/exim/ChangeLog,v 1.222 2012/05/29 14:53:40 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/exim/ChangeLog,v 1.223 2012/05/31 10:51:53 grobian Exp $
+
+*exim-4.80 (31 May 2012)
+
+ 31 May 2012; Fabian Groffen <grobian@gentoo.org> -exim-4.80_rc7.ebuild,
+ +exim-4.80.ebuild:
+ Version bump to 4.80 release. This version uses SSLv3, and disables v2 by
+ default. Supports TLSv1.{1,2} when using OpenSSL >=1.0.1. ChangeLog should
+ become available at ftp://ftp.exim.org/pub/exim/ChangeLogs/ChangeLog-4.80
*exim-4.80_rc7 (29 May 2012)
diff --git a/mail-mta/exim/exim-4.80_rc7.ebuild b/mail-mta/exim/exim-4.80.ebuild
index 2803f446915b..8a9a1a6e8a2c 100644
--- a/mail-mta/exim/exim-4.80_rc7.ebuild
+++ b/mail-mta/exim/exim-4.80.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/exim/exim-4.80_rc7.ebuild,v 1.1 2012/05/29 14:53:40 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/exim/exim-4.80.ebuild,v 1.1 2012/05/31 10:51:53 grobian Exp $
EAPI="3"
@@ -21,7 +21,7 @@ HOMEPAGE="http://www.exim.org/"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-solaris"
DEPEND=">=sys-apps/sed-4.0.5
>=sys-libs/db-3.2
@@ -46,6 +46,7 @@ DEPEND=">=sys-apps/sed-4.0.5
)
sqlite? ( dev-db/sqlite )
radius? ( net-dialup/radiusclient )
+ virtual/pkgconfig
virtual/libiconv
"
# added X check for #57206
@@ -87,6 +88,14 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-4.76-dsn.patch
epatch exim_${DSN_EXIM_V}_dsn_${DSN_V}.patch
fi
+
+ # user Exim believes it should be
+ MAILUSER=mail
+ MAILGROUP=mail
+ if use prefix && [[ ${EUID} != 0 ]] ; then
+ MAILUSER=$(id -un)
+ MAILGROUP=$(id -gn)
+ fi
}
src_configure() {
@@ -106,7 +115,7 @@ src_configure() {
-e "s:# SPOOL_DIRECTORY=/var/spool/exim:SPOOL_DIRECTORY=${EPREFIX}/var/spool/exim:" \
-e "s:# SUPPORT_MAILDIR=yes:SUPPORT_MAILDIR=yes:" \
-e "s:# SUPPORT_MAILSTORE=yes:SUPPORT_MAILSTORE=yes:" \
- -e "s:EXIM_USER=:EXIM_USER=mail:" \
+ -e "s:EXIM_USER=:EXIM_USER=${MAILUSER}:" \
-e "s:# AUTH_SPA=yes:AUTH_SPA=yes:" \
-e "s:# AUTH_CRAM_MD5=yes:AUTH_CRAM_MD5=yes:" \
-e "s:# AUTH_PLAINTEXT=yes:AUTH_PLAINTEXT=yes:" \
@@ -188,15 +197,12 @@ src_configure() {
use !elibc_glibc && echo "EXTRALIBS_EXIM=-liconv" >> Makefile
if use ssl; then
- sed -i \
- -e "s:# \(SUPPORT_TLS=yes\):\1:" Makefile
+ echo "SUPPORT_TLS=yes" >> Makefile
if use gnutls; then
- sed -i \
- -e "s:# \(USE_GNUTLS=yes\):\1:" \
- -e "s:# \(TLS_LIBS=-lgnutls -ltasn1 -lgcrypt\):\1:" Makefile
+ echo "USE_GNUTLS=yes" >> Makefile
+ echo "USE_GNUTLS_PC=gnutls" >> Makefile
else
- sed -i \
- -e "s:# \(TLS_LIBS=-lssl -lcrypto\):\1:" Makefile
+ echo "USE_OPENSSL_PC=openssl" >> Makefile
fi
fi
@@ -224,9 +230,8 @@ src_configure() {
fi
if use sqlite; then
- sed -i "s:# LOOKUP_SQLITE=yes: LOOKUP_SQLITE=yes:" Makefile
- LOOKUP_INCLUDE="$LOOKUP_INCLUDE -I${EROOT}usr/include/sqlite"
- LOOKUP_LIBS="$LOOKUP_LIBS -lsqlite3"
+ echo "LOOKUP_SQLITE=yes" >> Makefile
+ echo "LOOKUP_SQLITE_PC=sqlite3" >> Makefile
fi
if [[ -n ${LOOKUP_INCLUDE} ]]; then
@@ -266,6 +271,7 @@ src_configure() {
# use the "native" interface to the DBM library
echo "USE_DB=yes" >> Makefile
+ echo "DBMLIB=-ldb" >> Makefile
}
src_compile() {
@@ -323,7 +329,7 @@ src_install () {
newconfd "${FILESDIR}"/exim.confd exim
- DIROPTIONS="--mode=0750 --owner=mail --group=mail"
+ DIROPTIONS="--mode=0750 --owner=${MAILUSER} --group=${MAILGROUP}"
dodir /var/log/${PN}
}