summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2013-07-23 17:32:39 +0000
committerFabian Groffen <grobian@gentoo.org>2013-07-23 17:32:39 +0000
commit17f7698b07d7f3f03fc9956d2abd128aff98f17a (patch)
tree4f8c274bcf57d4a4c20b4c3db5404d1615a0d36f /mail-mta
parentCorrect tmpfiles.setup init script name in depend() (diff)
downloadgentoo-2-17f7698b07d7f3f03fc9956d2abd128aff98f17a.tar.gz
gentoo-2-17f7698b07d7f3f03fc9956d2abd128aff98f17a.tar.bz2
gentoo-2-17f7698b07d7f3f03fc9956d2abd128aff98f17a.zip
Fix/improve locating MySQL and PostgreSQL libraries, patch by Alexander Tsoy in bug #477792
(Portage version: 2.2.01.22124-prefix/cvs/Darwin i386, signed Manifest commit with key 0x5F75F607C5C74E89)
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/exim/ChangeLog7
-rw-r--r--mail-mta/exim/exim-4.80.1-r1.ebuild10
-rw-r--r--mail-mta/exim/exim-4.80.1.ebuild10
3 files changed, 16 insertions, 11 deletions
diff --git a/mail-mta/exim/ChangeLog b/mail-mta/exim/ChangeLog
index 0464658c31c8..b3b1b9b46d52 100644
--- a/mail-mta/exim/ChangeLog
+++ b/mail-mta/exim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-mta/exim
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/exim/ChangeLog,v 1.247 2013/07/23 17:16:27 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/exim/ChangeLog,v 1.248 2013/07/23 17:32:39 grobian Exp $
+
+ 23 Jul 2013; Fabian Groffen <grobian@gentoo.org> exim-4.80.1-r1.ebuild,
+ exim-4.80.1.ebuild:
+ Fix/improve locating MySQL and PostgreSQL libraries, patch by Alexander Tsoy
+ in bug #477792
23 Jul 2013; Fabian Groffen <grobian@gentoo.org> files/exim.logrotate:
Remove now useless sharedscripts from logrotate, thanks Alexander Tsoy
diff --git a/mail-mta/exim/exim-4.80.1-r1.ebuild b/mail-mta/exim/exim-4.80.1-r1.ebuild
index 10a6ee83ea08..40d60762f917 100644
--- a/mail-mta/exim/exim-4.80.1-r1.ebuild
+++ b/mail-mta/exim/exim-4.80.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/exim/exim-4.80.1-r1.ebuild,v 1.2 2013/07/23 09:17:44 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/exim/exim-4.80.1-r1.ebuild,v 1.3 2013/07/23 17:32:39 grobian Exp $
EAPI="4"
@@ -229,14 +229,14 @@ src_configure() {
if use mysql; then
sed -i "s:# LOOKUP_MYSQL=yes:LOOKUP_MYSQL=yes:" Makefile
- LOOKUP_INCLUDE="$LOOKUP_INCLUDE -I${EROOT}usr/include/mysql"
- LOOKUP_LIBS="$LOOKUP_LIBS -lmysqlclient"
+ LOOKUP_INCLUDE="$LOOKUP_INCLUDE $(mysql_config --include)"
+ LOOKUP_LIBS="$LOOKUP_LIBS $(mysql_config --libs)"
fi
if use postgres; then
sed -i "s:# LOOKUP_PGSQL=yes:LOOKUP_PGSQL=yes:" Makefile
- LOOKUP_INCLUDE="$LOOKUP_INCLUDE -I${EROOT}usr/include/postgresql"
- LOOKUP_LIBS="$LOOKUP_LIBS -lpq"
+ LOOKUP_INCLUDE="$LOOKUP_INCLUDE -I$(pg_config --includedir)"
+ LOOKUP_LIBS="$LOOKUP_LIBS -L$(pg_config --libdir) -lpq"
fi
if use sqlite; then
diff --git a/mail-mta/exim/exim-4.80.1.ebuild b/mail-mta/exim/exim-4.80.1.ebuild
index 1e261a4b07dc..96a2d7c3fd15 100644
--- a/mail-mta/exim/exim-4.80.1.ebuild
+++ b/mail-mta/exim/exim-4.80.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/exim/exim-4.80.1.ebuild,v 1.13 2013/03/23 18:00:38 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/exim/exim-4.80.1.ebuild,v 1.14 2013/07/23 17:32:39 grobian Exp $
EAPI="3"
@@ -232,14 +232,14 @@ src_configure() {
if use mysql; then
sed -i "s:# LOOKUP_MYSQL=yes:LOOKUP_MYSQL=yes:" Makefile
- LOOKUP_INCLUDE="$LOOKUP_INCLUDE -I${EROOT}usr/include/mysql"
- LOOKUP_LIBS="$LOOKUP_LIBS -lmysqlclient"
+ LOOKUP_INCLUDE="$LOOKUP_INCLUDE $(mysql_config --include)"
+ LOOKUP_LIBS="$LOOKUP_LIBS $(mysql_config --libs)"
fi
if use postgres; then
sed -i "s:# LOOKUP_PGSQL=yes:LOOKUP_PGSQL=yes:" Makefile
- LOOKUP_INCLUDE="$LOOKUP_INCLUDE -I${EROOT}usr/include/postgresql"
- LOOKUP_LIBS="$LOOKUP_LIBS -lpq"
+ LOOKUP_INCLUDE="$LOOKUP_INCLUDE -I$(pg_config --includedir)"
+ LOOKUP_LIBS="$LOOKUP_LIBS -L$(pg_config --libdir) -lpq"
fi
if use sqlite; then