summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2008-06-10 20:14:06 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2008-06-10 20:14:06 +0000
commita23f099c54eaaa3486ebb23ca01512e7cacd4cc5 (patch)
treed6deb98f36d788b5b49d1fc8970aab2986a222ec /mail-mta/ssmtp
parentFix building of some locales. Bug #225779 (diff)
downloadgentoo-2-a23f099c54eaaa3486ebb23ca01512e7cacd4cc5.tar.gz
gentoo-2-a23f099c54eaaa3486ebb23ca01512e7cacd4cc5.tar.bz2
gentoo-2-a23f099c54eaaa3486ebb23ca01512e7cacd4cc5.zip
Version bump, restrict access to ssmtp.conf (#187841), drop mailwrapper support (#222157), drop needless virtual/libc dependency (#211886), upstream fixed date header creation on uclibc (#145456)
(Portage version: 2.1.5.4)
Diffstat (limited to 'mail-mta/ssmtp')
-rw-r--r--mail-mta/ssmtp/ChangeLog11
-rw-r--r--mail-mta/ssmtp/ssmtp-2.62.ebuild84
2 files changed, 93 insertions, 2 deletions
diff --git a/mail-mta/ssmtp/ChangeLog b/mail-mta/ssmtp/ChangeLog
index c7f02be919f9..d8429274a47e 100644
--- a/mail-mta/ssmtp/ChangeLog
+++ b/mail-mta/ssmtp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-mta/ssmtp
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/ssmtp/ChangeLog,v 1.46 2007/01/06 00:54:36 ferdy Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/ssmtp/ChangeLog,v 1.47 2008/06/10 20:14:06 dertobi123 Exp $
+
+*ssmtp-2.62 (10 Jun 2008)
+
+ 10 Jun 2008; Tobias Scherbaum <dertobi123@gentoo.org> +ssmtp-2.62.ebuild:
+ Version bump, restrict access to ssmtp.conf (#187841), drop mailwrapper
+ support (#222157), drop needless virtual/libc dependency (#211886),
+ upstream fixed date header creation on uclibc (#145456)
06 Jan 2007; Fernando J. Pereda <ferdy@gentoo.org> -ssmtp-2.61.ebuild:
QA: Clean unused versions.
diff --git a/mail-mta/ssmtp/ssmtp-2.62.ebuild b/mail-mta/ssmtp/ssmtp-2.62.ebuild
new file mode 100644
index 000000000000..ac2c44ac36d3
--- /dev/null
+++ b/mail-mta/ssmtp/ssmtp-2.62.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/ssmtp/ssmtp-2.62.ebuild,v 1.1 2008/06/10 20:14:06 dertobi123 Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Extremely simple MTA to get mail off the system to a Mailhub"
+HOMEPAGE="ftp://ftp.debian.org/debian/pool/main/s/ssmtp/"
+SRC_URI="mirror://debian/pool/main/s/ssmtp/${P/-/_}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="ssl ipv6 md5sum"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ enewgroup ssmtp
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Respect LDFLAGS (bug #152197)
+ sed -i -e 's:$(CC) -o:$(CC) @LDFLAGS@ -o:' Makefile.in
+}
+
+src_compile() {
+ tc-export CC LD
+
+ econf \
+ --sysconfdir=/etc/ssmtp \
+ $(use_enable ssl) \
+ $(use_enable ipv6 inet6) \
+ $(use_enable md5sum md5auth) \
+ || die
+ make clean || die
+ make etcdir=/etc || die
+}
+
+src_install() {
+ dodir /usr/bin /usr/sbin /usr/lib
+ dosbin ssmtp || die
+ fperms 755 /usr/sbin/ssmtp
+
+ doman ssmtp.8
+ dodoc INSTALL README TLS CHANGELOG_OLD
+ newdoc ssmtp.lsm DESC
+
+ insinto /etc/ssmtp
+ doins ssmtp.conf revaliases
+
+ local conffile="${D}etc/ssmtp/ssmtp.conf"
+
+ mv "${conffile}" "${conffile}.orig"
+
+ # Sorry about the weird indentation, I couldn't figure out a cleverer way
+ # to do this without having horribly >80 char lines.
+ sed -e "s:^hostname=:\n# Gentoo bug #47562\\
+# Commenting the following line will force ssmtp to figure\\
+# out the hostname itself.\n\\
+# hostname=:" \
+ "${conffile}.orig" > "${conffile}" \
+ || die "sed failed"
+
+ rm "${conffile}.orig" || die "Failed to remove temporary created copy of ssmtp.conf"
+
+ # Set restrictive perms on ssmtp.conf as per #187841
+ # Protect the ssmtp configfile from being readable by regular users as it
+ # may contain login/password data to auth against a the mailhub used, add
+ # users to the ssmtp group to enable them to use ssmtp.
+ fowners root:ssmtp /etc/ssmtp/ssmtp.conf
+ fperms 640 /etc/ssmtp/ssmtp.conf
+
+ dosym /usr/sbin/ssmtp /usr/lib/sendmail
+ dosym /usr/sbin/ssmtp /usr/bin/sendmail
+ dosym /usr/sbin/ssmtp /usr/sbin/sendmail
+ dosym /usr/sbin/ssmtp /usr/bin/mailq
+ dosym /usr/sbin/ssmtp /usr/bin/newaliases
+}