summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Martin <slarti@gentoo.org>2005-04-07 11:57:27 +0000
committerTom Martin <slarti@gentoo.org>2005-04-07 11:57:27 +0000
commit1fd46e7d6e34379da4e00441fec891584290cc88 (patch)
treef79008a8614203e22a6a5715da79893310b993f6 /mail-mta/msmtp/msmtp-1.4.0.ebuild
parentStable -r1 on IA64. (diff)
downloadgentoo-2-1fd46e7d6e34379da4e00441fec891584290cc88.tar.gz
gentoo-2-1fd46e7d6e34379da4e00441fec891584290cc88.tar.bz2
gentoo-2-1fd46e7d6e34379da4e00441fec891584290cc88.zip
DEPEND on GnuTLS 1.2.0 and above instead of 1.1.23 and above. Fix use_enable for GSASL.
(Portage version: 2.0.51.19)
Diffstat (limited to 'mail-mta/msmtp/msmtp-1.4.0.ebuild')
-rw-r--r--mail-mta/msmtp/msmtp-1.4.0.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/mail-mta/msmtp/msmtp-1.4.0.ebuild b/mail-mta/msmtp/msmtp-1.4.0.ebuild
new file mode 100644
index 000000000000..b6d6c222aebb
--- /dev/null
+++ b/mail-mta/msmtp/msmtp-1.4.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/msmtp/msmtp-1.4.0.ebuild,v 1.1 2005/04/07 11:57:27 slarti Exp $
+
+DESCRIPTION="An SMTP client and SMTP plugin for mail user agents such as Mutt"
+HOMEPAGE="http://msmtp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/msmtp/${P}.tar.bz2"
+IUSE="ssl gnutls sasl mailwrapper"
+DEPEND="virtual/libc
+ dev-util/pkgconfig
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.0 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ sasl? ( >=virtual/gsasl-0.2.4 )
+ mailwrapper? ( >=net-mail/mailwrapper-0.2 )
+ !mailwrapper? ( !virtual/mta )"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~amd64 ~sparc"
+PROVIDE="virtual/mta"
+
+src_compile () {
+ local myconf
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --enable-ssl --with-ssl=gnutls"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --enable-ssl --with-ssl=openssl"
+ else
+ myconf="${myconf} --disable-ssl"
+ fi
+
+ econf \
+ $(use_enable sasl gsasl) \
+ ${myconf} \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install () {
+ make DESTDIR=${D} docdir=${D}/usr/share/doc docdirname=${P} install || die "install failed"
+
+ if use mailwrapper; then
+ insinto /etc/mail
+ doins ${FILESDIR}/mailer.conf
+ else
+ dodir /usr/sbin /usr/lib
+ dosym /usr/bin/msmtp /usr/sbin/sendmail || die "dosym failed"
+ dosym /usr/sbin/sendmail /usr/lib/sendmail || die "dosym failed"
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS doc/msmtprc.example \
+ doc/Mutt+msmtp.txt doc/msmtprc.example README.gsasl \
+ doc/msmtprc-system.example doc/msmtprc-user.example \
+ || die "dodoc failed"
+
+ if use doc; then
+ dohtml doc/msmtp.html || die "dohtml failed"
+ insinto /usr/share/doc/${PF}
+ doins doc/msmtp.pdf
+ fi
+}