summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2006-07-14 17:11:38 +0000
committerLuca Longinotti <chtekk@gentoo.org>2006-07-14 17:11:38 +0000
commit87ebbee8174fb3d1d0d6a6080052a9bab9691c70 (patch)
tree644abf688871e4a6a8e17ea4a882cc6e0616af0d /mail-mta/courier
parentppc stable, bug #139612 (diff)
downloadgentoo-2-87ebbee8174fb3d1d0d6a6080052a9bab9691c70.tar.gz
gentoo-2-87ebbee8174fb3d1d0d6a6080052a9bab9691c70.tar.bz2
gentoo-2-87ebbee8174fb3d1d0d6a6080052a9bab9691c70.zip
Fix issues from bug #135005.
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'mail-mta/courier')
-rw-r--r--mail-mta/courier/ChangeLog7
-rw-r--r--mail-mta/courier/courier-0.53.2.ebuild16
-rw-r--r--mail-mta/courier/files/mailer.conf4
3 files changed, 23 insertions, 4 deletions
diff --git a/mail-mta/courier/ChangeLog b/mail-mta/courier/ChangeLog
index 04a894dda3cd..3ced55710709 100644
--- a/mail-mta/courier/ChangeLog
+++ b/mail-mta/courier/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-mta/courier
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/ChangeLog,v 1.71 2006/07/12 04:38:42 tsunam Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/ChangeLog,v 1.72 2006/07/14 17:11:38 chtekk Exp $
+
+ 14 Jul 2006; Luca Longinotti <chtekk@gentoo.org> files/mailer.conf,
+ courier-0.53.2.ebuild:
+ Fix bug in src_test and correct mailer.conf, thanks to Jason Wever on bug
+ #135005.
12 Jul 2006; Joshua Jackson <tsunam@gentoo.org> courier-0.52.2.ebuild:
Stable x86; security bug #135005
diff --git a/mail-mta/courier/courier-0.53.2.ebuild b/mail-mta/courier/courier-0.53.2.ebuild
index f868625d35c7..25cb1dc49f3e 100644
--- a/mail-mta/courier/courier-0.53.2.ebuild
+++ b/mail-mta/courier/courier-0.53.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.53.2.ebuild,v 1.1 2006/07/11 00:21:53 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.53.2.ebuild,v 1.2 2006/07/14 17:11:38 chtekk Exp $
inherit eutils gnuconfig flag-o-matic
@@ -265,6 +265,20 @@ src_install() {
fi
}
+src_test() {
+ addpredict /
+ vecho ">>> Test phase [check]: ${CATEGORY}/${PF}"
+ if hasq userpriv ${FEATURES} ; then
+ if ! emake -j1 check; then
+ hasq test ${FEATURES} && die "Make check failed. See above for details."
+ hasq test ${FEATURES} || eerror "Make check failed. See above for details."
+ fi
+ else
+ hasq test ${FEATURES} && eerror "Make check needs FEATURES="userpriv" to work."
+ fi
+ SANDBOX_PREDICT="${SANDBOX_PREDICT%:/}"
+}
+
pkg_postinst() {
use fam && einfo "fam daemon is needed for courier-imapd" \
|| ewarn "courier was built without fam support"
diff --git a/mail-mta/courier/files/mailer.conf b/mail-mta/courier/files/mailer.conf
index bb1f3eee8251..a97cbf6ce63e 100644
--- a/mail-mta/courier/files/mailer.conf
+++ b/mail-mta/courier/files/mailer.conf
@@ -1,6 +1,6 @@
# Execute the "real" sendmail program, named /usr/sbin/sendmail
#
-sendmail /usr/sbin/sendmail.courier
-send-mail /usr/sbin/sendmail.courier
+sendmail /usr/bin/sendmail.courier
+send-mail /usr/bin/sendmail.courier
mailq /usr/bin/mailq.courier
rmail /usr/bin/rmail.courier