summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLim Swee Tat <st_lim@gentoo.org>2005-01-21 15:39:00 +0000
committerLim Swee Tat <st_lim@gentoo.org>2005-01-21 15:39:00 +0000
commitfd6330f09ef63dc694a261a20dca259734bf26e7 (patch)
treef6a3a6f16d938a77437e7ef3a3944889b770e0d5 /mail-filter
parentadd missing patch for hardened (diff)
downloadgentoo-2-fd6330f09ef63dc694a261a20dca259734bf26e7.tar.gz
gentoo-2-fd6330f09ef63dc694a261a20dca259734bf26e7.tar.bz2
gentoo-2-fd6330f09ef63dc694a261a20dca259734bf26e7.zip
Trying to fix bug #78768
(Portage version: 2.0.51-r14)
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/dspam/ChangeLog10
-rw-r--r--mail-filter/dspam/dspam-3.2.4.ebuild8
-rw-r--r--mail-filter/dspam/dspam-3.2.6.ebuild10
-rw-r--r--mail-filter/dspam/dspam-3.3.11.ebuild14
-rw-r--r--mail-filter/dspam/dspam-3.3.8.ebuild14
-rw-r--r--mail-filter/dspam/dspam-3.4_beta1.ebuild19
6 files changed, 36 insertions, 39 deletions
diff --git a/mail-filter/dspam/ChangeLog b/mail-filter/dspam/ChangeLog
index 28fdaf438678..4adfe1a42009 100644
--- a/mail-filter/dspam/ChangeLog
+++ b/mail-filter/dspam/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for mail-filter/dspam
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/ChangeLog,v 1.39 2005/01/20 01:20:54 st_lim Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/ChangeLog,v 1.40 2005/01/21 15:39:00 st_lim Exp $
+
+*dspam-3.4_beta1 (21 Jan 2005)
+
+ 21 Jan 2005; Lim Swee Tat <st_lim@gentoo.org> dspam-3.2.4.ebuild,
+ dspam-3.2.6.ebuild, dspam-3.3.11.ebuild, dspam-3.3.8.ebuild,
+ dspam-3.4_beta1.ebuild:
+ Trying to fix bug #78768
+ Changing dspam to a userid of 26, one after 25.
20 Jan 2005; Lim Swee Tat <st_lim@gentoo.org> :
Added courier as a dependency for maildrop
diff --git a/mail-filter/dspam/dspam-3.2.4.ebuild b/mail-filter/dspam/dspam-3.2.4.ebuild
index 819d2110e231..7189627bcca6 100644
--- a/mail-filter/dspam/dspam-3.2.4.ebuild
+++ b/mail-filter/dspam/dspam-3.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/dspam-3.2.4.ebuild,v 1.5 2005/01/20 01:20:54 st_lim Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/dspam-3.2.4.ebuild,v 1.6 2005/01/21 15:39:00 st_lim Exp $
inherit eutils
@@ -14,7 +14,7 @@ IUSE="cyrus debug exim mysql maildrop neural oci8 postgres procmail sqlite large
DEPEND="exim? ( >=mail-mta/exim-4.34 )
mysql? ( >=dev-db/mysql-3.23 ) || ( >=sys-libs/db-4.0 )
sqlite? ( <dev-db/sqlite-3 )
- maildrop? ( >=mail-filter/maildrop-1.5.3 ) || ( >=mail-mta/courier-0.46 )
+ maildrop? (( >=mail-filter/maildrop-1.5.3 ) || ( >=mail-mta/courier-0.46))
postgres? ( >=dev-db/postgresql-7.4.3 )
procmail? ( >=mail-filter/procmail-3.22 )
x86? ( cyrus? ( >=net-mail/cyrus-imapd-2.1.15 ) )
@@ -53,8 +53,8 @@ pkg_setup() {
ewarn "(Control-C to abort)..."
epause 30
fi
- id dspam 2>/dev/null || enewgroup dspam 65532
- id dspam 2>/dev/null || enewuser dspam 65532 /bin/bash ${HOMEDIR} dspam
+ id dspam 2>/dev/null || enewgroup dspam 26
+ id dspam 2>/dev/null || enewuser dspam 26 /bin/bash ${HOMEDIR} dspam
}
src_compile() {
diff --git a/mail-filter/dspam/dspam-3.2.6.ebuild b/mail-filter/dspam/dspam-3.2.6.ebuild
index 205ad62ab4da..12f20ce9e439 100644
--- a/mail-filter/dspam/dspam-3.2.6.ebuild
+++ b/mail-filter/dspam/dspam-3.2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/dspam-3.2.6.ebuild,v 1.2 2005/01/20 01:20:54 st_lim Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/dspam-3.2.6.ebuild,v 1.3 2005/01/21 15:39:00 st_lim Exp $
inherit eutils
@@ -14,14 +14,14 @@ IUSE="cyrus debug exim mysql maildrop neural oci8 postgres procmail sqlite large
DEPEND="exim? ( >=mail-mta/exim-4.34 )
mysql? ( >=dev-db/mysql-3.23 ) || ( >=sys-libs/db-4.0 )
sqlite? ( <dev-db/sqlite-3 )
- maildrop? ( >=mail-filter/maildrop-1.5.3 ) || ( >=mail-mta/courier-0.46 )
+ maildrop? (( >=mail-filter/maildrop-1.5.3 ) || ( >=mail-mta/courier-0.46))
postgres? ( >=dev-db/postgresql-7.4.3 )
procmail? ( >=mail-filter/procmail-3.22 )
x86? ( cyrus? ( >=net-mail/cyrus-imapd-2.1.15 ) )
"
RDEPEND="sys-apps/cronbase
app-admin/logrotate"
-KEYWORDS="x86 ~ppc ~alpha"
+KEYWORDS="~x86 ~ppc ~alpha"
SLOT="0"
# some FHS-like structure
@@ -53,8 +53,8 @@ pkg_setup() {
ewarn "(Control-C to abort)..."
epause 30
fi
- id dspam 2>/dev/null || enewgroup dspam 65532
- id dspam 2>/dev/null || enewuser dspam 65532 /bin/bash ${HOMEDIR} dspam
+ id dspam 2>/dev/null || enewgroup dspam 26
+ id dspam 2>/dev/null || enewuser dspam 26 /bin/bash ${HOMEDIR} dspam
}
src_compile() {
diff --git a/mail-filter/dspam/dspam-3.3.11.ebuild b/mail-filter/dspam/dspam-3.3.11.ebuild
index 5076358d79e9..342b71789136 100644
--- a/mail-filter/dspam/dspam-3.3.11.ebuild
+++ b/mail-filter/dspam/dspam-3.3.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/dspam-3.3.11.ebuild,v 1.4 2005/01/20 01:20:54 st_lim Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/dspam-3.3.11.ebuild,v 1.5 2005/01/21 15:39:00 st_lim Exp $
inherit eutils
@@ -11,14 +11,10 @@ SRC_URI="http://dspam.nuclearelephant.com/sources/${PN}-${PV}.tar.gz
HOMEPAGE="http://dspam.nuclearelephant.com/"
LICENSE="GPL-2"
-IUSE="cyrus debug exim mysql maildrop neural oci8 postgres procmail sqlite large-domain"
-DEPEND="exim? ( >=mail-mta/exim-4.34 )
- mysql? ( >=dev-db/mysql-3.23 ) || ( >=sys-libs/db-4.0 )
+IUSE="debug mysql neural oci8 postgres sqlite large-domain"
+DEPEND="mysql? ( >=dev-db/mysql-3.23 ) || ( >=sys-libs/db-4.0 )
sqlite? ( <dev-db/sqlite-3 )
- maildrop? ( >=mail-filter/maildrop-1.5.3 ) || ( >=mail-mta/courier-0.46 )
postgres? ( >=dev-db/postgresql-7.4.3 )
- procmail? ( >=mail-filter/procmail-3.22 )
- x86? ( cyrus? ( >=net-mail/cyrus-imapd-2.1.15 ) )
"
RDEPEND="sys-apps/cronbase
app-admin/logrotate"
@@ -54,8 +50,8 @@ pkg_setup() {
ewarn "(Control-C to abort)..."
epause 30
fi
- id dspam 2>/dev/null || enewgroup dspam 65532
- id dspam 2>/dev/null || enewuser dspam 65532 /bin/bash ${HOMEDIR} dspam
+ id dspam 2>/dev/null || enewgroup dspam 26
+ id dspam 2>/dev/null || enewuser dspam 26 /bin/bash ${HOMEDIR} dspam
}
src_compile() {
diff --git a/mail-filter/dspam/dspam-3.3.8.ebuild b/mail-filter/dspam/dspam-3.3.8.ebuild
index cfb0c9a24dd5..80de6271bdfd 100644
--- a/mail-filter/dspam/dspam-3.3.8.ebuild
+++ b/mail-filter/dspam/dspam-3.3.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/dspam-3.3.8.ebuild,v 1.5 2005/01/20 01:20:54 st_lim Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/dspam-3.3.8.ebuild,v 1.6 2005/01/21 15:39:00 st_lim Exp $
inherit eutils
@@ -10,14 +10,10 @@ SRC_URI="http://dspam.nuclearelephant.com/sources/${PN}-${PV}.tar.gz"
HOMEPAGE="http://dspam.nuclearelephant.com/"
LICENSE="GPL-2"
-IUSE="cyrus debug exim mysql maildrop neural oci8 postgres procmail sqlite large-domain"
-DEPEND="exim? ( >=mail-mta/exim-4.34 )
- mysql? ( >=dev-db/mysql-3.23 ) || ( >=sys-libs/db-4.0 )
+IUSE="debug mysql neural oci8 postgres sqlite large-domain"
+DEPEND="mysql? ( >=dev-db/mysql-3.23 ) || ( >=sys-libs/db-4.0 )
sqlite? ( <dev-db/sqlite-3 )
- maildrop? ( >=mail-filter/maildrop-1.5.3 ) || ( >=mail-mta/courier-0.46 )
postgres? ( >=dev-db/postgresql-7.4.3 )
- procmail? ( >=mail-filter/procmail-3.22 )
- x86? ( cyrus? ( >=net-mail/cyrus-imapd-2.1.15 ) )
"
RDEPEND="sys-apps/cronbase
app-admin/logrotate"
@@ -53,8 +49,8 @@ pkg_setup() {
ewarn "(Control-C to abort)..."
epause 30
fi
- id dspam 2>/dev/null || enewgroup dspam 65532
- id dspam 2>/dev/null || enewuser dspam 65532 /bin/bash ${HOMEDIR} dspam
+ id dspam 2>/dev/null || enewgroup dspam 26
+ id dspam 2>/dev/null || enewuser dspam 26 /bin/bash ${HOMEDIR} dspam
}
src_compile() {
diff --git a/mail-filter/dspam/dspam-3.4_beta1.ebuild b/mail-filter/dspam/dspam-3.4_beta1.ebuild
index da953136e6f8..1ef6a63f1fff 100644
--- a/mail-filter/dspam/dspam-3.4_beta1.ebuild
+++ b/mail-filter/dspam/dspam-3.4_beta1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/dspam-3.4_beta1.ebuild,v 1.2 2005/01/20 01:20:54 st_lim Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/dspam-3.4_beta1.ebuild,v 1.3 2005/01/21 15:39:00 st_lim Exp $
inherit eutils
@@ -12,14 +12,11 @@ SRC_URI="http://dspam.nuclearelephant.com/sources/${PN}-${MY_PV}.tar.gz
HOMEPAGE="http://dspam.nuclearelephant.com/"
LICENSE="GPL-2"
-IUSE="cyrus debug exim mysql maildrop neural oci8 postgres procmail sqlite large-domain"
-DEPEND="exim? ( >=mail-mta/exim-4.34 )
- mysql? ( >=dev-db/mysql-3.23 ) || ( >=sys-libs/db-4.0 )
+IUSE="debug mysql neural oci8 postgres sqlite large-domain"
+DEPEND="mysql? ( >=dev-db/mysql-3.23 ) || ( >=sys-libs/db-4.0 )
sqlite? ( <dev-db/sqlite-3 )
- maildrop? ( >=mail-filter/maildrop-1.5.3 ) || ( >=mail-mta/courier-0.46 )
+ sqlite3? ( >=dev-db/sqlite-3 )
postgres? ( >=dev-db/postgresql-7.4.3 )
- procmail? ( >=mail-filter/procmail-3.22 )
- x86? ( cyrus? ( >=net-mail/cyrus-imapd-2.1.15 ) )
"
RDEPEND="sys-apps/cronbase
app-admin/logrotate"
@@ -39,7 +36,7 @@ pkg_setup() {
(use postgres && use sqlite) || \
(use sqlite && use oci8); then
echo
- ewarn "You have two of either \"mysql\", \"postgres\", \"oci8\" or \"sqlite\" in your USE flags."
+ ewarn "You have two of either \"mysql\", \"postgres\", \"oci8\", \"sqlite\" or \"sqlite3\" in your USE flags."
ewarn "Will default to MySQL as your dspam database backend."
ewarn "If you want to build with Postgres/Oracle/SQLite support; hit Control-C now."
ewarn "Change your USE flag -mysql and emerge again."
@@ -47,7 +44,7 @@ pkg_setup() {
has_version ">=sys-apps/portage-2.0.50" && (
einfo "It would be best practice to add the set of USE flags that you use for this"
einfo "package to the file: /etc/portage/package.use. Example:"
- einfo "\`echo \"net-mail/dspam -mysql postgres -oci8 -sqlite\" >> /etc/portage/package.use\`"
+ einfo "\`echo \"net-mail/dspam -mysql postgres -oci8 -sqlite -sqlite3\" >> /etc/portage/package.use\`"
einfo "to build dspam with Postgres database as your dspam backend."
)
echo
@@ -55,8 +52,8 @@ pkg_setup() {
ewarn "(Control-C to abort)..."
epause 30
fi
- id dspam 2>/dev/null || enewgroup dspam 65532
- id dspam 2>/dev/null || enewuser dspam 65532 /bin/bash ${HOMEDIR} dspam
+ id dspam 2>/dev/null || enewgroup dspam 26
+ id dspam 2>/dev/null || enewuser dspam 26 /bin/bash ${HOMEDIR} dspam
}
src_compile() {