summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2006-12-09 15:48:01 +0000
committerTorsten Veller <tove@gentoo.org>2006-12-09 15:48:01 +0000
commitfcfde27bd1bbf26c5451531867f8192e1d60a65e (patch)
treea92621f778e6c97c764f211f68e12a6fb504fa63 /mail-filter
parentStable on ppc wrt bug 156504 (diff)
downloadgentoo-2-fcfde27bd1bbf26c5451531867f8192e1d60a65e.tar.gz
gentoo-2-fcfde27bd1bbf26c5451531867f8192e1d60a65e.tar.bz2
gentoo-2-fcfde27bd1bbf26c5451531867f8192e1d60a65e.zip
Fixes parallel make failure with included gsl (bug #112638).
(Portage version: 2.1.2_rc3)
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/bogofilter/ChangeLog7
-rw-r--r--mail-filter/bogofilter/bogofilter-0.92.8.ebuild4
-rw-r--r--mail-filter/bogofilter/bogofilter-1.1.3.ebuild17
-rw-r--r--mail-filter/bogofilter/files/1.1.3-patch.1142.Makefile.am59
4 files changed, 81 insertions, 6 deletions
diff --git a/mail-filter/bogofilter/ChangeLog b/mail-filter/bogofilter/ChangeLog
index 1aa0344a2714..e054b16a3ea9 100644
--- a/mail-filter/bogofilter/ChangeLog
+++ b/mail-filter/bogofilter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-filter/bogofilter
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/ChangeLog,v 1.75 2006/12/03 14:35:18 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/ChangeLog,v 1.76 2006/12/09 15:48:01 tove Exp $
+
+ 09 Dec 2006; Torsten Veller <tove@gentoo.org>
+ +files/1.1.3-patch.1142.Makefile.am, bogofilter-1.1.3.ebuild:
+ Fixes parallel make failure with included gsl (bug #112638). Thanks to
+ Martin von Gagern and David Relson.
*bogofilter-1.1.3 (03 Dec 2006)
diff --git a/mail-filter/bogofilter/bogofilter-0.92.8.ebuild b/mail-filter/bogofilter/bogofilter-0.92.8.ebuild
index 8d023e81580f..90fe53dcdc8a 100644
--- a/mail-filter/bogofilter/bogofilter-0.92.8.ebuild
+++ b/mail-filter/bogofilter/bogofilter-0.92.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/bogofilter-0.92.8.ebuild,v 1.12 2006/10/29 09:18:20 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/bogofilter-0.92.8.ebuild,v 1.13 2006/12/09 15:48:01 tove Exp $
DESCRIPTION="Bayesian spam filter designed with fast algorithms, and tuned for speed."
HOMEPAGE="http://bogofilter.sourceforge.net/"
@@ -14,7 +14,7 @@ IUSE="doc"
RDEPEND="virtual/libc
>=sys-libs/db-3.2"
DEPEND="${DEPEND}
- !ppc64? ( doc? ( app-text/xmlto ) )"
+ doc? ( app-text/xmlto )"
src_compile() {
econf --with-included-gsl || die "configure failed"
diff --git a/mail-filter/bogofilter/bogofilter-1.1.3.ebuild b/mail-filter/bogofilter/bogofilter-1.1.3.ebuild
index e82145013f3f..0447cb6d2037 100644
--- a/mail-filter/bogofilter/bogofilter-1.1.3.ebuild
+++ b/mail-filter/bogofilter/bogofilter-1.1.3.ebuild
@@ -1,6 +1,11 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/bogofilter-1.1.3.ebuild,v 1.1 2006/12/03 14:35:18 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/bogofilter-1.1.3.ebuild,v 1.2 2006/12/09 15:48:01 tove Exp $
+
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=latest
+
+inherit eutils autotools
DESCRIPTION="Bayesian spam filter designed with fast algorithms, and tuned for speed."
HOMEPAGE="http://bogofilter.sourceforge.net/"
@@ -16,10 +21,16 @@ DEPEND="virtual/libiconv
!berkdb? (
sqlite? ( >=dev-db/sqlite-3.2.6 )
!sqlite? ( >=sys-libs/db-3.2 ) )
- gsl? ( sci-libs/gsl )
- >=sys-devel/flex-2.5.33"
+ gsl? ( sci-libs/gsl )"
# app-arch/pax" # only needed for bf_tar
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/1.1.3-patch.1142.Makefile.am
+ eautomake
+}
+
src_compile() {
local myconf=""
myconf="$(use_with !gsl included-gsl)"
diff --git a/mail-filter/bogofilter/files/1.1.3-patch.1142.Makefile.am b/mail-filter/bogofilter/files/1.1.3-patch.1142.Makefile.am
new file mode 100644
index 000000000000..d33e1abca715
--- /dev/null
+++ b/mail-filter/bogofilter/files/1.1.3-patch.1142.Makefile.am
@@ -0,0 +1,59 @@
+Index: src/Makefile.am
+===================================================================
+RCS file: /cvsroot/bogofilter/bogofilter/src/Makefile.am,v
+retrieving revision 1.141
+retrieving revision 1.142
+diff -u -B -r1.141 -r1.142
+--- src/Makefile.am 30 Nov 2006 00:14:16 -0000 1.141
++++ src/Makefile.am 9 Dec 2006 13:53:57 -0000 1.142
+@@ -12,22 +12,6 @@
+
+ noinst_LIBRARIES = libbogofilter.a
+
+-if NEED_GSL
+-libbf_gsl_a_CFLAGS=$(AM_CFLAGS) -DRENAMEFILES
+-libbf_gsl_a_SOURCES= \
+-../gsl/cdf/chisq.c ../gsl/cdf/gamma.c \
+-../gsl/specfunc/gamma_inc.c ../gsl/err/error.c \
+-../gsl/sys/infnan.c ../gsl/sys/fdiv.c \
+-../gsl/specfunc/exp.c ../gsl/specfunc/trig.c \
+-../gsl/specfunc/log.c ../gsl/specfunc/psi.c \
+-../gsl/specfunc/zeta.c ../gsl/specfunc/elementary.c \
+-../gsl/err/stream.c ../gsl/specfunc/expint.c \
+-../gsl/specfunc/erfc.c ../gsl/sys/coerce.c \
+-../gsl/sys/pow_int.c ../gsl/sys/minmax.c
+-noinst_LIBRARIES += libbf_gsl.a
+-libbf_gsl_a_CPPFLAGS= -I$(top_srcdir)
+-endif
+-
+ if USE_GCC4
+ AM_CPPFLAGS = -iquote$(top_srcdir)/gnugetopt -iquote$(top_srcdir)/trio \
+ -I$(srcdir) @GSL_CFLAGS@ -I$(top_srcdir)/gsl/specfunc -I$(top_srcdir)
+@@ -59,8 +43,27 @@
+ bogofilter_LDADD = $(LDADD) $(LIBDB) $(GSL_LIBS)
+ bogoutil_LDADD = $(LDADD) $(LIBDB)
+ configtest_LDADD = $(LDADD) $(LIBDB)
++bogofilter_DEPENDENCIES = $(LDADD)
++
++if NEED_GSL
++libbf_gsl_a_CFLAGS=$(AM_CFLAGS) -DRENAMEFILES
++libbf_gsl_a_SOURCES= \
++../gsl/cdf/chisq.c ../gsl/cdf/gamma.c \
++../gsl/specfunc/gamma_inc.c ../gsl/err/error.c \
++../gsl/sys/infnan.c ../gsl/sys/fdiv.c \
++../gsl/specfunc/exp.c ../gsl/specfunc/trig.c \
++../gsl/specfunc/log.c ../gsl/specfunc/psi.c \
++../gsl/specfunc/zeta.c ../gsl/specfunc/elementary.c \
++../gsl/err/stream.c ../gsl/specfunc/expint.c \
++../gsl/specfunc/erfc.c ../gsl/sys/coerce.c \
++../gsl/sys/pow_int.c ../gsl/sys/minmax.c
++noinst_LIBRARIES += libbf_gsl.a
++libbf_gsl_a_CPPFLAGS= -I$(top_srcdir)
++bogofilter_DEPENDENCIES += libbf_gsl.a
++endif
+
+ EXTRA_PROGRAMS=panicenv
++
+ panicenv_SOURCES=panicenv.c
+ panicenv_LDADD=$(LIBDB)
+