summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-02-22 09:44:41 +0000
committerTorsten Veller <tove@gentoo.org>2009-02-22 09:44:41 +0000
commitf78208441832fbcaaa4c18cf98598eeb01613866 (patch)
tree0f07ad66940d79c93f164dd9d1a669ce21810340 /mail-filter
parentAdding ppc keyword (diff)
downloadgentoo-2-f78208441832fbcaaa4c18cf98598eeb01613866.tar.gz
gentoo-2-f78208441832fbcaaa4c18cf98598eeb01613866.tar.bz2
gentoo-2-f78208441832fbcaaa4c18cf98598eeb01613866.zip
Version bump
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/bogofilter/ChangeLog9
-rw-r--r--mail-filter/bogofilter/bogofilter-1.2.0.ebuild77
2 files changed, 84 insertions, 2 deletions
diff --git a/mail-filter/bogofilter/ChangeLog b/mail-filter/bogofilter/ChangeLog
index e99fcaaa5f97..484eeaec3a5b 100644
--- a/mail-filter/bogofilter/ChangeLog
+++ b/mail-filter/bogofilter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-filter/bogofilter
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/ChangeLog,v 1.111 2008/11/23 08:34:08 tove Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/ChangeLog,v 1.112 2009/02/22 09:44:41 tove Exp $
+
+*bogofilter-1.2.0 (22 Feb 2009)
+
+ 22 Feb 2009; Torsten Veller <tove@gentoo.org> +bogofilter-1.2.0.ebuild:
+ Version bump
23 Nov 2008; Torsten Veller <tove@gentoo.org> -bogofilter-1.1.5.ebuild,
-bogofilter-1.1.6.ebuild:
diff --git a/mail-filter/bogofilter/bogofilter-1.2.0.ebuild b/mail-filter/bogofilter/bogofilter-1.2.0.ebuild
new file mode 100644
index 000000000000..a5c0b0e826a4
--- /dev/null
+++ b/mail-filter/bogofilter/bogofilter-1.2.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/bogofilter-1.2.0.ebuild,v 1.1 2009/02/22 09:44:41 tove Exp $
+
+inherit db-use flag-o-matic
+
+DESCRIPTION="Bayesian spam filter designed with fast algorithms, and tuned for speed."
+HOMEPAGE="http://bogofilter.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="berkdb sqlite"
+
+DEPEND="virtual/libiconv
+ berkdb? ( >=sys-libs/db-3.2 )
+ !berkdb? (
+ sqlite? ( >=dev-db/sqlite-3.5.4 )
+ !sqlite? ( >=sys-libs/db-3.2 ) )
+ sci-libs/gsl"
+# app-arch/pax" # only needed for bf_tar
+
+src_compile() {
+ local myconf="" berkdb=true
+ myconf="--without-included-gsl"
+
+ # determine backend: berkdb *is* default
+ if use berkdb && use sqlite ; then
+ elog "Both useflags berkdb and sqlite are in USE:"
+ elog "Using berkdb as database backend."
+ elif use sqlite ; then
+ myconf="${myconf} --with-database=sqlite"
+ berkdb=false
+ elif ! use berkdb ; then
+ elog "Neither berkdb nor sqlite are in USE:"
+ elog "Using berkdb as database backend."
+ fi
+
+ # Include the right berkdb headers for FreeBSD
+ if ${berkdb} ; then
+ append-flags "-I$(db_includedir)"
+ fi
+
+ econf ${myconf} || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ exeinto /usr/share/${PN}/contrib
+ doexe contrib/{bogofilter-qfe,parmtest,randomtrain}.sh \
+ contrib/{bfproxy,bogominitrain,mime.get.rfc822,printmaildir}.pl \
+ contrib/{spamitarium,stripsearch}.pl || die "doexec failed"
+
+ insinto /usr/share/${PN}/contrib
+ doins contrib/{README.*,dot-qmail-bogofilter-default} \
+ contrib/{bogogrep.c,bogo.R,bogofilter-milter.pl,*.example} \
+ contrib/vm-bogofilter.el \
+ contrib/{trainbogo,scramble}.sh || die "doins failed"
+
+ dodoc AUTHORS NEWS README RELEASE.NOTES* TODO GETTING.STARTED \
+ doc/integrating-with-* doc/README.{db,sqlite} || die "dodoc failed"
+
+ dohtml doc/*.html
+
+ dodir /usr/share/doc/${PF}/samples
+ mv "${D}"/etc/bogofilter.cf.example "${D}"/usr/share/doc/${PF}/samples/
+ rmdir "${D}"/etc
+}
+
+pkg_postinst() {
+ echo
+ elog "If you need \"${ROOT}usr/bin/bf_tar\" please install app-arch/pax."
+ echo
+}