summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-02-13 06:03:51 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-02-13 06:03:51 +0000
commitee36a672ac7d94c82f6b4d1fd8ca4a482c430442 (patch)
tree2cc2bd66d8cb37c6715a4557993eaa9ac9ca393a /mail-filter
parentold (diff)
downloadgentoo-2-ee36a672ac7d94c82f6b4d1fd8ca4a482c430442.tar.gz
gentoo-2-ee36a672ac7d94c82f6b4d1fd8ca4a482c430442.tar.bz2
gentoo-2-ee36a672ac7d94c82f6b4d1fd8ca4a482c430442.zip
Better automatize clamav integration
(Portage version: 2.1.3.19)
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/qmail-scanner/ChangeLog8
-rw-r--r--mail-filter/qmail-scanner/qmail-scanner-2.02-r1.ebuild (renamed from mail-filter/qmail-scanner/qmail-scanner-2.02.ebuild)18
2 files changed, 17 insertions, 9 deletions
diff --git a/mail-filter/qmail-scanner/ChangeLog b/mail-filter/qmail-scanner/ChangeLog
index efb54229d62c..e8946b4d8908 100644
--- a/mail-filter/qmail-scanner/ChangeLog
+++ b/mail-filter/qmail-scanner/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-filter/qmail-scanner
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/qmail-scanner/ChangeLog,v 1.40 2008/01/22 22:35:08 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/qmail-scanner/ChangeLog,v 1.41 2008/02/13 06:03:51 tupone Exp $
+
+*qmail-scanner-2.02-r1 (13 Feb 2008)
+
+ 13 Feb 2008; <atupone@gentoo.org> -qmail-scanner-2.02.ebuild,
+ +qmail-scanner-2.02-r1.ebuild:
+ Better automatize clamav integration
22 Jan 2008; Tupone Alfredo <tupone@gentoo.org> qmail-scanner-2.02.ebuild:
Fixing instructions for clamav integration
diff --git a/mail-filter/qmail-scanner/qmail-scanner-2.02.ebuild b/mail-filter/qmail-scanner/qmail-scanner-2.02-r1.ebuild
index 3fc80d863ef6..0a59bd7d61f1 100644
--- a/mail-filter/qmail-scanner/qmail-scanner-2.02.ebuild
+++ b/mail-filter/qmail-scanner/qmail-scanner-2.02-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/qmail-scanner/qmail-scanner-2.02.ebuild,v 1.2 2008/01/22 22:35:08 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/qmail-scanner/qmail-scanner-2.02-r1.ebuild,v 1.1 2008/02/13 06:03:51 tupone Exp $
inherit fixheadtails toolchain-funcs eutils
@@ -10,7 +10,7 @@ HOMEPAGE="http://qmail-scanner.sourceforge.net/"
SRC_URI="mirror://sourceforge/qmail-scanner/${P}.tgz
http://toribio.apollinare.org/qmail-scanner/download/q-s-${PV}st-${Q_S_DATE}.patch.gz"
-IUSE="spamassassin"
+IUSE="clamav spamassassin"
LICENSE="GPL-2"
SLOT="0"
@@ -26,11 +26,13 @@ DEPEND=">=dev-lang/perl-5.6.1-r1
>=app-arch/unzip-5.42-r1
sys-process/daemontools
virtual/antivirus
+ clamav? ( app-antivirus/clamav )
spamassassin? ( >=mail-filter/spamassassin-2.64 )"
pkg_setup() {
enewgroup qscand 210
enewuser qscand 210 -1 /var/spool/qscan qscand
+ use clamav && usermod -a -G qscand,nofiles clamav
}
pkg_preinst() {
@@ -179,10 +181,10 @@ pkg_postinst () {
ewarn "user is changed. Please update it manually to /var/spool/qscan"
ewarn "or remove the user and emerge again this package"
- ewarn "For an integration with clamav, clamav user should have access"
- ewarn "to files in the qscand and nofiles group."
- ewarn "To allow that, add clamav user to the qscan and nofiles group and"
- ewarn "comment-out in /etc/clamd.conf AllowSupplementaryGroups putting yes."
- ewarn "After that, restart clamd with"
- ewarn "/etc/init.d/clamd restart"
+ if use clamav; then
+ ewarn "To allow clamav integration comment-out in /etc/clamd.conf:"
+ ewarn "AllowSupplementaryGroups putting yes."
+ ewarn "After that, restart clamd with"
+ ewarn "/etc/init.d/clamd restart"
+ fi
}