summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2010-06-15 12:00:07 +0000
committerDaniel Black <dragonheart@gentoo.org>2010-06-15 12:00:07 +0000
commitb7210951f71f63a9b6d8d4bbdb22824119970e5b (patch)
treeff9c97fc27640fdf59a19df1079faf3391305167 /mail-filter
parentQA, imported prefix changes (diff)
downloadgentoo-2-b7210951f71f63a9b6d8d4bbdb22824119970e5b.tar.gz
gentoo-2-b7210951f71f63a9b6d8d4bbdb22824119970e5b.tar.bz2
gentoo-2-b7210951f71f63a9b6d8d4bbdb22824119970e5b.zip
Pidfile now is in the opendkim.conf file rather than as a command line argument. Command line arguement was removed in 2.1.0. Bug report as per #323245 thanks to Guillaume Castagnino
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/opendkim/ChangeLog8
-rw-r--r--mail-filter/opendkim/files/opendkim.init18
-rw-r--r--mail-filter/opendkim/opendkim-2.0.3.ebuild3
-rw-r--r--mail-filter/opendkim/opendkim-2.0.4.ebuild3
-rw-r--r--mail-filter/opendkim/opendkim-2.1.0.ebuild3
5 files changed, 22 insertions, 13 deletions
diff --git a/mail-filter/opendkim/ChangeLog b/mail-filter/opendkim/ChangeLog
index 32341837047f..aeb00363ea54 100644
--- a/mail-filter/opendkim/ChangeLog
+++ b/mail-filter/opendkim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-filter/opendkim
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/opendkim/ChangeLog,v 1.16 2010/06/07 23:07:52 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/opendkim/ChangeLog,v 1.17 2010/06/15 12:00:07 dragonheart Exp $
+
+ 15 Jun 2010; Daniel Black <dragonheart@gentoo.org> opendkim-2.0.3.ebuild,
+ opendkim-2.0.4.ebuild, opendkim-2.1.0.ebuild, files/opendkim.init:
+ Pidfile now is in the opendkim.conf file rather than as a command line
+ argument. Command line arguement was removed in 2.1.0. Bug report as per
+ #323245 thanks to Guillaume Castagnino
*opendkim-2.1.0 (07 Jun 2010)
diff --git a/mail-filter/opendkim/files/opendkim.init b/mail-filter/opendkim/files/opendkim.init
index ddf3d5548610..9e295f7398ed 100644
--- a/mail-filter/opendkim/files/opendkim.init
+++ b/mail-filter/opendkim/files/opendkim.init
@@ -1,10 +1,9 @@
#!/sbin/runscript
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/opendkim/files/opendkim.init,v 1.1 2009/10/06 09:10:42 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/opendkim/files/opendkim.init,v 1.2 2010/06/15 12:00:07 dragonheart Exp $
CONFFILE=/etc/opendkim/${SVCNAME}.conf
-PIDFILE=/var/run/opendkim/${SVCNAME}.pid
depend() {
use dns logger net
@@ -12,19 +11,18 @@ depend() {
check_cfg() {
+ PIDFILE=$(sed -ne 's/^[[:space:]]*PidFile[[:space:]]\+//p' "${CONFFILE}")
if [ ! -f "${CONFFILE}" ] ; then
eerror "Configuration file ${CONFFILE} is missing"
return 1
fi
-
- if egrep -q '^[[:space:]]*Background[[:space:]]+no' "${CONFFILE}" ; then
- eerror "${SVCNAME} service cannot run with Background key set to yes!"
+ if [ -z "${PIDFILE}" ] ; then
+ eerror "Configuration file needs PidFile setting - recommend adding 'PidFile /var/run/opendkim/${SVCNAME}.pid' to ${CONFFILE}"
return 1
fi
- if egrep -q '^[[:space:]]*PidFile[[:space:]]' "${CONFFILE}"; then
- eerror "Please remove PidFile key from your configuration file!"
- eerror "${SVCNAME} is automatically configured to use ${PIDFILE} as pid file."
+ if egrep -q '^[[:space:]]*Background[[:space:]]+no' "${CONFFILE}" ; then
+ eerror "${SVCNAME} service cannot run with Background key set to yes!"
return 1
fi
}
@@ -34,17 +32,19 @@ start() {
# Remove stalled Unix socket if no other process is using it
local UNIX_SOCKET=$(sed -ne 's/^[[:space:]]*Socket[[:space:]]\+\(unix\|local\)://p' "${CONFFILE}")
+
if [ -S "${UNIX_SOCKET}" ] && ! fuser -s "${UNIX_SOCKET}"; then
rm "${UNIX_SOCKET}"
fi
ebegin "Starting OpenDKIM"
start-stop-daemon --start --pidfile "${PIDFILE}" \
- --exec /usr/sbin/opendkim -- -x "${CONFFILE}" -P "${PIDFILE}"
+ --exec /usr/sbin/opendkim -- -x "${CONFFILE}"
eend $?
}
stop() {
+ check_cfg || return 1
ebegin "Stopping OpenDKIM"
start-stop-daemon --stop --pidfile "${PIDFILE}"
eend $?
diff --git a/mail-filter/opendkim/opendkim-2.0.3.ebuild b/mail-filter/opendkim/opendkim-2.0.3.ebuild
index 63b74ebc043f..eac500067c96 100644
--- a/mail-filter/opendkim/opendkim-2.0.3.ebuild
+++ b/mail-filter/opendkim/opendkim-2.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/opendkim/opendkim-2.0.3.ebuild,v 1.1 2010/05/01 01:46:59 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/opendkim/opendkim-2.0.3.ebuild,v 1.2 2010/06/15 12:00:06 dragonheart Exp $
EAPI="2"
@@ -45,6 +45,7 @@ pkg_setup() {
src_prepare() {
sed -i -e 's:/var/db/dkim:/etc/opendkim:g' \
-e 's:/etc/mail:/etc/opendkim:g' \
+ -e 's:^#[[:space:]]*PidFile.*:PidFile /var/run/opendkim/opendkim.pid:' \
opendkim/opendkim.conf.sample
}
diff --git a/mail-filter/opendkim/opendkim-2.0.4.ebuild b/mail-filter/opendkim/opendkim-2.0.4.ebuild
index d220a7ae6b8d..870a11c574f1 100644
--- a/mail-filter/opendkim/opendkim-2.0.4.ebuild
+++ b/mail-filter/opendkim/opendkim-2.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/opendkim/opendkim-2.0.4.ebuild,v 1.1 2010/05/18 08:08:47 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/opendkim/opendkim-2.0.4.ebuild,v 1.2 2010/06/15 12:00:07 dragonheart Exp $
EAPI="2"
@@ -45,6 +45,7 @@ pkg_setup() {
src_prepare() {
sed -i -e 's:/var/db/dkim:/etc/opendkim:g' \
-e 's:/etc/mail:/etc/opendkim:g' \
+ -e 's:^#[[:space:]]*PidFile.*:PidFile /var/run/opendkim/opendkim.pid:' \
opendkim/opendkim.conf.sample
}
diff --git a/mail-filter/opendkim/opendkim-2.1.0.ebuild b/mail-filter/opendkim/opendkim-2.1.0.ebuild
index 6ae140bcb594..1cb5c9c9a272 100644
--- a/mail-filter/opendkim/opendkim-2.1.0.ebuild
+++ b/mail-filter/opendkim/opendkim-2.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/opendkim/opendkim-2.1.0.ebuild,v 1.1 2010/06/07 23:07:52 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/opendkim/opendkim-2.1.0.ebuild,v 1.2 2010/06/15 12:00:07 dragonheart Exp $
EAPI="2"
@@ -45,6 +45,7 @@ pkg_setup() {
src_prepare() {
sed -i -e 's:/var/db/dkim:/etc/opendkim:g' \
-e 's:/etc/mail:/etc/opendkim:g' \
+ -e 's:^#[[:space:]]*PidFile.*:PidFile /var/run/opendkim/opendkim.pid:' \
opendkim/opendkim.conf.sample
}