summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hartmann <ian@gentoo.org>2006-06-06 17:38:22 +0000
committerChristian Hartmann <ian@gentoo.org>2006-06-06 17:38:22 +0000
commit77e600a8491b9890ae60ccd1d0423f82d7a81d25 (patch)
treed445bf9510730d195ac3aa2db5f452a9555d4a87 /mail-filter/spamassassin
parentFixed line 165 typo (diff)
downloadgentoo-2-77e600a8491b9890ae60ccd1d0423f82d7a81d25.tar.gz
gentoo-2-77e600a8491b9890ae60ccd1d0423f82d7a81d25.tar.bz2
gentoo-2-77e600a8491b9890ae60ccd1d0423f82d7a81d25.zip
Version bump; security bug #135746
(Portage version: 2.1_rc4-r2)
Diffstat (limited to 'mail-filter/spamassassin')
-rw-r--r--mail-filter/spamassassin/ChangeLog8
-rw-r--r--mail-filter/spamassassin/files/digest-spamassassin-3.1.33
-rw-r--r--mail-filter/spamassassin/spamassassin-3.1.3.ebuild246
3 files changed, 256 insertions, 1 deletions
diff --git a/mail-filter/spamassassin/ChangeLog b/mail-filter/spamassassin/ChangeLog
index 93bd2aa3cbc4..acfbabc5c8c2 100644
--- a/mail-filter/spamassassin/ChangeLog
+++ b/mail-filter/spamassassin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-filter/spamassassin
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamassassin/ChangeLog,v 1.101 2006/05/26 02:03:11 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamassassin/ChangeLog,v 1.102 2006/06/06 17:38:21 ian Exp $
+
+*spamassassin-3.1.3 (06 Jun 2006)
+
+ 06 Jun 2006; Christian Hartmann <ian@gentoo.org>
+ +spamassassin-3.1.3.ebuild:
+ Version bump; security bug #135746
*spamassassin-3.1.2 (26 May 2006)
diff --git a/mail-filter/spamassassin/files/digest-spamassassin-3.1.3 b/mail-filter/spamassassin/files/digest-spamassassin-3.1.3
new file mode 100644
index 000000000000..d9ab784fb6f6
--- /dev/null
+++ b/mail-filter/spamassassin/files/digest-spamassassin-3.1.3
@@ -0,0 +1,3 @@
+MD5 5f049f0b9fc63585a85593a3c68409bb Mail-SpamAssassin-3.1.3.tar.bz2 975274
+RMD160 a17b5245e577bd1517db40d6d1de50699b0f72b5 Mail-SpamAssassin-3.1.3.tar.bz2 975274
+SHA256 2170ead06852832166585f8b100150864844f8f2790615dc0c5e9c3778572dd4 Mail-SpamAssassin-3.1.3.tar.bz2 975274
diff --git a/mail-filter/spamassassin/spamassassin-3.1.3.ebuild b/mail-filter/spamassassin/spamassassin-3.1.3.ebuild
new file mode 100644
index 000000000000..a7e3ede0800b
--- /dev/null
+++ b/mail-filter/spamassassin/spamassassin-3.1.3.ebuild
@@ -0,0 +1,246 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamassassin/spamassassin-3.1.3.ebuild,v 1.1 2006/06/06 17:38:21 ian Exp $
+
+inherit perl-module eutils
+
+MY_P=Mail-SpamAssassin-${PV//_/-}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="SpamAssassin is an extensible email filter which is used to identify spam."
+HOMEPAGE="http://spamassassin.apache.org/"
+SRC_URI="mirror://apache/spamassassin/source/${MY_P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="berkdb qmail ssl doc ldap mysql postgres sqlite tools ipv6"
+
+DEPEND=">=dev-lang/perl-5.8.2-r1
+ virtual/perl-MIME-Base64
+ >=virtual/perl-PodParser-1.32
+ virtual/perl-Storable
+ virtual/perl-Time-HiRes
+ >=dev-perl/HTML-Parser-3.31
+ >=dev-perl/Net-DNS-0.53
+ dev-perl/Digest-SHA1
+ dev-perl/libwww-perl
+ >=dev-perl/Archive-Tar-1.26
+ app-crypt/gnupg
+ dev-perl/IO-Zlib
+ ssl? (
+ dev-perl/IO-Socket-SSL
+ dev-libs/openssl
+ )
+ berkdb? (
+ virtual/perl-DB_File
+ )
+ ldap? ( dev-perl/perl-ldap )
+ mysql? (
+ dev-perl/DBI
+ dev-perl/DBD-mysql
+ )
+ postgres? (
+ dev-perl/DBI
+ dev-perl/DBD-Pg
+ )
+ sqlite? (
+ dev-perl/DBI
+ dev-perl/DBD-SQLite
+ )
+
+ ipv6? (
+ dev-perl/IO-Socket-INET6
+ )"
+
+src_compile() {
+ # - Set SYSCONFDIR explicitly so we can't get bitten by bug 48205 again
+ # (just to be sure, nobody knows how it could happen in the first place).
+ myconf="SYSCONFDIR=/etc DATADIR=/usr/share/spamassassin"
+
+ # If ssl is enabled, spamc can be built with ssl support
+ if use ssl; then
+ myconf="${myconf} ENABLE_SSL=yes"
+ else
+ myconf="${myconf} ENABLE_SSL=no"
+ fi
+
+ # Set the path to the Perl executable explictly. This will be used to
+ # create the initial sharpbang line in the scripts and might cause
+ # a versioned app name end in there, see
+ # <http://bugs.gentoo.org/show_bug.cgi?id=62276>
+ myconf="${myconf} PERL_BIN=/usr/bin/perl"
+
+ # If you are going to enable taint mode, make sure that the bug where
+ # spamd doesn't start when the PATH contains . is addressed, and make
+ # sure you deal with versions of razor <2.36-r1 not being taint-safe.
+ # <http://bugzilla.spamassassin.org/show_bug.cgi?id=2511> and
+ # <http://spamassassin.org/released/Razor2.patch>.
+ myconf="${myconf} PERL_TAINT=no"
+
+ # No settings needed for 'make all'.
+ mymake=""
+
+ # Neither for 'make install'.
+ myinst=""
+
+ # Add Gentoo tag to make it easier for the upstream devs to spot
+ # possible modifications or patches.
+ version_tag="g${PV:6}${PR}"
+ version_str="${PV//_/-}-${version_tag}"
+
+ # Create the Gentoo config file before Makefile.PL is called so it
+ # is copied later on.
+ echo "version_tag ${version_tag}" > rules/11_gentoo.cf
+
+ # Setting the following env var ensures that no questions are asked.
+ export PERL_MM_USE_DEFAULT=1
+ perl-module_src_prep
+ # Run the autoconf stuff now, just to make the build sequence look more
+ # familiar to the user :) Plus feeding the VERSION_STRING skips some
+ # calls to Perl.
+ make spamc/Makefile VERSION_STRING="${version_str}"
+
+ # Now compile all the stuff selected.
+ perl-module_src_compile
+ if use qmail; then
+ make spamc/qmail-spamc || die building qmail-spamc failed
+ fi
+
+ # Remove the MANIFEST files as they aren't docu files
+ rm -f MANIFEST*
+
+ use doc && make text_html_doc
+}
+
+src_install () {
+ perl-module_src_install
+
+ # Create the stub dir used by sa-update and friends
+ dodir /var/lib/spamassassin
+
+ # Move spamd to sbin where it belongs.
+ dodir /usr/sbin
+ mv "${D}"/usr/bin/spamd "${D}"/usr/sbin/spamd || die
+
+ use qmail && dobin spamc/qmail-spamc
+
+ dosym /etc/mail/spamassassin /etc/spamassassin
+
+ # Disable plugin by default
+ sed -i -e 's/^loadplugin/\#loadplugin/g' ${D}/etc/mail/spamassassin/init.pre
+
+ # Add the init and config scripts.
+ newinitd "${FILESDIR}"/3.0.0-spamd.init spamd
+ newconfd "${FILESDIR}"/3.0.0-spamd.conf spamd
+
+ if use doc; then
+ dodoc NOTICE TRADEMARK CREDITS INSTALL UPGRADE BUGS USAGE \
+ sql/README.bayes sql/README.awl README.ldap procmailrc.example \
+ sample-nonspam.txt sample-spam.txt rules/STATISTICS-set0.txt \
+ STATISTICS-set1.txt STATISTICS-set2.txt STATISTICS-set3.txt \
+ spamd/PROTOCOL
+
+ # Rename some docu files so they don't clash with others
+ newdoc spamd/README README.spamd
+ newdoc sql/README README.sql
+ newdoc ldap/README README.ldap
+ use qmail && newdoc spamc/README.qmail README.qmail
+
+ dohtml doc/*.html
+ docinto sql
+ dodoc sql/*.sql
+ fi
+
+ # Install provided tools. See bug 108168
+ if use tools; then
+ docinto tools
+ dodoc tools/*
+ fi
+
+ cp ${FILESDIR}/secrets.cf ${D}/etc/mail/spamassassin/secrets.cf.example
+ fperms 0400 /etc/mail/spamassassin/secrets.cf.example
+ echo "">>${D}/etc/mail/spamassassin/local.cf.example
+ echo "# Sensitive data, such as database connection info, should">>${D}/etc/mail/spamassassin/local.cf.example
+ echo "# be stored in /etc/mail/spamassassin/secrets.cf with">>${D}/etc/mail/spamassassin/local.cf.example
+ echo "# appropriate permissions">>${D}/etc/mail/spamassassin/local.cf.example
+}
+
+pkg_postinst() {
+ perl-module_pkg_postinst
+
+ if ! has_version "perl-core/DB_File"; then
+ einfo "The Bayes backend requires the Berkeley DB to store its data. You"
+ einfo "need to emerge perl-core/DB_File or USE=berkdb to make it available."
+ fi
+
+ if has_version "mail-filter/razor"; then
+ if ! has_version ">=mail-filter/razor-2.61"; then
+ ewarn "You have $(best_version mail-filter/razor) installed but SpamAssassin"
+ if has_version "<mail-filter/razor-2.40"; then
+ ewarn "requires at least version 2.40, version 2.61 or later is recommended."
+ else
+ ewarn "recommends at least version 2.61."
+ fi
+ fi
+ fi
+
+ if use doc; then
+ einfo
+ einfo "Please read the file"
+ einfo " /usr/share/doc/${PF}/INSTALL.gz"
+ einfo "to find out which optional modules you need to install to enable"
+ einfo "additional features which depend on them."
+ einfo
+ einfo "If upgraded from 2.x, please read the file"
+ einfo " /usr/share/doc/${PF}/UPGRADE.gz"
+ einfo
+ fi
+
+ ewarn
+ ewarn "spamd is not designed to listen to an untrusted network"
+ ewarn "and is vulnerable to DoS attacks (and eternal doom) if"
+ ewarn "configured to do so"
+ ewarn
+ ewarn "If you plan on using the -u flag to spamd, please read the notes"
+ ewarn "in /etc/conf.d/spamd regarding the location of the pid file."
+
+ einfo
+ einfo "If you build ${PN} with optional dependancy support,"
+ einfo "you can enable them in /etc/mail/spamassassin/init.pre"
+
+ if has_version '>=dev-lang/perl-5.8.8'; then
+ ewarn "Perl 5.8 now uses Unicode internally by default, which causes trouble for"
+ ewarn "SpamAssassin (and almost all other reasonably complex pieces of perl"
+ ewarn "code!)."
+ echo ""
+ ewarn "We've worked around this in most places, as far as we know, but there may"
+ ewarn "still be some issues. In addition, there is a speed hit, which it would"
+ ewarn "be nice to avoid."
+ echo ""
+ ewarn "Setting the LANG environment variable before any invocation of"
+ ewarn "SpamAssassin sometimes seems to help fix it, like so:"
+ echo ""
+ ewarn " export LANG=en_US"
+ echo ""
+ ewarn "Notably, the LANG setting must not include \"utf8\". However, some folks"
+ ewarn "have reported that this makes no difference. ;)"
+ fi
+ einfo
+ if ! has_version 'dev-perl/Mail-SPF-Query'; then
+ einfo "For spf support, please emerge dev-perl/Mail-SPF-Query"
+ fi
+ if ! has_version 'mail-filter/dcc'; then
+ einfo "For dcc support, please emerge mail-filter/dcc"
+ fi
+ if ! has_version 'dev-python/pyzor'; then
+ einfo "For pyzor support, please emerge dev-python/pyzor"
+ fi
+ if ! has_version 'mail-filter/razor'; then
+ einfo "For razor support, please emerge mail-filter/razor"
+ fi
+ einfo
+ einfo "For addtional functionality, you may wish to emerge:"
+ einfo "dev-perl/IP-Country dev-perl/Net-Ident "
+ einfo "dev-perl/Mail-DomainKeys"
+
+}