summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Smee <strerror@gentoo.org>2007-10-17 14:33:53 +0000
committerBenjamin Smee <strerror@gentoo.org>2007-10-17 14:33:53 +0000
commitebb969bca00094c9c80452c5a8927fa945bb6f58 (patch)
tree46420e7591e8bf8de2d3ff477d0c95c05f80d335 /mail-filter/policyd
parentVersion bump, bug 180112 (diff)
downloadgentoo-2-ebb969bca00094c9c80452c5a8927fa945bb6f58.tar.gz
gentoo-2-ebb969bca00094c9c80452c5a8927fa945bb6f58.tar.bz2
gentoo-2-ebb969bca00094c9c80452c5a8927fa945bb6f58.zip
Version bump
(Portage version: 2.1.3.14)
Diffstat (limited to 'mail-filter/policyd')
-rw-r--r--mail-filter/policyd/ChangeLog7
-rw-r--r--mail-filter/policyd/files/digest-policyd-1.823
-rw-r--r--mail-filter/policyd/policyd-1.82.ebuild72
3 files changed, 81 insertions, 1 deletions
diff --git a/mail-filter/policyd/ChangeLog b/mail-filter/policyd/ChangeLog
index 0227c3c15623..6808cb24e738 100644
--- a/mail-filter/policyd/ChangeLog
+++ b/mail-filter/policyd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-filter/policyd
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/policyd/ChangeLog,v 1.2 2007/07/30 00:58:02 strerror Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/policyd/ChangeLog,v 1.3 2007/10/17 14:33:52 strerror Exp $
+
+*policyd-1.82 (17 Oct 2007)
+
+ 17 Oct 2007; Benjamin Smee <strerror@gentoo.org> +policyd-1.82.ebuild:
+ Version bump
*policyd-1.81 (30 Jul 2007)
diff --git a/mail-filter/policyd/files/digest-policyd-1.82 b/mail-filter/policyd/files/digest-policyd-1.82
new file mode 100644
index 000000000000..750e9c8c45e7
--- /dev/null
+++ b/mail-filter/policyd/files/digest-policyd-1.82
@@ -0,0 +1,3 @@
+MD5 6f6167dc2032353cb14f02da7cdb1339 policyd-1.82.tar.gz 68372
+RMD160 0258ee9abaa00cde9a139bdeafed36df1ec37537 policyd-1.82.tar.gz 68372
+SHA256 63a90d26732ed24f8d8fa8623d74b73104a61a2c80b0e062437777cf13b80566 policyd-1.82.tar.gz 68372
diff --git a/mail-filter/policyd/policyd-1.82.ebuild b/mail-filter/policyd/policyd-1.82.ebuild
new file mode 100644
index 000000000000..baa82b99ef9e
--- /dev/null
+++ b/mail-filter/policyd/policyd-1.82.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/policyd/policyd-1.82.ebuild,v 1.1 2007/10/17 14:33:52 strerror Exp $
+
+inherit eutils
+
+DESCRIPTION="Policy daemon for postfix and other MTAs"
+HOMEPAGE="http://policyd.sf.net/"
+
+# This is not available through SF mirrors
+SRC_URI="http://policyd.sourceforge.net/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND="dev-db/mysql
+ dev-libs/openssl"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-makefile.patch"
+
+ ebegin "Applying config patches"
+ sed -i -e s:UID=0:UID=65534:g \
+ -e s:GID=0:GID=65534:g \
+ -e s:DAEMON=0:DAEMON=1:g \
+ -e s:DEBUG=3:DEBUG=0:g \
+ -e s:DATABASE_KEEPALIVE=0:DATABASE_KEEPALIVE=1:g \
+ policyd.conf || "sed failed"
+ eend
+}
+
+src_compile() {
+ emake build || "emake build failed"
+}
+
+src_install() {
+ insopts -o root -g nobody -m 0750
+ mv cleanup policyd_cleanup
+ mv stats policyd_stats
+
+ dosbin policyd policyd_cleanup policyd_stats
+
+ insopts -o root -g nobody -m 0640
+ insinto /etc
+ doins policyd.conf
+
+ insopts -o root -g nobody -m 0700
+ exeinto /etc/cron.hourly
+ newexe "${FILESDIR}/${PN}-cleanup.cron" ${PN}-cleanup.cron
+
+ dodoc ChangeLog DATABASE.mysql LICENSE README doc/support.txt
+
+ newinitd "${FILESDIR}/${PN}.rc" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}
+
+pkg_postinst() {
+ elog "You will need to create the database using the script provided in"
+ elog "/usr/share/doc/${PF}/DATABASE.mysql.gz"
+ elog "Read the mysql section of the README.txt for details."
+ elog
+ elog "To use policyd with postfix, update your /etc/postfix/main.cf file by adding"
+ elog " check_policy_service inet:127.0.0.1:10031"
+ elog "to your smtpd_recipient_restrictions line, or similar."
+ elog
+ elog "Also remember to start the daemon at boot:"
+ elog " rc-update add policyd default"
+ elog
+ elog "Read the documentation for more info."
+}