summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2012-11-02 20:29:16 +0000
committerEray Aslan <eras@gentoo.org>2012-11-02 20:29:16 +0000
commitef4f35d8f22195ad7f1cb0fa01378b6769009c8b (patch)
tree775611b1965e41c1f119952a3c951dc8a8527e8d /mail-filter/libspf2
parentCorrect package naming syntax and month, noted by pchrist (diff)
downloadgentoo-2-ef4f35d8f22195ad7f1cb0fa01378b6769009c8b.tar.gz
gentoo-2-ef4f35d8f22195ad7f1cb0fa01378b6769009c8b.tar.bz2
gentoo-2-ef4f35d8f22195ad7f1cb0fa01378b6769009c8b.zip
Add static-libs support - bug #440958
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 0x77F1F175586A3B1F)
Diffstat (limited to 'mail-filter/libspf2')
-rw-r--r--mail-filter/libspf2/ChangeLog7
-rw-r--r--mail-filter/libspf2/libspf2-1.2.9-r1.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/mail-filter/libspf2/ChangeLog b/mail-filter/libspf2/ChangeLog
index b5f0571517d2..8678adfc4242 100644
--- a/mail-filter/libspf2/ChangeLog
+++ b/mail-filter/libspf2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-filter/libspf2
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/libspf2/ChangeLog,v 1.42 2012/10/31 19:05:32 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/libspf2/ChangeLog,v 1.43 2012/11/02 20:29:16 eras Exp $
+
+*libspf2-1.2.9-r1 (02 Nov 2012)
+
+ 02 Nov 2012; Eray Aslan <eras@gentoo.org> +libspf2-1.2.9-r1.ebuild:
+ Add static-libs support - bug #440958
31 Oct 2012; Jeroen Roovers <jer@gentoo.org> libspf2-1.2.9.ebuild:
Stable for HPPA (bug #440058).
diff --git a/mail-filter/libspf2/libspf2-1.2.9-r1.ebuild b/mail-filter/libspf2/libspf2-1.2.9-r1.ebuild
new file mode 100644
index 000000000000..ad2d85ab59df
--- /dev/null
+++ b/mail-filter/libspf2/libspf2-1.2.9-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/libspf2/libspf2-1.2.9-r1.ebuild,v 1.1 2012/11/02 20:29:16 eras Exp $
+
+EAPI=4
+inherit eutils autotools
+
+DESCRIPTION="libspf2 implements the Sender Policy Framework, a part of the SPF/SRS protocol pair."
+HOMEPAGE="http://www.libspf2.org"
+SRC_URI="http://www.libspf2.org/spf/libspf2-${PV}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 BSD-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="static-libs"
+
+DEPEND=""
+RDEPEND="!dev-perl/Mail-SPF-Query"
+
+src_prepare() {
+ if ! use static-libs; then
+ sed -i -e '/bin_PROGRAMS/s/spfquery_static//' src/spfquery/Makefile.am \
+ -e '/bin_PROGRAMS/s/spftest_static//' src/spftest/Makefile.am \
+ -e '/bin_PROGRAMS/s/spfd_static//' src/spfd/Makefile.am \
+ -e '/bin_PROGRAMS/s/spf_example_static//' src/spf_example/Makefile.am \
+ || die
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README TODO INSTALL
+
+ use static-libs || rm -f "${D}"/usr/lib*/libspf2.la
+}