summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-08-11 01:35:43 +0000
committerJeroen Roovers <jer@gentoo.org>2010-08-11 01:35:43 +0000
commit1f24f92f91cb3cd51af0989f74f6f9d95c554474 (patch)
treef475059f0f504ff9e868ebf955484e9f722ed454 /mail-filter/gld
parentVersion bump (diff)
downloadgentoo-2-1f24f92f91cb3cd51af0989f74f6f9d95c554474.tar.gz
gentoo-2-1f24f92f91cb3cd51af0989f74f6f9d95c554474.tar.bz2
gentoo-2-1f24f92f91cb3cd51af0989f74f6f9d95c554474.zip
Respect LDFLAGS (bug #331785). Move dosed scripts to src_prepare and make sure they are run properly. Respect CC. Respect CFLAGS. Whitespace.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'mail-filter/gld')
-rw-r--r--mail-filter/gld/ChangeLog8
-rw-r--r--mail-filter/gld/gld-1.7-r1.ebuild69
2 files changed, 76 insertions, 1 deletions
diff --git a/mail-filter/gld/ChangeLog b/mail-filter/gld/ChangeLog
index db341f07f0f2..b16631bb350b 100644
--- a/mail-filter/gld/ChangeLog
+++ b/mail-filter/gld/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-filter/gld
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/gld/ChangeLog,v 1.43 2010/06/17 21:36:11 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/gld/ChangeLog,v 1.44 2010/08/11 01:35:43 jer Exp $
+
+*gld-1.7-r1 (11 Aug 2010)
+
+ 11 Aug 2010; Jeroen Roovers <jer@gentoo.org> +gld-1.7-r1.ebuild:
+ Respect LDFLAGS (bug #331785). Move dosed scripts to src_prepare and make
+ sure they are run properly. Respect CC. Respect CFLAGS. Whitespace.
17 Jun 2010; Patrick Lauer <patrick@gentoo.org> gld-1.7.ebuild:
Migrating away from deprecated postgres virtuals
diff --git a/mail-filter/gld/gld-1.7-r1.ebuild b/mail-filter/gld/gld-1.7-r1.ebuild
new file mode 100644
index 000000000000..466d2cdd9a67
--- /dev/null
+++ b/mail-filter/gld/gld-1.7-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/gld/gld-1.7-r1.ebuild,v 1.1 2010/08/11 01:35:43 jer Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A standalone anti-spam greylisting algorithm on top of Postfix"
+HOMEPAGE="http://www.gasmi.net/gld.html"
+SRC_URI="http://www.gasmi.net/down/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="postgres"
+# Not adding a mysql USE flag. The package defaults to it, so we will too.
+DEPEND="sys-libs/zlib
+ >=dev-libs/openssl-0.9.6
+ postgres? ( dev-db/postgresql-server )
+ !postgres? ( virtual/mysql )"
+
+src_prepare() {
+ sed -i gld.conf \
+ -e 's:^LOOPBACKONLY=.*:LOOPBACKONLY=1:' \
+ -e 's:^#USER=.*:USER=nobody:' \
+ -e 's:^#GROUP=.*:GROUP=nobody:' \
+ || die "sed gld.conf failed"
+
+ sed -i Makefile.in \
+ -e '/ -c /{s|-O2|$(CFLAGS)|g}' \
+ -e '/ -o /{s|-O2|$(CFLAGS) $(LDFLAGS)|g}' \
+ -e '/strip/d' \
+ || die "sed Makefile.in failed"
+}
+
+src_configure() {
+ tc-export CC
+ # It's kind of weird. $(use_with postgres pgsql) won't work if you don't
+ # use it...
+ if use postgres ; then
+ myconf="${myconf} --with-pgsql"
+ fi
+
+ econf ${myconf} || die "econf failed"
+}
+
+src_install() {
+ dobin gld
+
+ insinto /etc
+ newins gld.conf gld.conf.example
+
+ dodoc HISTORY README*
+
+ insinto /usr/share/${PN}/sql
+ doins *.pgsql *-whitelist.sql "${FILESDIR}"/tables.sql
+
+ newinitd "${FILESDIR}"/gld.rc gld
+}
+
+pkg_postinst() {
+ elog
+ elog "Please read the README file in /usr/share/doc/${PF} for"
+ elog "details on how to setup gld."
+ elog
+ elog "The sql files have been installed to /usr/share/${PN}/sql."
+ elog
+}