summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-09-29 23:07:39 +0000
committerHanno Böck <hanno@gentoo.org>2009-09-29 23:07:39 +0000
commita5126559bf4483fe019db0ebdbae787474011ef9 (patch)
tree862bc59af28b41e5b5b326668a3a647f5e1eaacf /mail-filter/couriersrs
parentremove old ebuilds (diff)
downloadgentoo-2-a5126559bf4483fe019db0ebdbae787474011ef9.tar.gz
gentoo-2-a5126559bf4483fe019db0ebdbae787474011ef9.tar.bz2
gentoo-2-a5126559bf4483fe019db0ebdbae787474011ef9.zip
Initial commit of courier srs implementation.
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'mail-filter/couriersrs')
-rw-r--r--mail-filter/couriersrs/ChangeLog10
-rw-r--r--mail-filter/couriersrs/couriersrs-0.1.1.ebuild34
-rw-r--r--mail-filter/couriersrs/files/couriersrs-0.1.1-libtool-automake-fixes.diff62
-rw-r--r--mail-filter/couriersrs/metadata.xml6
4 files changed, 112 insertions, 0 deletions
diff --git a/mail-filter/couriersrs/ChangeLog b/mail-filter/couriersrs/ChangeLog
new file mode 100644
index 000000000000..1c07c0a6dde1
--- /dev/null
+++ b/mail-filter/couriersrs/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for mail-filter/couriersrs
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/couriersrs/ChangeLog,v 1.1 2009/09/29 23:07:37 hanno Exp $
+
+*couriersrs-0.1.1 (29 Sep 2009)
+
+ 29 Sep 2009; Hanno Boeck <hanno@gentoo.org> +couriersrs-0.1.1.ebuild,
+ +files/couriersrs-0.1.1-libtool-automake-fixes.diff, +metadata.xml:
+ Initial commit of courier srs implementation.
+
diff --git a/mail-filter/couriersrs/couriersrs-0.1.1.ebuild b/mail-filter/couriersrs/couriersrs-0.1.1.ebuild
new file mode 100644
index 000000000000..b67c8b3c455a
--- /dev/null
+++ b/mail-filter/couriersrs/couriersrs-0.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/couriersrs/couriersrs-0.1.1.ebuild,v 1.1 2009/09/29 23:07:37 hanno Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="SRS (Sender Rewriting Scheme) wrapper for the courier MTA."
+HOMEPAGE="http://couriersrs.com/"
+SRC_URI="http://couriersrs.com/download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+DEPEND="dev-libs/popt
+ mail-filter/libsrs2"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm `grep -l gettext m4/*.m4`
+ epatch "${FILESDIR}/${P}-libtool-automake-fixes.diff"
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS ChangeLog
+}
diff --git a/mail-filter/couriersrs/files/couriersrs-0.1.1-libtool-automake-fixes.diff b/mail-filter/couriersrs/files/couriersrs-0.1.1-libtool-automake-fixes.diff
new file mode 100644
index 000000000000..54f3c0b48445
--- /dev/null
+++ b/mail-filter/couriersrs/files/couriersrs-0.1.1-libtool-automake-fixes.diff
@@ -0,0 +1,62 @@
+--- couriersrs-0.1.1/configure.ac 2007-03-26 23:17:30.000000000 +0200
++++ couriersrs-0.1.1-1/configure.ac 2009-09-19 22:15:37.000000000 +0200
+@@ -24,9 +24,6 @@
+
+ AC_SUBST([localedir], ['${datadir}/locale'])
+
+-dnl use libtool to compile checks (particularly lib checks), mostly so we don't have to worry about how/if the os supports -R
+-ac_link="${SHELL} ${srcdir}/libtool --mode=link $ac_link"
+-
+ dnl headers we need
+ AC_HEADER_STDC
+
+diff -Naur couriersrs-0.1.1/intl/Makefile.in couriersrs-0.1.1-x/intl/Makefile.in
+--- couriersrs-0.1.1/intl/Makefile.in 2007-03-15 20:59:02.000000000 +0100
++++ couriersrs-0.1.1-x/intl/Makefile.in 2009-09-19 23:36:54.000000000 +0200
+@@ -39,8 +39,7 @@
+
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+-MKINSTALLDIRS = @MKINSTALLDIRS@
+-mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
++mkinstalldirs = @mkdir_p@
+
+ l = @INTL_LIBTOOL_SUFFIX_PREFIX@
+
+diff -Naur couriersrs-0.1.1/m4/Makefile.in couriersrs-0.1.1-x/m4/Makefile.in
+--- couriersrs-0.1.1/m4/Makefile.in 2007-03-26 23:17:43.000000000 +0200
++++ couriersrs-0.1.1-x/m4/Makefile.in 2009-09-19 23:28:26.000000000 +0200
+@@ -127,7 +127,7 @@
+ LTLIBINTL = @LTLIBINTL@
+ LTLIBOBJS = @LTLIBOBJS@
+ MAKEINFO = @MAKEINFO@
+-MKINSTALLDIRS = @MKINSTALLDIRS@
++MKINSTALLDIRS = @mkdir_p@
+ MSGFMT = @MSGFMT@
+ MSGMERGE = @MSGMERGE@
+ OBJEXT = @OBJEXT@
+diff -Naur couriersrs-0.1.1/Makefile.in couriersrs-0.1.1-x/Makefile.in
+--- couriersrs-0.1.1/Makefile.in 2007-03-26 23:17:44.000000000 +0200
++++ couriersrs-0.1.1-x/Makefile.in 2009-09-19 23:28:26.000000000 +0200
+@@ -174,7 +174,7 @@
+ LTLIBINTL = @LTLIBINTL@
+ LTLIBOBJS = @LTLIBOBJS@
+ MAKEINFO = @MAKEINFO@
+-MKINSTALLDIRS = @MKINSTALLDIRS@
++MKINSTALLDIRS = @mkdir_p@
+ MSGFMT = @MSGFMT@
+ MSGMERGE = @MSGMERGE@
+ OBJEXT = @OBJEXT@
+diff -Naur couriersrs-0.1.1/po/Makefile.in.in couriersrs-0.1.1-x/po/Makefile.in.in
+--- couriersrs-0.1.1/po/Makefile.in.in 2007-03-15 20:59:04.000000000 +0100
++++ couriersrs-0.1.1-x/po/Makefile.in.in 2009-09-19 23:36:00.000000000 +0200
+@@ -28,8 +28,7 @@
+
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+-MKINSTALLDIRS = @MKINSTALLDIRS@
+-mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
++mkinstalldirs = @mkdir_p@
+
+ GMSGFMT = @GMSGFMT@
+ MSGFMT = @MSGFMT@
diff --git a/mail-filter/couriersrs/metadata.xml b/mail-filter/couriersrs/metadata.xml
new file mode 100644
index 000000000000..b507dbb0fd19
--- /dev/null
+++ b/mail-filter/couriersrs/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-mail</herd>
+<maintainer><email>hanno@gentoo.org</email></maintainer>
+</pkgmetadata>