summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-03-12 18:25:34 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-03-12 18:25:34 +0000
commitfdf37590402066e9c91130b8556d87162ed9bd9a (patch)
treee5747bd539f78426591574631a913b1d64bfef19 /mail-client
parentRedigest (diff)
downloadgentoo-2-fdf37590402066e9c91130b8556d87162ed9bd9a.tar.gz
gentoo-2-fdf37590402066e9c91130b8556d87162ed9bd9a.tar.bz2
gentoo-2-fdf37590402066e9c91130b8556d87162ed9bd9a.zip
Version bump
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mozilla-thunderbird-bin/ChangeLog8
-rw-r--r--mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-3.0_beta2.ebuild173
2 files changed, 180 insertions, 1 deletions
diff --git a/mail-client/mozilla-thunderbird-bin/ChangeLog b/mail-client/mozilla-thunderbird-bin/ChangeLog
index d7a82108269e..43353d1c4fea 100644
--- a/mail-client/mozilla-thunderbird-bin/ChangeLog
+++ b/mail-client/mozilla-thunderbird-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/mozilla-thunderbird-bin
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird-bin/ChangeLog,v 1.123 2009/01/01 18:55:59 keytoaster Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird-bin/ChangeLog,v 1.124 2009/03/12 18:25:34 armin76 Exp $
+
+*mozilla-thunderbird-bin-3.0_beta2 (12 Mar 2009)
+
+ 12 Mar 2009; Raúl Porcel <armin76@gentoo.org>
+ +mozilla-thunderbird-bin-3.0_beta2.ebuild:
+ Version bump
01 Jan 2009; Tobias Heinlein <keytoaster@gentoo.org>
mozilla-thunderbird-bin-2.0.0.19.ebuild:
diff --git a/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-3.0_beta2.ebuild b/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-3.0_beta2.ebuild
new file mode 100644
index 000000000000..d4f7da8d9727
--- /dev/null
+++ b/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-3.0_beta2.ebuild
@@ -0,0 +1,173 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-3.0_beta2.ebuild,v 1.1 2009/03/12 18:25:34 armin76 Exp $
+
+inherit eutils mozilla-launcher multilib mozextension
+
+LANGS="af ar be bg ca cs de el en-US es-AR es-ES et eu fi fr fy-NL ga-IE gl he hu id is it ja ko lt nb-NO nl nn-NO pa-IN pl pt-BR pt-PT ro ru si sk sr sv-SE uk vi zh-CN"
+NOSHORTLANGS="es-AR pt-BR"
+
+MY_PV="${PV/_beta/b}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Thunderbird Mail Client"
+SRC_URI="http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/${MY_PV}/linux-i686/en-US/thunderbird-${MY_PV}.tar.bz2"
+HOMEPAGE="http://www.mozilla.com/thunderbird"
+RESTRICT="strip"
+
+KEYWORDS="-* ~amd64 ~x86"
+SLOT="0"
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+IUSE=""
+
+for X in ${LANGS} ; do
+ if [ "${X}" != "en" ] && [ "${X}" != "en-US" ]; then
+ SRC_URI="${SRC_URI}
+ linguas_${X/-/_}? ( http://dev.gentooexperimental.org/~armin76/dist/${MY_P/-bin}-xpi/${MY_P/-bin/}-${X}.xpi )"
+ fi
+ IUSE="${IUSE} linguas_${X/-/_}"
+ # english is handled internally
+ if [ "${#X}" == 5 ] && ! has ${X} ${NOSHORTLANGS}; then
+ if [ "${X}" != "en-US" ]; then
+ SRC_URI="${SRC_URI}
+ linguas_${X%%-*}? ( http://dev.gentooexperimental.org/~armin76/dist/${MY_P/-bin}-xpi/${MY_P/-bin/}-${X}.xpi )"
+ fi
+ IUSE="${IUSE} linguas_${X%%-*}"
+ fi
+done
+
+DEPEND="app-arch/unzip"
+RDEPEND="x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
+ x86? (
+ >=x11-libs/gtk+-2.2
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-1.0
+ >=app-emulation/emul-linux-x86-gtklibs-1.0
+ app-emulation/emul-linux-x86-compat
+ )"
+
+S="${WORKDIR}/thunderbird"
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
+
+linguas() {
+ local LANG SLANG
+ for LANG in ${LINGUAS}; do
+ if has ${LANG} en en_US; then
+ has en ${linguas} || linguas="${linguas:+"${linguas} "}en"
+ continue
+ elif has ${LANG} ${LANGS//-/_}; then
+ has ${LANG//_/-} ${linguas} || linguas="${linguas:+"${linguas} "}${LANG//_/-}"
+ continue
+ elif [[ " ${LANGS} " == *" ${LANG}-"* ]]; then
+ for X in ${LANGS}; do
+ if [[ "${X}" == "${LANG}-"* ]] && \
+ [[ " ${NOSHORTLANGS} " != *" ${X} "* ]]; then
+ has ${X} ${linguas} || linguas="${linguas:+"${linguas} "}${X}"
+ continue 2
+ fi
+ done
+ fi
+ ewarn "Sorry, but ${PN} does not support the ${LANG} LINGUA"
+ done
+}
+
+src_unpack() {
+ unpack ${A}
+
+ linguas
+ for X in ${linguas}; do
+ [[ ${X} != en ]] && xpi_unpack ${MY_P/-bin}-${X}.xpi
+ done
+ if [[ ${linguas} != "" && ${linguas} != "en" ]]; then
+ einfo "Selected language packs (first will be default): ${linguas}"
+ fi
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME="/opt/thunderbird"
+
+ # Install thunderbird in /opt
+ dodir ${MOZILLA_FIVE_HOME%/*}
+ mv "${S}" "${D}"${MOZILLA_FIVE_HOME}
+
+ linguas
+ for X in ${linguas}; do
+ [[ ${X} != en ]] && xpi_install ${WORKDIR}/${MY_P/-bin}-${X}
+ done
+
+ local LANG=${linguas%% *}
+ if [[ ${LANG} != "" && ${LANG} != "en" ]]; then
+ ebegin "Setting default locale to ${LANG}"
+ sed -i "s:pref(\"general.useragent.locale\", \"en-US\"):pref(\"general.useragent.locale\", \"${LANG}\"):" \
+ "${D}"${MOZILLA_FIVE_HOME}/defaults/pref/all-thunderbird.js \
+ "${D}"${MOZILLA_FIVE_HOME}/defaults/pref/all-l10n.js
+ eend $? || die "sed failed to change locale"
+ fi
+
+ # Install /usr/bin/thunderbird-bin
+ make_wrapper thunderbird-bin "${MOZILLA_FIVE_HOME}/thunderbird"
+
+ # Install icon and .desktop for menu entry
+ doicon "${FILESDIR}"/icon/${PN}-icon.png
+ domenu "${FILESDIR}"/icon/${PN}.desktop
+
+ # revdep-rebuild entry
+ insinto /etc/revdep-rebuild
+ doins "${FILESDIR}"/10thunderbird-bin
+
+ # install ldpath env.d
+ doenvd "${FILESDIR}"/71thunderbird-bin
+}
+
+pkg_preinst() {
+ declare MOZILLA_FIVE_HOME="/opt/thunderbird"
+
+ # Remove entire installed instance to solve various
+ # problems, for example see bug 27719
+ rm -rf "${ROOT}"${MOZILLA_FIVE_HOME}
+}
+
+pkg_postinst() {
+ #elog "For enigmail, please see instructions at"
+ #elog " http://enigmail.mozdev.org/"
+
+ ewarn "Enigmail or probably any other extension won't work"
+ ewarn "with Thunderbird 3.0."
+
+ if use x86; then
+ if ! has_version 'gnome-base/gconf' || ! has_version 'gnome-base/orbit' \
+ || ! has_version 'net-misc/curl'; then
+ einfo
+ einfo "For using the crashreporter, you need gnome-base/gconf,"
+ einfo "gnome-base/orbit and net-misc/curl emerged."
+ einfo
+ fi
+ if has_version 'net-misc/curl' && built_with_use --missing \
+ true 'net-misc/curl' nss; then
+ einfo
+ einfo "Crashreporter won't be able to send reports"
+ einfo "if you have curl emerged with the nss USE-flag"
+ einfo
+ fi
+ else
+ einfo
+ einfo "NB: You just installed a 32-bit thunderbird"
+ einfo
+ einfo "Crashreporter won't work on amd64"
+ einfo
+ fi
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}