summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-05 14:24:38 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-05 14:24:38 +0000
commite9c36b0570c01798fa9aee9191c6a43717513be7 (patch)
tree21d521f1740499a07a5fa4f8bdde165ef24cad40 /mail-client
parentFix tree that was just broken by masking of libnotify. (diff)
downloadgentoo-2-e9c36b0570c01798fa9aee9191c6a43717513be7.tar.gz
gentoo-2-e9c36b0570c01798fa9aee9191c6a43717513be7.tar.bz2
gentoo-2-e9c36b0570c01798fa9aee9191c6a43717513be7.zip
Fix building with x11-libs/libnotify >= 0.7.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/evolution/ChangeLog6
-rw-r--r--mail-client/evolution/evolution-2.32.1-r1.ebuild4
-rw-r--r--mail-client/evolution/files/evolution-2.32.1-libnotify-0.7.patch81
3 files changed, 89 insertions, 2 deletions
diff --git a/mail-client/evolution/ChangeLog b/mail-client/evolution/ChangeLog
index de885cea9cc0..9a77f62e8f2f 100644
--- a/mail-client/evolution/ChangeLog
+++ b/mail-client/evolution/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-client/evolution
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/ChangeLog,v 1.321 2011/01/30 19:38:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/ChangeLog,v 1.322 2011/02/05 14:24:38 ssuominen Exp $
+
+ 05 Feb 2011; Samuli Suominen <ssuominen@gentoo.org>
+ evolution-2.32.1-r1.ebuild, +files/evolution-2.32.1-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7.
30 Jan 2011; Raúl Porcel <armin76@gentoo.org> evolution-2.30.3.ebuild:
alpha/ia64/sparc stable wrt #348987
diff --git a/mail-client/evolution/evolution-2.32.1-r1.ebuild b/mail-client/evolution/evolution-2.32.1-r1.ebuild
index 621a198b1aeb..15135504bc20 100644
--- a/mail-client/evolution/evolution-2.32.1-r1.ebuild
+++ b/mail-client/evolution/evolution-2.32.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-2.32.1-r1.ebuild,v 1.3 2011/01/15 19:56:39 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-2.32.1-r1.ebuild,v 1.4 2011/02/05 14:24:38 ssuominen Exp $
EAPI="3"
GCONF_DEBUG="no"
@@ -132,6 +132,8 @@ pkg_setup() {
src_prepare() {
gnome2_src_prepare
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+
# Fix invalid use of la file in contact-editor, upstream bug #635002
epatch "${FILESDIR}/${PN}-2.32.0-wrong-lafile-usage.patch"
diff --git a/mail-client/evolution/files/evolution-2.32.1-libnotify-0.7.patch b/mail-client/evolution/files/evolution-2.32.1-libnotify-0.7.patch
new file mode 100644
index 000000000000..7e2474b47742
--- /dev/null
+++ b/mail-client/evolution/files/evolution-2.32.1-libnotify-0.7.patch
@@ -0,0 +1,81 @@
+--- calendar/gui/alarm-notify/alarm-queue.c
++++ calendar/gui/alarm-notify/alarm-queue.c
+@@ -40,6 +40,9 @@
+
+ #ifdef HAVE_LIBNOTIFY
+ #include <libnotify/notify.h>
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
+ #endif
+
+ #include "alarm.h"
+@@ -1606,7 +1609,12 @@
+ body = g_strdup_printf ("%s %s", start_str, time_str);
+ }
+
+- n = notify_notification_new (summary, body, "stock_appointment-reminder", NULL);
++ n = notify_notification_new (summary, body, "stock_appointment-reminder"
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ );
++#else
++ , NULL);
++#endif
+ if (!notify_notification_show(n, NULL))
+ g_warning ("Could not send notification to daemon\n");
+
+--- plugins/mail-notification/mail-notification.c
++++ plugins/mail-notification/mail-notification.c
+@@ -47,6 +47,9 @@
+
+ #ifdef HAVE_LIBNOTIFY
+ #include <libnotify/notify.h>
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
+ #endif
+
+ #define GCONF_KEY_ROOT "/apps/evolution/eplugin/mail-notification/"
+@@ -564,9 +567,14 @@
+
+ notify = notify_notification_new (
+ _("New email"), safetext,
+- "mail-unread", NULL);
++ "mail-unread"
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ );
++#else
++ , NULL);
+ notify_notification_attach_to_status_icon (
+ notify, status_icon);
++#endif
+
+ /* Check if actions are supported */
+ if (can_support_actions ()) {
+--- plugins/publish-calendar/publish-calendar.c
++++ plugins/publish-calendar/publish-calendar.c
+@@ -46,6 +46,9 @@
+
+ #ifdef HAVE_LIBNOTIFY
+ #include <libnotify/notify.h>
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
+ #endif
+
+ static GtkListStore *store = NULL;
+@@ -150,8 +153,13 @@
+ return;
+ }
+
+- notify = notify_notification_new (_("Calendar Publishing"), actual_msg->str, stock_name, NULL);
++ notify = notify_notification_new (_("Calendar Publishing"), actual_msg->str, stock_name
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ );
++#else
++ , NULL);
+ notify_notification_attach_to_status_icon (notify, status_icon);
++#endif
+ notify_notification_set_urgency (notify, NOTIFY_URGENCY_NORMAL);
+ notify_notification_set_timeout (notify, NOTIFY_EXPIRES_DEFAULT);
+ g_timeout_add (500, show_notify_cb, NULL);