summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2006-07-14 14:10:45 +0000
committerAkinori Hattori <hattya@gentoo.org>2006-07-14 14:10:45 +0000
commitc602977c0fc13856ae34e4ac061dc547ceda7814 (patch)
treecaa46bc0b4e56788f14182ceab60e3dcc3d21285 /mail-client
parentAdded missing USE: source. (diff)
downloadgentoo-2-c602977c0fc13856ae34e4ac061dc547ceda7814.tar.gz
gentoo-2-c602977c0fc13856ae34e4ac061dc547ceda7814.tar.bz2
gentoo-2-c602977c0fc13856ae34e4ac061dc547ceda7814.zip
use emake for install.
(Portage version: 2.1.1_pre2-r8)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/sylpheed/ChangeLog6
-rw-r--r--mail-client/sylpheed/sylpheed-2.0.4.ebuild23
-rw-r--r--mail-client/sylpheed/sylpheed-2.2.4.ebuild15
-rw-r--r--mail-client/sylpheed/sylpheed-2.2.5.ebuild13
4 files changed, 29 insertions, 28 deletions
diff --git a/mail-client/sylpheed/ChangeLog b/mail-client/sylpheed/ChangeLog
index 73957c010afe..bf0bc3b3ee85 100644
--- a/mail-client/sylpheed/ChangeLog
+++ b/mail-client/sylpheed/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-client/sylpheed
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.184 2006/07/14 14:05:31 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.185 2006/07/14 14:10:45 hattya Exp $
+
+ 14 Jul 2006; Akinori Hattori <hattya@gentoo.org> sylpheed-2.0.4.ebuild,
+ sylpheed-2.2.4.ebuild, sylpheed-2.2.5.ebuild:
+ use emake for install.
*sylpheed-2.2.6 (14 Jul 2006)
diff --git a/mail-client/sylpheed/sylpheed-2.0.4.ebuild b/mail-client/sylpheed/sylpheed-2.0.4.ebuild
index 1b0004fdb777..18f8b639b33a 100644
--- a/mail-client/sylpheed/sylpheed-2.0.4.ebuild
+++ b/mail-client/sylpheed/sylpheed-2.0.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/sylpheed-2.0.4.ebuild,v 1.8 2005/11/16 13:30:24 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/sylpheed-2.0.4.ebuild,v 1.9 2006/07/14 14:10:45 hattya Exp $
inherit eutils
@@ -30,32 +30,31 @@ RDEPEND="${DEPEND}
src_unpack() {
unpack ${A}
+ cd "${S}"
- cd ${S}
- epatch ${FILESDIR}/${PN}-namespace.diff
- epatch ${FILESDIR}/${PN}-procmime.diff
+ epatch "${FILESDIR}"/${PN}-namespace.diff
+ epatch "${FILESDIR}"/${PN}-procmime.diff
}
src_compile() {
econf \
- `use_enable nls` \
- `use_enable ssl` \
`use_enable crypt gpgme` \
- `use_enable pda jpilot` \
- `use_enable ldap` \
`use_enable ipv6` \
+ `use_enable ldap` \
+ `use_enable nls` \
+ `use_enable pda jpilot` \
+ `use_enable ssl` \
`use_enable xface compface` \
|| die
-
emake || die
}
src_install() {
- einstall
+ emake DESTDIR="${D}" install
dodir /usr/share/pixmaps
insinto /usr/share/pixmaps
@@ -64,6 +63,6 @@ src_install() {
insinto /usr/share/applications
doins sylpheed.desktop
- dodoc AUTHORS COPYING ChangeLog* INSTALL* NEWS* README* TODO*
+ dodoc AUTHORS ChangeLog* NEWS* README* TODO*
}
diff --git a/mail-client/sylpheed/sylpheed-2.2.4.ebuild b/mail-client/sylpheed/sylpheed-2.2.4.ebuild
index 787785980cb2..b34fb837795e 100644
--- a/mail-client/sylpheed/sylpheed-2.2.4.ebuild
+++ b/mail-client/sylpheed/sylpheed-2.2.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/sylpheed-2.2.4.ebuild,v 1.7 2006/05/25 17:48:36 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/sylpheed-2.2.4.ebuild,v 1.8 2006/07/14 14:10:45 hattya Exp $
-inherit eutils
+inherit autotools eutils
IUSE="crypt gnome ipv6 ldap nls pda spell ssl xface"
@@ -31,10 +31,10 @@ RDEPEND="${DEPEND}
src_unpack() {
unpack ${A}
+ cd "${S}"
- cd ${S}
- epatch ${FILESDIR}/${PN}-2.*.diff
- automake
+ epatch "${FILESDIR}"/${PN}-2.*.diff
+ eautomake
}
@@ -50,14 +50,13 @@ src_compile() {
`use_enable ssl` \
`use_enable xface compface` \
|| die
-
emake || die
}
src_install() {
- einstall
+ emake DESTDIR="${D}" install
dodir /usr/share/pixmaps
insinto /usr/share/pixmaps
@@ -66,6 +65,6 @@ src_install() {
insinto /usr/share/applications
doins sylpheed.desktop
- dodoc AUTHORS COPYING ChangeLog* INSTALL* NEWS* README* TODO*
+ dodoc AUTHORS ChangeLog* NEWS* README* TODO*
}
diff --git a/mail-client/sylpheed/sylpheed-2.2.5.ebuild b/mail-client/sylpheed/sylpheed-2.2.5.ebuild
index 7b20ff9c4b81..6671bdd08aad 100644
--- a/mail-client/sylpheed/sylpheed-2.2.5.ebuild
+++ b/mail-client/sylpheed/sylpheed-2.2.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/sylpheed-2.2.5.ebuild,v 1.3 2006/06/10 18:02:18 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/sylpheed-2.2.5.ebuild,v 1.4 2006/07/14 14:10:45 hattya Exp $
-inherit eutils
+inherit autotools eutils
IUSE="crypt gnome ipv6 ldap nls pda spell ssl xface"
@@ -31,10 +31,10 @@ RDEPEND="${DEPEND}
src_unpack() {
unpack ${A}
+ cd "${S}"
- cd ${S}
- epatch ${FILESDIR}/${PN}-2.*.diff
- automake
+ epatch "${FILESDIR}"/${PN}-2.*.diff
+ eautomake
}
@@ -50,14 +50,13 @@ src_compile() {
`use_enable ssl` \
`use_enable xface compface` \
|| die
-
emake || die
}
src_install() {
- einstall
+ emake DESTDIR="${D}" install
dodir /usr/share/pixmaps
insinto /usr/share/pixmaps