summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2006-11-11 13:57:23 +0000
committerAndrej Kacian <ticho@gentoo.org>2006-11-11 13:57:23 +0000
commitbc15c207d9882963d3c75745126c0c2a11a727ad (patch)
tree9c65e07a250fe6779d29b4141d522be54e6cb66e /mail-client
parentVersion bump; add metadata.xml. (diff)
downloadgentoo-2-bc15c207d9882963d3c75745126c0c2a11a727ad.tar.gz
gentoo-2-bc15c207d9882963d3c75745126c0c2a11a727ad.tar.bz2
gentoo-2-bc15c207d9882963d3c75745126c0c2a11a727ad.zip
Version bump.
(Portage version: 2.1.2_rc1-r1)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/sylpheed-claws-acpi-notifier/ChangeLog8
-rw-r--r--mail-client/sylpheed-claws-acpi-notifier/files/digest-sylpheed-claws-acpi-notifier-1.0.43
-rw-r--r--mail-client/sylpheed-claws-acpi-notifier/sylpheed-claws-acpi-notifier-1.0.4.ebuild44
3 files changed, 54 insertions, 1 deletions
diff --git a/mail-client/sylpheed-claws-acpi-notifier/ChangeLog b/mail-client/sylpheed-claws-acpi-notifier/ChangeLog
index 54848876d5bb..593df3a1a2a7 100644
--- a/mail-client/sylpheed-claws-acpi-notifier/ChangeLog
+++ b/mail-client/sylpheed-claws-acpi-notifier/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/sylpheed-claws-acpi-notifier
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-acpi-notifier/ChangeLog,v 1.6 2006/10/14 04:03:34 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-acpi-notifier/ChangeLog,v 1.7 2006/11/11 13:57:23 ticho Exp $
+
+*sylpheed-claws-acpi-notifier-1.0.4 (11 Nov 2006)
+
+ 11 Nov 2006; Andrej Kacian <ticho@gentoo.org>
+ +sylpheed-claws-acpi-notifier-1.0.4.ebuild:
+ Version bump.
14 Oct 2006; Marius Mauch <genone@gentoo.org> metadata.xml:
update maintainer info
diff --git a/mail-client/sylpheed-claws-acpi-notifier/files/digest-sylpheed-claws-acpi-notifier-1.0.4 b/mail-client/sylpheed-claws-acpi-notifier/files/digest-sylpheed-claws-acpi-notifier-1.0.4
new file mode 100644
index 000000000000..f6c842d6459e
--- /dev/null
+++ b/mail-client/sylpheed-claws-acpi-notifier/files/digest-sylpheed-claws-acpi-notifier-1.0.4
@@ -0,0 +1,3 @@
+MD5 3ee22023ba5ea29f0322fcc1e48d4d02 sylpheed-claws-extra-plugins-2.6.0.tar.bz2 3996572
+RMD160 9249849ca348ead6b8a8d55f1b2f5744a61ebda7 sylpheed-claws-extra-plugins-2.6.0.tar.bz2 3996572
+SHA256 da931b1a6d6881f8c888e5bcd8fecd63b4c5110198542f6fb028c0829325f7a6 sylpheed-claws-extra-plugins-2.6.0.tar.bz2 3996572
diff --git a/mail-client/sylpheed-claws-acpi-notifier/sylpheed-claws-acpi-notifier-1.0.4.ebuild b/mail-client/sylpheed-claws-acpi-notifier/sylpheed-claws-acpi-notifier-1.0.4.ebuild
new file mode 100644
index 000000000000..3bfb3f567d01
--- /dev/null
+++ b/mail-client/sylpheed-claws-acpi-notifier/sylpheed-claws-acpi-notifier-1.0.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-acpi-notifier/sylpheed-claws-acpi-notifier-1.0.4.ebuild,v 1.1 2006/11/11 13:57:23 ticho Exp $
+
+inherit eutils
+
+MY_PN="${PN#sylpheed-claws-}"
+MY_PN="${MY_PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+SC_BASE="2.6.0"
+SC_BASE_NAME="sylpheed-claws-extra-plugins-${SC_BASE}"
+
+DESCRIPTION="This plugin enables mail notification via LEDs on some laptops."
+HOMEPAGE="http://claws.sylpheed.org"
+SRC_URI="mirror://sourceforge/sylpheed-claws/${SC_BASE_NAME}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND=">=mail-client/sylpheed-claws-${SC_BASE}"
+
+S="${WORKDIR}/${SC_BASE_NAME}/${MY_P}"
+
+src_install() {
+ make DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+
+ # kill useless files
+ rm -f ${D}usr/lib*/sylpheed-claws/plugins/*.{a,la}
+}
+
+pkg_postinst() {
+ PROC_IFACES="$(echo /proc/acpi/{asus/mled,ibm/led,acer/mailled}) /proc/driver/acerhk/led"
+
+ local procfile
+ local message_shown=false
+
+ for procfile in ${PROC_IFACES}; do
+ if [[ -f ${procfile} ]]; then
+ elog "Make sure ${procfile} is writable by users of this plugin."
+ message_shown=true
+ fi
+ done
+}