summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-10-07 19:20:11 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-10-07 19:20:11 +0000
commitb6c613982aa71f516f0f2242058e1a4ec6272537 (patch)
treea22fb551fbad788c04c8f3d982e2d0166a615a8d /mail-client
parentamd64 stable wrt #376407 (diff)
downloadgentoo-2-b6c613982aa71f516f0f2242058e1a4ec6272537.tar.gz
gentoo-2-b6c613982aa71f516f0f2242058e1a4ec6272537.tar.bz2
gentoo-2-b6c613982aa71f516f0f2242058e1a4ec6272537.zip
Add calendar to mimetype and categories, reuse emid in ebuild logic
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/thunderbird/ChangeLog6
-rw-r--r--mail-client/thunderbird/thunderbird-7.0.1-r1.ebuild49
2 files changed, 31 insertions, 24 deletions
diff --git a/mail-client/thunderbird/ChangeLog b/mail-client/thunderbird/ChangeLog
index 906b93643e2b..5048afd6e039 100644
--- a/mail-client/thunderbird/ChangeLog
+++ b/mail-client/thunderbird/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-client/thunderbird
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/thunderbird/ChangeLog,v 1.97 2011/10/03 00:02:43 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/thunderbird/ChangeLog,v 1.98 2011/10/07 19:20:11 nirbheek Exp $
+
+ 07 Oct 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
+ thunderbird-7.0.1-r1.ebuild:
+ Add calendar to mimetype and categories, reuse emid in ebuild logic
*thunderbird-7.0.1-r1 (03 Oct 2011)
diff --git a/mail-client/thunderbird/thunderbird-7.0.1-r1.ebuild b/mail-client/thunderbird/thunderbird-7.0.1-r1.ebuild
index dbcf1986a8c3..a1c24a4ea566 100644
--- a/mail-client/thunderbird/thunderbird-7.0.1-r1.ebuild
+++ b/mail-client/thunderbird/thunderbird-7.0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/thunderbird/thunderbird-7.0.1-r1.ebuild,v 1.2 2011/10/03 07:30:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/thunderbird/thunderbird-7.0.1-r1.ebuild,v 1.3 2011/10/07 19:20:11 nirbheek Exp $
EAPI="3"
WANT_AUTOCONF="2.1"
@@ -110,7 +110,6 @@ pkg_setup() {
# Ensure we have enough disk space to compile
CHECKREQS_DISK_BUILD="4G"
check-reqs_pkg_setup
-
}
src_unpack() {
@@ -239,9 +238,22 @@ src_compile() {
src_install() {
declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
+ declare emid
emake DESTDIR="${D}" install || die "emake install failed"
+ if ! use bindist; then
+ newicon "${S}"/other-licenses/branding/thunderbird/content/icon48.png thunderbird-icon.png
+ domenu "${FILESDIR}"/icon/${PN}.desktop
+ else
+ newicon "${S}"/mail/branding/unofficial/content/icon48.png thunderbird-icon-unbranded.png
+ newmenu "${FILESDIR}"/icon/${PN}-unbranded.desktop \
+ ${PN}.desktop
+
+ sed -i -e "s:Mozilla\ Thunderbird:Lanikai:g" \
+ "${ED}"/usr/share/applications/${PN}.desktop
+ fi
+
if use crypt ; then
cd "${T}" || die
unzip "${S}"/mozilla/dist/bin/enigmail*.xpi install.rdf || die
@@ -253,22 +265,26 @@ src_install() {
fi
if use lightning ; then
- declare emid emd1 emid2
-
emid="{a62ef8ec-5fdc-40c2-873c-223b8a6925cc}"
dodir ${MOZILLA_FIVE_HOME}/extensions/${emid}
cd "${ED}"${MOZILLA_FIVE_HOME}/extensions/${emid}
unzip "${S}"/mozilla/dist/xpi-stage/gdata-provider.xpi
- emid1="calendar-timezones@mozilla.org"
- dodir ${MOZILLA_FIVE_HOME}/extensions/${emid1}
- cd "${ED}"${MOZILLA_FIVE_HOME}/extensions/${emid1}
+ emid="calendar-timezones@mozilla.org"
+ dodir ${MOZILLA_FIVE_HOME}/extensions/${emid}
+ cd "${ED}"${MOZILLA_FIVE_HOME}/extensions/${emid}
unzip "${S}"/mozilla/dist/xpi-stage/calendar-timezones.xpi
- emid2="{e2fda1a4-762b-4020-b5ad-a41df1933103}"
- dodir ${MOZILLA_FIVE_HOME}/extensions/${emid2}
- cd "${ED}"${MOZILLA_FIVE_HOME}/extensions/${emid2}
+ emid="{e2fda1a4-762b-4020-b5ad-a41df1933103}"
+ dodir ${MOZILLA_FIVE_HOME}/extensions/${emid}
+ cd "${ED}"${MOZILLA_FIVE_HOME}/extensions/${emid}
unzip "${S}"/mozilla/dist/xpi-stage/lightning.xpi
+
+ # Fix mimetype so it shows up as a calendar application in GNOME 3
+ # This requires that the .desktop file was already installed earlier
+ sed -e "s:^\(MimeType=\):\1text/calendar;:" \
+ -e "s:^\(Categories=\):\1Calendar;:" \
+ -i "${ED}"/usr/share/applications/${PN}.desktop
fi
if ! [[ ${PV} =~ alpha|beta ]]; then
@@ -278,19 +294,6 @@ src_install() {
done
fi
- if ! use bindist; then
- newicon "${S}"/other-licenses/branding/thunderbird/content/icon48.png thunderbird-icon.png
- domenu "${FILESDIR}"/icon/${PN}.desktop
- else
- newicon "${S}"/mail/branding/unofficial/content/icon48.png thunderbird-icon-unbranded.png
- newmenu "${FILESDIR}"/icon/${PN}-unbranded.desktop \
- ${PN}.desktop
-
- sed -i -e "s:Mozilla\ Thunderbird:Lanikai:g" \
- "${D}"/usr/share/applications/${PN}.desktop
-
- fi
-
pax-mark m "${ED}"/${MOZILLA_FIVE_HOME}/thunderbird-bin
# Enable very specific settings for thunderbird-3