summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-05-18 02:00:29 +0000
committerTim Harder <radhermit@gentoo.org>2013-05-18 02:00:29 +0000
commit985d8cd126f8866b8d1c748555fae3e143f08851 (patch)
treef8dc69c3f0dae62fce1a4b900ea520ffc49368fe /mail-client
parentversion bump (diff)
downloadgentoo-2-985d8cd126f8866b8d1c748555fae3e143f08851.tar.gz
gentoo-2-985d8cd126f8866b8d1c748555fae3e143f08851.tar.bz2
gentoo-2-985d8cd126f8866b8d1c748555fae3e143f08851.zip
Version bump.
(Portage version: 2.2.0_alpha175/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/roundcube/ChangeLog7
-rw-r--r--mail-client/roundcube/roundcube-0.9.1.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/mail-client/roundcube/ChangeLog b/mail-client/roundcube/ChangeLog
index da085be67c75..553733b5894c 100644
--- a/mail-client/roundcube/ChangeLog
+++ b/mail-client/roundcube/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/roundcube
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/ChangeLog,v 1.113 2013/04/18 04:57:51 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/ChangeLog,v 1.114 2013/05/18 02:00:29 radhermit Exp $
+
+*roundcube-0.9.1 (18 May 2013)
+
+ 18 May 2013; Tim Harder <radhermit@gentoo.org> +roundcube-0.9.1.ebuild:
+ Version bump.
18 Apr 2013; Tim Harder <radhermit@gentoo.org> -roundcube-0.8.4.ebuild,
-roundcube-0.8.5.ebuild, -roundcube-0.9_rc2.ebuild:
diff --git a/mail-client/roundcube/roundcube-0.9.1.ebuild b/mail-client/roundcube/roundcube-0.9.1.ebuild
new file mode 100644
index 000000000000..a8a7974dde85
--- /dev/null
+++ b/mail-client/roundcube/roundcube-0.9.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/roundcube-0.9.1.ebuild,v 1.1 2013/05/18 02:00:29 radhermit Exp $
+
+EAPI=5
+
+inherit webapp
+
+MY_PN=${PN}mail
+MY_P=${MY_PN}-${PV/_/-}
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="http://roundcube.net"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ldap +mysql postgres sqlite ssl spell"
+
+RDEPEND="virtual/httpd-php
+ >=dev-lang/php-5.3[crypt,gd,iconv,json,ldap?,pdo,postgres?,session,sockets,ssl?,xml,unicode]
+ mysql? ( || ( dev-lang/php[mysql] dev-lang/php[mysqli] ) )
+ spell? ( dev-lang/php[curl,spell] )
+ sqlite? ( || ( dev-lang/php[sqlite] dev-lang/php[sqlite3] ) )
+ >=dev-php/PEAR-Mail_Mime-1.8.1
+ >=dev-php/PEAR-Net_SMTP-1.4.2
+ >=dev-php/PEAR-Net_IDNA2-0.1.1
+ >=dev-php/PEAR-Auth_SASL-1.0.3"
+
+need_httpd_cgi
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ cp config/db.inc.php{.dist,} || die
+ cp config/main.inc.php{.dist,} || die
+
+ # Remove bundled PEAR packages
+ rm -r program/lib/{Auth,Mail,Net,PEAR*} || die
+}
+
+src_install() {
+ webapp_src_preinst
+ dodoc CHANGELOG INSTALL README.md UPGRADING
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/{db,main}.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-0.6.txt
+ webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en-0.6.txt
+ webapp_postupgrade_txt en UPGRADING
+ webapp_src_install
+}