summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-09-04 09:52:48 +0000
committerTim Harder <radhermit@gentoo.org>2013-09-04 09:52:48 +0000
commit78c1af8a02f056f00cfc485d3d59918b20c7ae1c (patch)
treed3c8d1f50dd0f227e5f7544b870a72b30f8f5c31 /mail-client
parentStable for ppc, wrt bug #483092 (diff)
downloadgentoo-2-78c1af8a02f056f00cfc485d3d59918b20c7ae1c.tar.gz
gentoo-2-78c1af8a02f056f00cfc485d3d59918b20c7ae1c.tar.bz2
gentoo-2-78c1af8a02f056f00cfc485d3d59918b20c7ae1c.zip
Version bump (bug #482206).
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/roundcube/ChangeLog7
-rw-r--r--mail-client/roundcube/roundcube-0.9.3.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/mail-client/roundcube/ChangeLog b/mail-client/roundcube/ChangeLog
index ec62960ab961..a43d2776eaa2 100644
--- a/mail-client/roundcube/ChangeLog
+++ b/mail-client/roundcube/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/roundcube
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/ChangeLog,v 1.120 2013/07/30 07:30:47 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/ChangeLog,v 1.121 2013/09/04 09:52:48 radhermit Exp $
+
+*roundcube-0.9.3 (04 Sep 2013)
+
+ 04 Sep 2013; Tim Harder <radhermit@gentoo.org> +roundcube-0.9.3.ebuild:
+ Version bump (bug #482206).
30 Jul 2013; Tim Harder <radhermit@gentoo.org> -roundcube-0.9.0.ebuild,
-roundcube-0.9.1.ebuild:
diff --git a/mail-client/roundcube/roundcube-0.9.3.ebuild b/mail-client/roundcube/roundcube-0.9.3.ebuild
new file mode 100644
index 000000000000..d67bd095341b
--- /dev/null
+++ b/mail-client/roundcube/roundcube-0.9.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/roundcube-0.9.3.ebuild,v 1.1 2013/09/04 09:52:48 radhermit Exp $
+
+EAPI=5
+
+inherit webapp
+
+MY_PN=${PN}mail
+MY_P=${MY_PN}-${PV/_/-}
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="http://roundcube.net"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ldap +mysql postgres sqlite ssl spell"
+
+RDEPEND="virtual/httpd-php
+ >=dev-lang/php-5.3[crypt,gd,iconv,json,ldap?,pdo,postgres?,session,sockets,ssl?,xml,unicode]
+ mysql? ( || ( dev-lang/php[mysql] dev-lang/php[mysqli] ) )
+ spell? ( dev-lang/php[curl,spell] )
+ sqlite? ( || ( dev-lang/php[sqlite] dev-lang/php[sqlite3] ) )
+ >=dev-php/PEAR-Mail_Mime-1.8.1
+ >=dev-php/PEAR-Net_SMTP-1.4.2
+ >=dev-php/PEAR-Net_IDNA2-0.1.1
+ >=dev-php/PEAR-Auth_SASL-1.0.3"
+
+need_httpd_cgi
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ cp config/db.inc.php{.dist,} || die
+ cp config/main.inc.php{.dist,} || die
+
+ # Remove bundled PEAR packages
+ rm -r program/lib/{Auth,Mail,Net,PEAR*} || die
+}
+
+src_install() {
+ webapp_src_preinst
+ dodoc CHANGELOG INSTALL README.md UPGRADING
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/{db,main}.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-0.6.txt
+ webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en-0.6.txt
+ webapp_postupgrade_txt en UPGRADING
+ webapp_src_install
+}