summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-03-24 17:11:16 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-03-24 17:11:16 +0000
commit7192cb126403911699f9371d629efc2cc9f4b852 (patch)
tree4d506874c7a91c05d637af1cf14231c47c3abcf1 /mail-client
parentx86 stable wrt bug #405149 (diff)
downloadgentoo-2-7192cb126403911699f9371d629efc2cc9f4b852.tar.gz
gentoo-2-7192cb126403911699f9371d629efc2cc9f4b852.tar.bz2
gentoo-2-7192cb126403911699f9371d629efc2cc9f4b852.zip
mail-client/alot: Version bump to 0.3.
(Portage version: 2.1.10.50/cvs/Linux x86_64)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/alot/ChangeLog11
-rw-r--r--mail-client/alot/alot-0.3.ebuild45
2 files changed, 54 insertions, 2 deletions
diff --git a/mail-client/alot/ChangeLog b/mail-client/alot/ChangeLog
index 06d1fbd5474e..f5b353bb078b 100644
--- a/mail-client/alot/ChangeLog
+++ b/mail-client/alot/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-client/alot
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/alot/ChangeLog,v 1.2 2011/12/27 11:23:56 aidecoe Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/alot/ChangeLog,v 1.3 2012/03/24 17:11:16 aidecoe Exp $
+
+*alot-0.3 (24 Mar 2012)
+
+ 24 Mar 2012; Amadeusz Żołnowski <aidecoe@gentoo.org> +alot-0.3.ebuild:
+ Version bump. Dependencies has been changed. VERSION file is no longer used
+ by setup. Added postinst warning about change in format of config file.
+ vcs-snapshot is used in the ebuild instead of custom src_unpack().
*alot-0.21-r1 (27 Dec 2011)
diff --git a/mail-client/alot/alot-0.3.ebuild b/mail-client/alot/alot-0.3.ebuild
new file mode 100644
index 000000000000..fe71412253f8
--- /dev/null
+++ b/mail-client/alot/alot-0.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/alot/alot-0.3.ebuild,v 1.1 2012/03/24 17:11:16 aidecoe Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.7"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[456] 3.*"
+
+inherit distutils vcs-snapshot
+
+DESCRIPTION="Experimental terminal UI for net-mail/notmuch written in Python"
+HOMEPAGE="https://github.com/pazz/alot"
+SRC_URI="${HOMEPAGE}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ >=dev-python/configobj-4.6.0
+ >=dev-python/twisted-10.2.0
+ >=dev-python/urwid-1.0.0
+ net-mail/mailbase
+ >=net-mail/notmuch-0.12[crypt,python]
+ sys-apps/file[python]
+ "
+
+src_prepare() {
+ distutils_src_prepare
+
+ local md
+ for md in *.md; do
+ mv "${md}" "${md%.md}"
+ done
+}
+
+pkg_postinst() {
+ ewarn "If you're upgrading from version prior to 0.3, you need to remove"
+ ewarn "current config (\$HOME/.config/alot/config) before running alot,"
+ ewarn "because its format has been changed."
+}