summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2009-12-15 18:06:31 +0000
committerFabian Groffen <grobian@gentoo.org>2009-12-15 18:06:31 +0000
commit6fedae8c1ad41004dccecd5bc6d872a8a7bbee6d (patch)
treecdf928082b180c9074cbd6b968496de108b52e9d /mail-client
parentFix HOMEPAGE and SRC_URI wrt #297028. (diff)
downloadgentoo-2-6fedae8c1ad41004dccecd5bc6d872a8a7bbee6d.tar.gz
gentoo-2-6fedae8c1ad41004dccecd5bc6d872a8a7bbee6d.tar.bz2
gentoo-2-6fedae8c1ad41004dccecd5bc6d872a8a7bbee6d.zip
Bump to fix two bugs fixed upstream: don't store header colors in header cache and fix off-by-one errors in mailcap parsing
(Portage version: 2.2.00.15095-prefix/cvs/Darwin powerpc, RepoMan options: --force)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mutt/ChangeLog11
-rw-r--r--mail-client/mutt/files/mutt-1.5.20-no-hcolor-in-hcache-b7d2cb7c7ce1.patch22
-rw-r--r--mail-client/mutt/files/mutt-1.5.20-off-by-one-mailcap-736b6af3c5f1.patch29
-rw-r--r--mail-client/mutt/mutt-1.5.20-r9.ebuild (renamed from mail-client/mutt/mutt-1.5.20-r8.ebuild)4
4 files changed, 64 insertions, 2 deletions
diff --git a/mail-client/mutt/ChangeLog b/mail-client/mutt/ChangeLog
index 3af7e5562e37..200af38134c1 100644
--- a/mail-client/mutt/ChangeLog
+++ b/mail-client/mutt/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for mail-client/mutt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/ChangeLog,v 1.169 2009/12/08 13:36:30 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/ChangeLog,v 1.170 2009/12/15 18:06:31 grobian Exp $
+
+*mutt-1.5.20-r9 (15 Dec 2009)
+
+ 15 Dec 2009; Fabian Groffen <grobian@gentoo.org> -mutt-1.5.20-r8.ebuild,
+ +mutt-1.5.20-r9.ebuild,
+ +files/mutt-1.5.20-no-hcolor-in-hcache-b7d2cb7c7ce1.patch,
+ +files/mutt-1.5.20-off-by-one-mailcap-736b6af3c5f1.patch:
+ Bump to fix two bugs fixed upstream: don't store header colors in header
+ cache and fix off-by-one errors in mailcap parsing
08 Dec 2009; Fabian Groffen <grobian@gentoo.org> mutt-1.5.20-r8.ebuild,
+files/mutt-1.5.20-ssl-stack-compile-fix-1cf34ea1f128.patch:
diff --git a/mail-client/mutt/files/mutt-1.5.20-no-hcolor-in-hcache-b7d2cb7c7ce1.patch b/mail-client/mutt/files/mutt-1.5.20-no-hcolor-in-hcache-b7d2cb7c7ce1.patch
new file mode 100644
index 000000000000..a75c434ee76f
--- /dev/null
+++ b/mail-client/mutt/files/mutt-1.5.20-no-hcolor-in-hcache-b7d2cb7c7ce1.patch
@@ -0,0 +1,22 @@
+http://dev.mutt.org/hg/mutt/rev/b7d2cb7c7ce1
+
+# HG changeset patch
+# User Daniel Jacobowitz <dan@debian.org>
+# Date 1260514342 28800
+# Node ID b7d2cb7c7ce19e67444412d0bc840a4e7ddf303f
+# Parent 1cf34ea1f12864efa1c3f4481fc409ed6c8e11eb
+Do not store header color in hcache.
+If the color directive is removed from muttrc, the cached value from
+the last directive would otherwise still be in effect.
+
+--- a/hcache.c Mon Dec 07 23:08:47 2009 -0800
++++ b/hcache.c Thu Dec 10 22:52:22 2009 -0800
+@@ -624,6 +624,7 @@
+ nh.limited = 0;
+ nh.num_hidden = 0;
+ nh.recipient = 0;
++ nh.pair = 0;
+ nh.attach_valid = 0;
+ nh.path = NULL;
+ nh.tree = NULL;
+
diff --git a/mail-client/mutt/files/mutt-1.5.20-off-by-one-mailcap-736b6af3c5f1.patch b/mail-client/mutt/files/mutt-1.5.20-off-by-one-mailcap-736b6af3c5f1.patch
new file mode 100644
index 000000000000..8b5e0f89159a
--- /dev/null
+++ b/mail-client/mutt/files/mutt-1.5.20-off-by-one-mailcap-736b6af3c5f1.patch
@@ -0,0 +1,29 @@
+http://dev.mutt.org/trac/changeset/736b6af3c5f1
+http://dev.mutt.org/trac/ticket/3362
+
+Fix off-by-one errors in mailcap parser. Closes #3362
+
+
+Index: rfc1524.c
+===================================================================
+--- rfc1524.c (revision 5827:776ef9dbe4d2)
++++ rfc1524.c (revision 6033:736b6af3c5f1)
+@@ -69,7 +69,8 @@
+ mutt_sanitize_filename (type, 0);
+
+- while (command[x] && x<clen && y<sizeof(buf))
+- {
+- if (command[x] == '\\') {
++ while (x < clen && command[x] && y < sizeof (buf) - 1)
++ {
++ if (command[x] == '\\')
++ {
+ x++;
+ buf[y++] = command[x++];
+@@ -86,5 +87,5 @@
+
+ x++;
+- while (command[x] && command[x] != '}' && z<sizeof(param))
++ while (command[x] && command[x] != '}' && z < sizeof (param) - 1)
+ param[z++] = command[x++];
+ param[z] = '\0';
diff --git a/mail-client/mutt/mutt-1.5.20-r8.ebuild b/mail-client/mutt/mutt-1.5.20-r9.ebuild
index 38736b3a91bc..eb641a719dd1 100644
--- a/mail-client/mutt/mutt-1.5.20-r8.ebuild
+++ b/mail-client/mutt/mutt-1.5.20-r9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/mutt-1.5.20-r8.ebuild,v 1.7 2009/12/08 13:36:30 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/mutt-1.5.20-r9.ebuild,v 1.1 2009/12/15 18:06:31 grobian Exp $
inherit eutils flag-o-matic autotools
@@ -102,6 +102,8 @@ src_unpack() {
epatch "${FILESDIR}"/mutt-1.5.20-next-invalid-pattern-crash-6a08a5244d60.patch
epatch "${FILESDIR}"/mutt-1.5.20-ssl-CVE-2009-3765-dc09812e63a3.patch
epatch "${FILESDIR}"/mutt-1.5.20-ssl-stack-compile-fix-1cf34ea1f128.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-no-hcolor-in-hcache-b7d2cb7c7ce1.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-off-by-one-mailcap-736b6af3c5f1.patch
# patch version string for bug reports
sed -i -e 's/"Mutt %s (%s)"/"Mutt %s (%s, Gentoo '"${PVR}"')"/' \