summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-05-12 12:45:06 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-05-12 12:45:06 +0000
commit57340576bb243d6433ad410e8df331390de46cca (patch)
tree12767256464d2dab5709cdb8291fc86aa67bed56 /mail-client
parentversion bump for bug 218708 (diff)
downloadgentoo-2-57340576bb243d6433ad410e8df331390de46cca.tar.gz
gentoo-2-57340576bb243d6433ad410e8df331390de46cca.tar.bz2
gentoo-2-57340576bb243d6433ad410e8df331390de46cca.zip
version bump for bug 218708
(Portage version: 2.1.4.4)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/claws-mail-notification/ChangeLog8
-rw-r--r--mail-client/claws-mail-notification/claws-mail-notification-0.16.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/mail-client/claws-mail-notification/ChangeLog b/mail-client/claws-mail-notification/ChangeLog
index a1c56b8e0a7e..f6e4e9e3dab6 100644
--- a/mail-client/claws-mail-notification/ChangeLog
+++ b/mail-client/claws-mail-notification/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/claws-mail-notification
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-notification/ChangeLog,v 1.13 2008/02/13 20:52:57 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-notification/ChangeLog,v 1.14 2008/05/12 12:45:06 opfer Exp $
+
+*claws-mail-notification-0.16 (12 May 2008)
+
+ 12 May 2008; Christian Faulhammer <opfer@gentoo.org>
+ +claws-mail-notification-0.16.ebuild:
+ version bump for bug 218708
13 Feb 2008; Andrej Kacian <ticho@gentoo.org>
claws-mail-notification-0.12.ebuild,
diff --git a/mail-client/claws-mail-notification/claws-mail-notification-0.16.ebuild b/mail-client/claws-mail-notification/claws-mail-notification-0.16.ebuild
new file mode 100644
index 000000000000..f42a39e1aa77
--- /dev/null
+++ b/mail-client/claws-mail-notification/claws-mail-notification-0.16.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-notification/claws-mail-notification-0.16.ebuild,v 1.1 2008/05/12 12:45:06 opfer Exp $
+
+MY_P="${PN#claws-mail-}_plugin-${PV}"
+
+DESCRIPTION="Plugin providing various ways to notify user of new and unread mail"
+HOMEPAGE="http://www.claws-mail.org/"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+RDEPEND=">=mail-client/claws-mail-3.4.0
+ >=x11-libs/gtk+-2.10
+ libnotify? ( x11-libs/libnotify )"
+DEPEND="${RDPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf $(use_enable libnotify) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+
+ # kill useless files
+ rm -f "${D}"/usr/lib*/claws-mail/plugins/*.{a,la}
+}