summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2007-08-09 09:28:05 +0000
committerAkinori Hattori <hattya@gentoo.org>2007-08-09 09:28:05 +0000
commit53685cdd0d7516a73a8a21a30a6ca59db8060447 (patch)
tree8fd4212c9aa64c7245579491b9e1ff22c404ba2f /mail-client
parentppc stable, bug #187205 (diff)
downloadgentoo-2-53685cdd0d7516a73a8a21a30a6ca59db8060447.tar.gz
gentoo-2-53685cdd0d7516a73a8a21a30a6ca59db8060447.tar.bz2
gentoo-2-53685cdd0d7516a73a8a21a30a6ca59db8060447.zip
new upstream release. fixes bug #186075.
(Portage version: 2.1.2.11)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/sylpheed/ChangeLog7
-rw-r--r--mail-client/sylpheed/files/digest-sylpheed-2.4.43
-rw-r--r--mail-client/sylpheed/sylpheed-2.4.4.ebuild72
3 files changed, 81 insertions, 1 deletions
diff --git a/mail-client/sylpheed/ChangeLog b/mail-client/sylpheed/ChangeLog
index 3435ac9dd594..4a1b3bfad4fb 100644
--- a/mail-client/sylpheed/ChangeLog
+++ b/mail-client/sylpheed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/sylpheed
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.235 2007/07/13 13:41:45 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.236 2007/08/09 09:28:05 hattya Exp $
+
+*sylpheed-2.4.4 (09 Aug 2007)
+
+ 09 Aug 2007; Akinori Hattori <hattya@gentoo.org> +sylpheed-2.4.4.ebuild:
+ new upstream release. fixes bug #186075.
13 Jul 2007; Gustavo Zacarias <gustavoz@gentoo.org> sylpheed-2.4.2.ebuild:
Stable on sparc
diff --git a/mail-client/sylpheed/files/digest-sylpheed-2.4.4 b/mail-client/sylpheed/files/digest-sylpheed-2.4.4
new file mode 100644
index 000000000000..998f31af23ec
--- /dev/null
+++ b/mail-client/sylpheed/files/digest-sylpheed-2.4.4
@@ -0,0 +1,3 @@
+MD5 79225738189e78e9a9f2a47a3ee4f3d6 sylpheed-2.4.4.tar.bz2 2743315
+RMD160 052a03adfa931046b8c40cbd3e67cb20ce2fe42f sylpheed-2.4.4.tar.bz2 2743315
+SHA256 675e1a89e6b4e71d45b1599c7b65c5786d822dd5864c7df317b4095ffc2d185f sylpheed-2.4.4.tar.bz2 2743315
diff --git a/mail-client/sylpheed/sylpheed-2.4.4.ebuild b/mail-client/sylpheed/sylpheed-2.4.4.ebuild
new file mode 100644
index 000000000000..f8d736ecb045
--- /dev/null
+++ b/mail-client/sylpheed/sylpheed-2.4.4.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/sylpheed-2.4.4.ebuild,v 1.1 2007/08/09 09:28:05 hattya Exp $
+
+inherit autotools eutils
+
+IUSE="crypt ipv6 ldap nls pda spell ssl xface"
+
+DESCRIPTION="A lightweight email client and newsreader"
+HOMEPAGE="http://sylpheed.sraoss.jp/"
+SRC_URI="http://sylpheed.sraoss.jp/${PN}/v${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+
+DEPEND=">=x11-libs/gtk+-2.4
+ nls? ( >=sys-devel/gettext-0.12.1 )
+ crypt? ( >=app-crypt/gpgme-0.4.5 )
+ ldap? ( >=net-nds/openldap-2.0.11 )
+ pda? ( app-pda/jpilot )
+ spell? ( app-text/gtkspell )
+ ssl? ( dev-libs/openssl )
+ xface? ( >=media-libs/compface-1.4 )"
+RDEPEND="${DEPEND}
+ app-misc/mime-types
+ x11-misc/shared-mime-info"
+
+AT_M4DIR="ac"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-2.*.diff
+
+ use crypt || cp ac/missing/gpgme.m4 ac
+
+ eautomake
+
+}
+
+src_compile() {
+
+ local htmldir=/usr/share/doc/${PF}/html
+
+ econf \
+ $(use_enable crypt gpgme) \
+ $(use_enable ipv6) \
+ $(use_enable ldap) \
+ $(use_enable nls) \
+ $(use_enable pda jpilot) \
+ $(use_enable spell gtkspell) \
+ $(use_enable ssl) \
+ $(use_enable xface compface) \
+ --with-manualdir=${htmldir}/manual \
+ --with-faqdir=${htmldir}/faq \
+ || die
+ emake || die
+
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog* NEWS* README* TODO*
+ doicon *.png
+ domenu *.desktop
+
+}