summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2007-09-03 13:53:33 +0000
committerAkinori Hattori <hattya@gentoo.org>2007-09-03 13:53:33 +0000
commit3f98dd152d1d708897d6f37d9dd731b3f2059c8f (patch)
tree1d9000e8ce4cae69fa9f710edc366d5d1cdcdd92 /mail-client
parentAdd ~x86 wrt #191107 (diff)
downloadgentoo-2-3f98dd152d1d708897d6f37d9dd731b3f2059c8f.tar.gz
gentoo-2-3f98dd152d1d708897d6f37d9dd731b3f2059c8f.tar.bz2
gentoo-2-3f98dd152d1d708897d6f37d9dd731b3f2059c8f.zip
new upstream release.
(Portage version: 2.1.2.12)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/sylpheed/ChangeLog7
-rw-r--r--mail-client/sylpheed/files/digest-sylpheed-2.4.53
-rw-r--r--mail-client/sylpheed/sylpheed-2.4.5.ebuild72
3 files changed, 81 insertions, 1 deletions
diff --git a/mail-client/sylpheed/ChangeLog b/mail-client/sylpheed/ChangeLog
index b0b03e026b8e..a7118cf8de18 100644
--- a/mail-client/sylpheed/ChangeLog
+++ b/mail-client/sylpheed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/sylpheed
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.238 2007/08/13 20:53:55 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.239 2007/09/03 13:53:33 hattya Exp $
+
+*sylpheed-2.4.5 (03 Sep 2007)
+
+ 03 Sep 2007; Akinori Hattori <hattya@gentoo.org> +sylpheed-2.4.5.ebuild:
+ new upstream release.
13 Aug 2007; Tobias Scherbaum <dertobi123@gentoo.org>
sylpheed-2.4.2.ebuild:
diff --git a/mail-client/sylpheed/files/digest-sylpheed-2.4.5 b/mail-client/sylpheed/files/digest-sylpheed-2.4.5
new file mode 100644
index 000000000000..028394db3560
--- /dev/null
+++ b/mail-client/sylpheed/files/digest-sylpheed-2.4.5
@@ -0,0 +1,3 @@
+MD5 27e7c802f9af3e3c58e4457aadd36a91 sylpheed-2.4.5.tar.bz2 2747464
+RMD160 1940ebe99ddd2a1394f43c93fc5447b34c9ba0fc sylpheed-2.4.5.tar.bz2 2747464
+SHA256 353b9a94283519203db7593e537f83c65b372cc0fd0befcb2ad932d01faec53e sylpheed-2.4.5.tar.bz2 2747464
diff --git a/mail-client/sylpheed/sylpheed-2.4.5.ebuild b/mail-client/sylpheed/sylpheed-2.4.5.ebuild
new file mode 100644
index 000000000000..a20f2528c4ba
--- /dev/null
+++ b/mail-client/sylpheed/sylpheed-2.4.5.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/sylpheed-2.4.5.ebuild,v 1.1 2007/09/03 13:53:33 hattya Exp $
+
+inherit autotools eutils
+
+IUSE="crypt ipv6 ldap nls pda spell ssl xface"
+
+DESCRIPTION="A lightweight email client and newsreader"
+HOMEPAGE="http://sylpheed.sraoss.jp/"
+SRC_URI="http://sylpheed.sraoss.jp/${PN}/v${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+
+DEPEND=">=x11-libs/gtk+-2.4
+ nls? ( >=sys-devel/gettext-0.12.1 )
+ crypt? ( >=app-crypt/gpgme-0.4.5 )
+ ldap? ( >=net-nds/openldap-2.0.11 )
+ pda? ( app-pda/jpilot )
+ spell? ( app-text/gtkspell )
+ ssl? ( dev-libs/openssl )
+ xface? ( >=media-libs/compface-1.4 )"
+RDEPEND="${DEPEND}
+ app-misc/mime-types
+ x11-misc/shared-mime-info"
+
+AT_M4DIR="ac"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-2.*.diff
+
+ use crypt || cp ac/missing/gpgme.m4 ac
+
+ eautomake
+
+}
+
+src_compile() {
+
+ local htmldir=/usr/share/doc/${PF}/html
+
+ econf \
+ $(use_enable crypt gpgme) \
+ $(use_enable ipv6) \
+ $(use_enable ldap) \
+ $(use_enable nls) \
+ $(use_enable pda jpilot) \
+ $(use_enable spell gtkspell) \
+ $(use_enable ssl) \
+ $(use_enable xface compface) \
+ --with-manualdir=${htmldir}/manual \
+ --with-faqdir=${htmldir}/faq \
+ || die
+ emake || die
+
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog* NEWS* README* TODO*
+ doicon *.png
+ domenu *.desktop
+
+}