summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimone Gotti <motaboy@gentoo.org>2004-11-18 23:26:18 +0000
committerSimone Gotti <motaboy@gentoo.org>2004-11-18 23:26:18 +0000
commit3e514398174f174962986f81ebd3b5206c05caee (patch)
tree95f856eb39e68d6e95114340c00d47e93acbaef9 /mail-client
parentwhitespace fix. (Manifest recommit) (diff)
downloadgentoo-2-3e514398174f174962986f81ebd3b5206c05caee.tar.gz
gentoo-2-3e514398174f174962986f81ebd3b5206c05caee.tar.bz2
gentoo-2-3e514398174f174962986f81ebd3b5206c05caee.zip
Added a patch to the configure script to honor the "arts" USE flag. Fixes bug #69532.
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/kbiff/ChangeLog7
-rw-r--r--mail-client/kbiff/files/kbiff-3.7-configure-arts.patch141
-rw-r--r--mail-client/kbiff/kbiff-3.7.ebuild8
3 files changed, 154 insertions, 2 deletions
diff --git a/mail-client/kbiff/ChangeLog b/mail-client/kbiff/ChangeLog
index e34e788c02dd..74a32e6e334e 100644
--- a/mail-client/kbiff/ChangeLog
+++ b/mail-client/kbiff/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/kbiff
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/kbiff/ChangeLog,v 1.8 2004/09/25 22:01:57 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/kbiff/ChangeLog,v 1.9 2004/11/18 23:26:18 motaboy Exp $
+
+ 19 Nov 2004; Simone Gotti <motaboy@gentoo.org>
+ +files/kbiff-3.7-configure-arts.patch, kbiff-3.7.ebuild:
+ Added a patch to the configure script to honor the "arts" USE flag. Fixes
+ bug #69532.
25 Sep 2004; Jason Wever <weeve@gentoo.org> kbiff-3.7.ebuild:
Stable on sparc.
diff --git a/mail-client/kbiff/files/kbiff-3.7-configure-arts.patch b/mail-client/kbiff/files/kbiff-3.7-configure-arts.patch
new file mode 100644
index 000000000000..e960ce1ff439
--- /dev/null
+++ b/mail-client/kbiff/files/kbiff-3.7-configure-arts.patch
@@ -0,0 +1,141 @@
+--- configure.orig 2004-11-18 19:52:29.980476896 +0000
++++ configure 2004-11-18 19:53:03.911318624 +0000
+@@ -22767,138 +22767,6 @@
+ fi
+
+
+- echo "$as_me:$LINENO: checking for mcopidl" >&5
+-echo $ECHO_N "checking for mcopidl... $ECHO_C" >&6
+- if test -n "$MCOPIDL"; then
+- kde_cv_path="$MCOPIDL";
+- else
+- kde_cache=`echo mcopidl | sed 'y%./+-%__p_%'`
+-
+- if eval "test \"\${kde_cv_path_$kde_cache+set}\" = set"; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+-
+- kde_cv_path="NONE"
+- dirs="$kde_default_bindirs"
+- kde_save_IFS=$IFS
+- IFS=':'
+- for dir in $PATH; do
+- dirs="$dirs $dir"
+- done
+- IFS=$kde_save_IFS
+-
+- for dir in $dirs; do
+- if test -x "$dir/mcopidl"; then
+- if test -n ""
+- then
+- evalstr="$dir/mcopidl 2>&1 "
+- if eval $evalstr; then
+- kde_cv_path="$dir/mcopidl"
+- break
+- fi
+- else
+- kde_cv_path="$dir/mcopidl"
+- break
+- fi
+- fi
+- done
+-
+- eval "kde_cv_path_$kde_cache=$kde_cv_path"
+-
+-
+-fi
+-
+-
+- eval "kde_cv_path=\"`echo '$kde_cv_path_'$kde_cache`\""
+-
+- fi
+-
+- if test -z "$kde_cv_path" || test "$kde_cv_path" = NONE; then
+- echo "$as_me:$LINENO: result: not found" >&5
+-echo "${ECHO_T}not found" >&6
+-
+- { { echo "$as_me:$LINENO: error: The important program mcopidl was not found!
+-Please check whether you installed KDE correctly.
+-" >&5
+-echo "$as_me: error: The important program mcopidl was not found!
+-Please check whether you installed KDE correctly.
+-" >&2;}
+- { (exit 1); exit 1; }; }
+-
+- else
+- echo "$as_me:$LINENO: result: $kde_cv_path" >&5
+-echo "${ECHO_T}$kde_cv_path" >&6
+- MCOPIDL=$kde_cv_path
+-
+- fi
+-
+-
+- echo "$as_me:$LINENO: checking for artsc-config" >&5
+-echo $ECHO_N "checking for artsc-config... $ECHO_C" >&6
+- if test -n "$ARTSCCONFIG"; then
+- kde_cv_path="$ARTSCCONFIG";
+- else
+- kde_cache=`echo artsc-config | sed 'y%./+-%__p_%'`
+-
+- if eval "test \"\${kde_cv_path_$kde_cache+set}\" = set"; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+-
+- kde_cv_path="NONE"
+- dirs="$kde_default_bindirs"
+- kde_save_IFS=$IFS
+- IFS=':'
+- for dir in $PATH; do
+- dirs="$dirs $dir"
+- done
+- IFS=$kde_save_IFS
+-
+- for dir in $dirs; do
+- if test -x "$dir/artsc-config"; then
+- if test -n ""
+- then
+- evalstr="$dir/artsc-config 2>&1 "
+- if eval $evalstr; then
+- kde_cv_path="$dir/artsc-config"
+- break
+- fi
+- else
+- kde_cv_path="$dir/artsc-config"
+- break
+- fi
+- fi
+- done
+-
+- eval "kde_cv_path_$kde_cache=$kde_cv_path"
+-
+-
+-fi
+-
+-
+- eval "kde_cv_path=\"`echo '$kde_cv_path_'$kde_cache`\""
+-
+- fi
+-
+- if test -z "$kde_cv_path" || test "$kde_cv_path" = NONE; then
+- echo "$as_me:$LINENO: result: not found" >&5
+-echo "${ECHO_T}not found" >&6
+-
+- { { echo "$as_me:$LINENO: error: The important program artsc-config was not found!
+-Please check whether you installed KDE correctly.
+-" >&5
+-echo "$as_me: error: The important program artsc-config was not found!
+-Please check whether you installed KDE correctly.
+-" >&2;}
+- { (exit 1); exit 1; }; }
+-
+- else
+- echo "$as_me:$LINENO: result: $kde_cv_path" >&5
+-echo "${ECHO_T}$kde_cv_path" >&6
+- ARTSCCONFIG=$kde_cv_path
+-
+- fi
+-
+-
+ echo "$as_me:$LINENO: checking for kde-config" >&5
+ echo $ECHO_N "checking for kde-config... $ECHO_C" >&6
+ if test -n "$KDECONFIG"; then
diff --git a/mail-client/kbiff/kbiff-3.7.ebuild b/mail-client/kbiff/kbiff-3.7.ebuild
index ee265df6ba83..bc0481414500 100644
--- a/mail-client/kbiff/kbiff-3.7.ebuild
+++ b/mail-client/kbiff/kbiff-3.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/kbiff/kbiff-3.7.ebuild,v 1.7 2004/09/25 22:01:57 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/kbiff/kbiff-3.7.ebuild,v 1.8 2004/11/18 23:26:18 motaboy Exp $
inherit kde
@@ -15,3 +15,9 @@ IUSE=""
DEPEND=">=kde-base/kdebase-3"
need-kde 3
+
+src_unpack() {
+ kde_src_unpack
+
+ use arts || epatch ${FILESDIR}/${P}-configure-arts.patch
+} \ No newline at end of file