summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2009-07-26 15:14:31 +0000
committerAkinori Hattori <hattya@gentoo.org>2009-07-26 15:14:31 +0000
commit39acdf8927d192a528beb455be35fcb5e1efb75e (patch)
tree25e01b2734a6e4a85d2ce8ad572ef56b6cdac5fe /mail-client
parentRemove deprecated musepack-tools SV7 from deps. (diff)
downloadgentoo-2-39acdf8927d192a528beb455be35fcb5e1efb75e.tar.gz
gentoo-2-39acdf8927d192a528beb455be35fcb5e1efb75e.tar.bz2
gentoo-2-39acdf8927d192a528beb455be35fcb5e1efb75e.zip
new upstream release.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/sylpheed/ChangeLog8
-rw-r--r--mail-client/sylpheed/files/sylpheed-2.7-shared-mime-info.diff55
-rw-r--r--mail-client/sylpheed/sylpheed-2.7.0.ebuild74
3 files changed, 136 insertions, 1 deletions
diff --git a/mail-client/sylpheed/ChangeLog b/mail-client/sylpheed/ChangeLog
index 706b9bdf746b..03b7704f4298 100644
--- a/mail-client/sylpheed/ChangeLog
+++ b/mail-client/sylpheed/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/sylpheed
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.276 2009/07/19 10:56:43 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.277 2009/07/26 15:14:31 hattya Exp $
+
+*sylpheed-2.7.0 (26 Jul 2009)
+
+ 26 Jul 2009; Akinori Hattori <hattya@gentoo.org>
+ +files/sylpheed-2.7-shared-mime-info.diff, +sylpheed-2.7.0.ebuild:
+ new upstream release.
19 Jul 2009; Raúl Porcel <armin76@gentoo.org> sylpheed-2.6.0.ebuild:
alpha/ia64/sparc stable wrt #276830
diff --git a/mail-client/sylpheed/files/sylpheed-2.7-shared-mime-info.diff b/mail-client/sylpheed/files/sylpheed-2.7-shared-mime-info.diff
new file mode 100644
index 000000000000..4e0783dc0214
--- /dev/null
+++ b/mail-client/sylpheed/files/sylpheed-2.7-shared-mime-info.diff
@@ -0,0 +1,55 @@
+Index: libsylph/procmime.c
+===================================================================
+--- libsylph/procmime.c (revision 2195)
++++ libsylph/procmime.c (working copy)
+@@ -1483,6 +1483,9 @@
+ g_free(dir);
+ mime_type_list = g_list_concat(mime_type_list, list);
+
++ list = procmime_get_mime_type_list(DATADIR "/mime/globs");
++ mime_type_list = g_list_concat(mime_type_list, list);
++
+ if (!mime_type_list) {
+ debug_print("mime.types not found\n");
+ return NULL;
+@@ -1535,7 +1538,7 @@
+ g_strstrip(buf);
+
+ p = buf;
+- while (*p && !g_ascii_isspace(*p)) p++;
++ while (*p && !g_ascii_isspace(*p) && *p != ':') p++;
+ if (*p) {
+ *p = '\0';
+ p++;
+@@ -1548,7 +1551,7 @@
+ mime_type->type = g_strdup(buf);
+ mime_type->sub_type = g_strdup(delim + 1);
+
+- while (*p && g_ascii_isspace(*p)) p++;
++ while (*p && (g_ascii_isspace(*p) || *p == '*' || *p == '.')) p++;
+ if (*p)
+ mime_type->extension = g_strdup(p);
+ else
+@@ -1560,7 +1563,7 @@
+ fclose(fp);
+
+ if (!list)
+- g_warning("Can't read mime.types\n");
++ g_warning("Can't read %s\n", file);
+
+ return list;
+ }
+Index: libsylph/Makefile.am
+===================================================================
+--- libsylph/Makefile.am (revision 2195)
++++ libsylph/Makefile.am (working copy)
+@@ -2,7 +2,8 @@
+ AM_CPPFLAGS = \
+ -DG_LOG_DOMAIN=\"LibSylph\" \
+ -DSYSCONFDIR=\""$(sysconfdir)"\" \
+- -DLOCALEDIR=\""$(localedir)"\"
++ -DLOCALEDIR=\""$(localedir)"\" \
++ -DDATADIR=\""$(datadir)"\"
+
+ INCLUDES = $(GLIB_CFLAGS) -I$(top_srcdir) -I$(includedir)
+
diff --git a/mail-client/sylpheed/sylpheed-2.7.0.ebuild b/mail-client/sylpheed/sylpheed-2.7.0.ebuild
new file mode 100644
index 000000000000..26e081475021
--- /dev/null
+++ b/mail-client/sylpheed/sylpheed-2.7.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/sylpheed-2.7.0.ebuild,v 1.1 2009/07/26 15:14:31 hattya Exp $
+
+inherit autotools eutils
+
+IUSE="crypt ipv6 ldap nls pda spell ssl xface"
+
+DESCRIPTION="A lightweight email client and newsreader"
+HOMEPAGE="http://sylpheed.sraoss.jp/"
+SRC_URI="http://sylpheed.sraoss.jp/${PN}/v${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+
+COMMON_DEPEND=">=x11-libs/gtk+-2.4
+ nls? ( >=sys-devel/gettext-0.12.1 )
+ crypt? ( >=app-crypt/gpgme-1 )
+ ldap? ( net-nds/openldap )
+ pda? ( app-pda/jpilot )
+ spell? ( app-text/gtkspell )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ xface? ( >=media-libs/compface-1.4 )"
+RDEPEND="${COMMON_DEPEND}
+ app-misc/mime-types
+ net-misc/curl
+ x11-misc/shared-mime-info"
+
+AT_M4DIR="ac"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-2.[457]-*.diff
+
+ use crypt || cp ac/missing/gpgme.m4 ac
+
+ eautoreconf
+
+}
+
+src_compile() {
+
+ local htmldir=/usr/share/doc/${PF}/html
+
+ econf \
+ $(use_enable crypt gpgme) \
+ $(use_enable ipv6) \
+ $(use_enable ldap) \
+ $(use_enable pda jpilot) \
+ $(use_enable spell gtkspell) \
+ $(use_enable ssl) \
+ $(use_enable xface compface) \
+ --with-manualdir=${htmldir}/manual \
+ --with-faqdir=${htmldir}/faq \
+ || die
+ emake || die
+
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog* NEWS* README* TODO*
+ doicon *.png
+ domenu *.desktop
+
+}