summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-02-10 11:13:13 +0000
committerTim Harder <radhermit@gentoo.org>2011-02-10 11:13:13 +0000
commit310d8544925027a8b8c2a44e27c3ca1024195989 (patch)
treef10d9239ea31eb2a5dc7b4b414e0f7b4979d588a /mail-client
parentx86 stable wrt bug #352160 (diff)
downloadgentoo-2-310d8544925027a8b8c2a44e27c3ca1024195989.tar.gz
gentoo-2-310d8544925027a8b8c2a44e27c3ca1024195989.tar.bz2
gentoo-2-310d8544925027a8b8c2a44e27c3ca1024195989.zip
Version bump for bug #354331.
(Portage version: 2.2.0_alpha22/cvs/Linux x86_64)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/roundcube/ChangeLog7
-rw-r--r--mail-client/roundcube/roundcube-0.5.1.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/mail-client/roundcube/ChangeLog b/mail-client/roundcube/ChangeLog
index c0520cfeb6ef..8ddad74c6680 100644
--- a/mail-client/roundcube/ChangeLog
+++ b/mail-client/roundcube/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/roundcube
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/ChangeLog,v 1.39 2011/01/12 23:40:37 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/ChangeLog,v 1.40 2011/02/10 11:13:13 radhermit Exp $
+
+*roundcube-0.5.1 (10 Feb 2011)
+
+ 10 Feb 2011; Tim Harder <radhermit@gentoo.org> +roundcube-0.5.1.ebuild:
+ Version bump for bug #354331.
*roundcube-0.5 (12 Jan 2011)
diff --git a/mail-client/roundcube/roundcube-0.5.1.ebuild b/mail-client/roundcube/roundcube-0.5.1.ebuild
new file mode 100644
index 000000000000..ace2c7a96f94
--- /dev/null
+++ b/mail-client/roundcube/roundcube-0.5.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/roundcube-0.5.1.ebuild,v 1.1 2011/02/10 11:13:13 radhermit Exp $
+
+EAPI="2"
+
+inherit webapp depend.php
+
+MY_PN="${PN}mail"
+MY_P="${MY_PN}-${PV/_/-}"
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="http://roundcube.net"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-2 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ldap mysql postgres ssl spell +sqlite"
+
+DEPEND=""
+RDEPEND="|| ( <dev-lang/php-5.3[crypt,iconv,ldap?,pcre,postgres?,session,spl,sqlite?,ssl?,unicode]
+ >=dev-lang/php-5.3[crypt,iconv,ldap?,postgres?,session,sqlite?,ssl?,unicode] )
+ spell? ( dev-lang/php[curl,spell] )
+ dev-php/PEAR-PEAR"
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ use mysql && require_php_with_any_use mysql mysqli
+
+ # add some warnings about optional functionality
+ if ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external; then
+ ewarn "IMAP quota display will not work correctly without GD support in PHP."
+ ewarn "Recompile PHP with either gd or gd-external in USE if you want this feature."
+ ewarn
+ fi
+}
+
+src_prepare() {
+ cp config/db.inc.php{.dist,}
+ cp config/main.inc.php{.dist,}
+}
+
+src_install() {
+ webapp_src_preinst
+ dodoc CHANGELOG INSTALL README UPGRADING
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/{db,main}.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en UPGRADING
+ webapp_src_install
+}