summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2009-09-17 15:12:57 +0000
committerBenedikt Boehm <hollow@gentoo.org>2009-09-17 15:12:57 +0000
commit2c27d09c3ba86f433a3cedcc2116d8e970705740 (patch)
treebb04b5fc01043abc5c2d5979ce4ff2be9c4583c8 /mail-client
parentSupport more versions of sys-libs/db (bug #275329). (diff)
downloadgentoo-2-2c27d09c3ba86f433a3cedcc2116d8e970705740.tar.gz
gentoo-2-2c27d09c3ba86f433a3cedcc2116d8e970705740.tar.bz2
gentoo-2-2c27d09c3ba86f433a3cedcc2116d8e970705740.zip
convert most of the USE flag mess to EAPI2
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/roundcube/ChangeLog5
-rw-r--r--mail-client/roundcube/roundcube-0.3.ebuild38
2 files changed, 13 insertions, 30 deletions
diff --git a/mail-client/roundcube/ChangeLog b/mail-client/roundcube/ChangeLog
index 2c39810ceb1e..da739c806ab2 100644
--- a/mail-client/roundcube/ChangeLog
+++ b/mail-client/roundcube/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for mail-client/roundcube
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/ChangeLog,v 1.9 2009/09/17 14:46:36 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/ChangeLog,v 1.10 2009/09/17 15:12:57 hollow Exp $
+
+ 17 Sep 2009; Benedikt Böhm <hollow@gentoo.org> roundcube-0.3.ebuild:
+ convert most of the USE flag mess to EAPI2
17 Sep 2009; Benedikt Böhm <hollow@gentoo.org> roundcube-0.2.2.ebuild,
roundcube-0.3.ebuild:
diff --git a/mail-client/roundcube/roundcube-0.3.ebuild b/mail-client/roundcube/roundcube-0.3.ebuild
index 26a93d27d10e..ef2e43fa1478 100644
--- a/mail-client/roundcube/roundcube-0.3.ebuild
+++ b/mail-client/roundcube/roundcube-0.3.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/roundcube-0.3.ebuild,v 1.3 2009/09/17 14:46:36 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/roundcube-0.3.ebuild,v 1.4 2009/09/17 15:12:57 hollow Exp $
EAPI="2"
MY_PN="${PN}mail"
MY_P="${MY_PN}-${PV}-stable"
-inherit eutils webapp depend.php depend.apache
+inherit confutils webapp depend.php depend.apache
DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
HOMEPAGE="http://roundcube.net"
@@ -17,10 +17,10 @@ SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
# for bundled PEAR components, googiespell and utf8.class.php
LICENSE="GPL-2 BSD PHP-2.02 PHP-3 MIT public-domain"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="ldap mysql postgres sqlite ssl spell"
+IUSE="ldap mysql postgres +sqlite +ssl spell"
DEPEND=""
-RDEPEND="
+RDEPEND="dev-lang/php[crypt,iconv,ldap?,pcre,postgres?,session,spl,ssl?,sqlite?,unicode]
spell? ( dev-lang/php[curl,spell] )
dev-php/PEAR-PEAR
"
@@ -31,32 +31,11 @@ need_php_httpd
S=${WORKDIR}/${MY_P}
pkg_setup() {
- local flags="crypt iconv pcre session unicode spl"
- use ldap && flags="${flags} ldap"
- use ssl && flags="${flags} ssl"
- use spell && flags="${flags} curl spell"
-
- # check for required PHP features
- if ! use mysql && ! use postgres && ! use sqlite ; then
- local dbflags="mysql mysqli postgres sqlite"
- if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} || \
- ! PHPCHECKNODIE="yes" require_php_with_any_use ${dbflags} ; then
- die "Re-install ${PHP_PKG} with ${flags} and at least one of ${dbflags} in USE."
- fi
- else
- for db in postgres sqlite ; do
- use ${db} && flags="${flags} ${db}"
- done
- if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} || \
- ( use mysql && ! PHPCHECKNODIE="yes" require_php_with_any_use mysql mysqli ) ; then
- local diemsg="Re-install ${PHP_PKG} with ${flags}"
- use mysql && diemsg="${diemsg} and at least one of mysql mysqli"
- die "${diemsg} in USE"
- fi
- fi
+ confutils_require_any mysql postgres sqlite
+ use mysql && require_php_with_any_use mysql mysqli
# add some warnings about optional functionality
- if ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
+ if ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external; then
ewarn "IMAP quota display will not work correctly without GD support in PHP."
ewarn "Recompile PHP with either gd or gd-external in USE if you want this feature."
ewarn
@@ -74,7 +53,8 @@ src_install () {
webapp_src_preinst
dodoc CHANGELOG INSTALL README UPGRADING
- cp -R [[:lower:]]* SQL "${D}/${MY_HTDOCSDIR}"
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
webapp_serverowned "${MY_HTDOCSDIR}"/logs
webapp_serverowned "${MY_HTDOCSDIR}"/temp