summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2006-06-25 04:16:35 +0000
committerMarius Mauch <genone@gentoo.org>2006-06-25 04:16:35 +0000
commit1956e5da89bd5629fd2d9e51329c9c2b39ce77fc (patch)
tree7982f9f02703f67af903ea5a2070d86107002f8a /mail-client
parentVersion bump (diff)
downloadgentoo-2-1956e5da89bd5629fd2d9e51329c9c2b39ce77fc.tar.gz
gentoo-2-1956e5da89bd5629fd2d9e51329c9c2b39ce77fc.tar.bz2
gentoo-2-1956e5da89bd5629fd2d9e51329c9c2b39ce77fc.zip
Version bump
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/sylpheed-claws-perl/ChangeLog8
-rw-r--r--mail-client/sylpheed-claws-perl/files/digest-sylpheed-claws-perl-0.9.43
-rw-r--r--mail-client/sylpheed-claws-perl/sylpheed-claws-perl-0.9.4.ebuild49
3 files changed, 59 insertions, 1 deletions
diff --git a/mail-client/sylpheed-claws-perl/ChangeLog b/mail-client/sylpheed-claws-perl/ChangeLog
index 7e2f50664818..fbc275338a67 100644
--- a/mail-client/sylpheed-claws-perl/ChangeLog
+++ b/mail-client/sylpheed-claws-perl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/sylpheed-claws-perl
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-perl/ChangeLog,v 1.7 2006/05/19 18:33:03 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-perl/ChangeLog,v 1.8 2006/06/25 04:16:35 genone Exp $
+
+*sylpheed-claws-perl-0.9.4 (25 Jun 2006)
+
+ 25 Jun 2006; Marius Mauch <genone@gentoo.org>
+ +sylpheed-claws-perl-0.9.4.ebuild:
+ Version bump
19 May 2006; Markus Rothe <corsair@gentoo.org>
sylpheed-claws-perl-0.9.ebuild:
diff --git a/mail-client/sylpheed-claws-perl/files/digest-sylpheed-claws-perl-0.9.4 b/mail-client/sylpheed-claws-perl/files/digest-sylpheed-claws-perl-0.9.4
new file mode 100644
index 000000000000..60b313a1234c
--- /dev/null
+++ b/mail-client/sylpheed-claws-perl/files/digest-sylpheed-claws-perl-0.9.4
@@ -0,0 +1,3 @@
+MD5 06b53d69913ea1c96fb154fa2686606a sylpheed-claws-extra-plugins-2.3.0.tar.bz2 3901667
+RMD160 64f026271d993de2c5895c251abf18c529b0244d sylpheed-claws-extra-plugins-2.3.0.tar.bz2 3901667
+SHA256 45e30623f3908577518a474a2f308453654d1f6422a2f15ff27ec4fb934aa438 sylpheed-claws-extra-plugins-2.3.0.tar.bz2 3901667
diff --git a/mail-client/sylpheed-claws-perl/sylpheed-claws-perl-0.9.4.ebuild b/mail-client/sylpheed-claws-perl/sylpheed-claws-perl-0.9.4.ebuild
new file mode 100644
index 000000000000..7cc0a860eed9
--- /dev/null
+++ b/mail-client/sylpheed-claws-perl/sylpheed-claws-perl-0.9.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-perl/sylpheed-claws-perl-0.9.4.ebuild,v 1.1 2006/06/25 04:16:35 genone Exp $
+
+MY_P="${P##sylpheed-claws-}"
+MY_PN="${PN##sylpheed-claws-}"
+SC_BASE="2.3.0"
+SC_BASE_NAME="sylpheed-claws-extra-plugins-${SC_BASE}"
+
+DESCRIPTION="Plugin for sylpheed-claws to use perl to write filtering rules"
+HOMEPAGE="http://claws.sylpheed.org"
+SRC_URI="mirror://sourceforge/sylpheed-claws/${SC_BASE_NAME}.tar.bz2"
+#SRC_URI="http://claws.sylpheed.org/downloads/${MY_PN}_plugin-${PV}_gtk2.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+DEPEND=">=mail-client/sylpheed-claws-${SC_BASE}
+ dev-lang/perl"
+
+S="${WORKDIR}/${SC_BASE_NAME}/${MY_PN}_plugin-${PV}"
+
+src_compile() {
+ econf || die
+ emake || die
+
+ pod2man --section=1 --release=${PV} --name=sc_perl sc_perl.pod > sc_perl.1
+
+ cd tools
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+
+ doman sc_perl.1
+
+ cd tools
+ exeinto /usr/lib/sylpheed-claws/tools
+ doexe *.pl
+
+ rm -f ${D}/usr/lib*/sylpheed-claws/plugins/*.{a,la}
+}
+
+pkg_postinst() {
+ einfo "The documentation for this plugin is contained in a manpage."
+ einfo "You can access it with 'man sc_perl'"
+}